summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2013-02-10 11:06:44 +0000
committerTim Harder <radhermit@gentoo.org>2013-02-10 11:06:44 +0000
commit49004046943a7f6421e1f181d43a43a2f766b0ab (patch)
treecce7a6d5c7e3d02a3c314c7e8eb8d1d118b355ca /dev-python/graph-tool
parentRev bump to push out root fix, bug #456384 (diff)
downloadgentoo-2-49004046943a7f6421e1f181d43a43a2f766b0ab.tar.gz
gentoo-2-49004046943a7f6421e1f181d43a43a2f766b0ab.tar.bz2
gentoo-2-49004046943a7f6421e1f181d43a43a2f766b0ab.zip
Add more PYTHON_USEDEP coverage on recently converted deps and drop python3 support until sci herd reinstates it for scipy (fixes bug #456188).
(Portage version: 2.2.0_alpha161/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'dev-python/graph-tool')
-rw-r--r--dev-python/graph-tool/ChangeLog7
-rw-r--r--dev-python/graph-tool/graph-tool-2.2.21.ebuild13
-rw-r--r--dev-python/graph-tool/graph-tool-9999.ebuild13
3 files changed, 20 insertions, 13 deletions
diff --git a/dev-python/graph-tool/ChangeLog b/dev-python/graph-tool/ChangeLog
index 0628426f04c7..af1a952fe37e 100644
--- a/dev-python/graph-tool/ChangeLog
+++ b/dev-python/graph-tool/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/graph-tool
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/graph-tool/ChangeLog,v 1.4 2013/01/31 09:30:05 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/graph-tool/ChangeLog,v 1.5 2013/02/10 11:06:44 radhermit Exp $
+
+ 10 Feb 2013; Tim Harder <radhermit@gentoo.org> graph-tool-2.2.21.ebuild,
+ graph-tool-9999.ebuild:
+ Add more PYTHON_USEDEP coverage on recently converted deps and drop python3
+ support until sci herd reinstates it for scipy (fixes bug #456188).
31 Jan 2013; Tim Harder <radhermit@gentoo.org> graph-tool-2.2.21.ebuild,
graph-tool-9999.ebuild:
diff --git a/dev-python/graph-tool/graph-tool-2.2.21.ebuild b/dev-python/graph-tool/graph-tool-2.2.21.ebuild
index e58cd8e23272..8e6014345f48 100644
--- a/dev-python/graph-tool/graph-tool-2.2.21.ebuild
+++ b/dev-python/graph-tool/graph-tool-2.2.21.ebuild
@@ -1,9 +1,10 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/graph-tool/graph-tool-2.2.21.ebuild,v 1.2 2013/01/31 09:30:05 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/graph-tool/graph-tool-2.2.21.ebuild,v 1.3 2013/02/10 11:06:44 radhermit Exp $
EAPI=5
-PYTHON_COMPAT=( python{2_7,3_1,3_2,3_3} )
+# python3 dropped until scipy reinstates support
+PYTHON_COMPAT=( python2_7 )
inherit check-reqs eutils toolchain-funcs python-r1
@@ -24,15 +25,15 @@ IUSE="+cairo openmp"
CDEPEND=">=dev-libs/boost-1.46.0[python]
dev-libs/expat
- dev-python/numpy
- sci-libs/scipy
+ dev-python/numpy[${PYTHON_USEDEP}]
+ sci-libs/scipy[${PYTHON_USEDEP}]
sci-mathematics/cgal
cairo? (
dev-cpp/cairomm
- dev-python/pycairo
+ dev-python/pycairo[${PYTHON_USEDEP}]
)"
RDEPEND="${CDEPEND}
- dev-python/matplotlib
+ dev-python/matplotlib[${PYTHON_USEDEP}]
media-gfx/graphviz[python]"
DEPEND="${CDEPEND}
dev-cpp/sparsehash
diff --git a/dev-python/graph-tool/graph-tool-9999.ebuild b/dev-python/graph-tool/graph-tool-9999.ebuild
index 7cfbcec7ba29..e77574845477 100644
--- a/dev-python/graph-tool/graph-tool-9999.ebuild
+++ b/dev-python/graph-tool/graph-tool-9999.ebuild
@@ -1,9 +1,10 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/graph-tool/graph-tool-9999.ebuild,v 1.3 2013/01/31 09:30:05 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/graph-tool/graph-tool-9999.ebuild,v 1.4 2013/02/10 11:06:44 radhermit Exp $
EAPI=5
-PYTHON_COMPAT=( python{2_7,3_1,3_2,3_3} )
+# python3 dropped until scipy reinstates support
+PYTHON_COMPAT=( python2_7 )
inherit check-reqs eutils toolchain-funcs python-r1
@@ -24,15 +25,15 @@ IUSE="+cairo openmp"
CDEPEND=">=dev-libs/boost-1.46.0[python]
dev-libs/expat
- dev-python/numpy
- sci-libs/scipy
+ dev-python/numpy[${PYTHON_USEDEP}]
+ sci-libs/scipy[${PYTHON_USEDEP}]
sci-mathematics/cgal
cairo? (
dev-cpp/cairomm
- dev-python/pycairo
+ dev-python/pycairo[${PYTHON_USEDEP}]
)"
RDEPEND="${CDEPEND}
- dev-python/matplotlib
+ dev-python/matplotlib[${PYTHON_USEDEP}]
media-gfx/graphviz[python]"
DEPEND="${CDEPEND}
dev-cpp/sparsehash