summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMagnus Granberg <zorry@gentoo.org>2011-08-27 14:24:18 +0000
committerMagnus Granberg <zorry@gentoo.org>2011-08-27 14:24:18 +0000
commitddc2edd1000c804842d4aefa94b5e02e13f4b66e (patch)
treec62e30f835e760c1abdb984f5f142c993179b671 /dev-python/git-python
parentAdd grub2 kcm module for in-kde configuration. (diff)
downloadgentoo-2-ddc2edd1000c804842d4aefa94b5e02e13f4b66e.tar.gz
gentoo-2-ddc2edd1000c804842d4aefa94b5e02e13f4b66e.tar.bz2
gentoo-2-ddc2edd1000c804842d4aefa94b5e02e13f4b66e.zip
Add newer build of git-python
(Portage version: 2.1.10.11/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/git-python')
-rw-r--r--dev-python/git-python/ChangeLog9
-rw-r--r--dev-python/git-python/git-python-0.3.2_rc1.ebuild31
2 files changed, 38 insertions, 2 deletions
diff --git a/dev-python/git-python/ChangeLog b/dev-python/git-python/ChangeLog
index ee57ce47fe6d..fd707c744d69 100644
--- a/dev-python/git-python/ChangeLog
+++ b/dev-python/git-python/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/git-python
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/git-python/ChangeLog,v 1.6 2010/07/15 17:16:50 jlec Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/git-python/ChangeLog,v 1.7 2011/08/27 14:24:18 zorry Exp $
+
+*git-python-0.3.2_rc1 (27 Aug 2011)
+
+ 27 Aug 2011; Magnus Granberg <zorry@gentoo.org> +git-python-0.3.2_rc1.ebuild:
+ Newer version of git-python
15 Jul 2010; Justin Lecher <jlec@gentoo.org> git-python-0.1.7.ebuild:
Keyworded for *-linux prefix, tested by me
diff --git a/dev-python/git-python/git-python-0.3.2_rc1.ebuild b/dev-python/git-python/git-python-0.3.2_rc1.ebuild
new file mode 100644
index 000000000000..5bfd7a004c98
--- /dev/null
+++ b/dev-python/git-python/git-python-0.3.2_rc1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/git-python/git-python-0.3.2_rc1.ebuild,v 1.1 2011/08/27 14:24:18 zorry Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils
+
+MY_PN="GitPython"
+MY_PV=${PV/_rc/.RC}
+MY_P="${MY_PN}-${MY_PV}"
+
+DESCRIPTION="GitPython is a python library used to interact with Git repositories."
+HOMEPAGE="http://gitorious.org/git-python http://pypi.python.org/pypi/GitPython"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="dev-vcs/git"
+DEPEND="${RDEPEND}
+ dev-python/setuptools"
+RESTRICT_PYTHON_ABIS="3.*"
+
+S="${WORKDIR}/${MY_P}"
+
+PYTHON_MODNAME="git"