summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2014-08-12 05:12:05 +0000
committerMike Frysinger <vapier@gentoo.org>2014-08-12 05:12:05 +0000
commit3c86ff7753d2c25c41092bca15f9ddba2366cb17 (patch)
tree6156d8d88813eb4a66d3570282cf9ecda71064da /dev-python/gcs-oauth2-boto-plugin
parentAdd support for running tests #519118 by Anthony Ryan. (diff)
downloadgentoo-2-3c86ff7753d2c25c41092bca15f9ddba2366cb17.tar.gz
gentoo-2-3c86ff7753d2c25c41092bca15f9ddba2366cb17.tar.bz2
gentoo-2-3c86ff7753d2c25c41092bca15f9ddba2366cb17.zip
New package required by newer gsutil #516026 by Bruno Ricci.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key D2E96200)
Diffstat (limited to 'dev-python/gcs-oauth2-boto-plugin')
-rw-r--r--dev-python/gcs-oauth2-boto-plugin/ChangeLog10
-rw-r--r--dev-python/gcs-oauth2-boto-plugin/files/gcs-oauth2-boto-plugin-1.7-use-friendy-version-checks.patch13
-rw-r--r--dev-python/gcs-oauth2-boto-plugin/gcs-oauth2-boto-plugin-1.7.ebuild33
-rw-r--r--dev-python/gcs-oauth2-boto-plugin/metadata.xml5
4 files changed, 61 insertions, 0 deletions
diff --git a/dev-python/gcs-oauth2-boto-plugin/ChangeLog b/dev-python/gcs-oauth2-boto-plugin/ChangeLog
new file mode 100644
index 000000000000..303f630c9616
--- /dev/null
+++ b/dev-python/gcs-oauth2-boto-plugin/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-python/gcs-oauth2-boto-plugin
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/gcs-oauth2-boto-plugin/ChangeLog,v 1.1 2014/08/12 05:12:05 vapier Exp $
+
+*gcs-oauth2-boto-plugin-1.7 (12 Aug 2014)
+
+ 12 Aug 2014; Mike Frysinger <vapier@gentoo.org>
+ +files/gcs-oauth2-boto-plugin-1.7-use-friendy-version-checks.patch,
+ +gcs-oauth2-boto-plugin-1.7.ebuild, +metadata.xml:
+ New package required by newer gsutil #516026 by Bruno Ricci.
diff --git a/dev-python/gcs-oauth2-boto-plugin/files/gcs-oauth2-boto-plugin-1.7-use-friendy-version-checks.patch b/dev-python/gcs-oauth2-boto-plugin/files/gcs-oauth2-boto-plugin-1.7-use-friendy-version-checks.patch
new file mode 100644
index 000000000000..665b1c4f01bb
--- /dev/null
+++ b/dev-python/gcs-oauth2-boto-plugin/files/gcs-oauth2-boto-plugin-1.7-use-friendy-version-checks.patch
@@ -0,0 +1,13 @@
+--- a/setup.py
++++ b/setup.py
+@@ -36,9 +36,7 @@ requires = [
+ 'python-gflags>=2.0',
+ 'google-api-python-client>=1.1',
+ 'pyOpenSSL>=0.13',
+- # Not using 1.02 because of:
+- # https://code.google.com/p/socksipy-branch/issues/detail?id=3
+- 'SocksiPy-branch==1.01',
++ 'SocksiPy-branch>=1.01',
+ 'retry_decorator>=1.0.0',
+ ]
+
diff --git a/dev-python/gcs-oauth2-boto-plugin/gcs-oauth2-boto-plugin-1.7.ebuild b/dev-python/gcs-oauth2-boto-plugin/gcs-oauth2-boto-plugin-1.7.ebuild
new file mode 100644
index 000000000000..b44605b00a86
--- /dev/null
+++ b/dev-python/gcs-oauth2-boto-plugin/gcs-oauth2-boto-plugin-1.7.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/gcs-oauth2-boto-plugin/gcs-oauth2-boto-plugin-1.7.ebuild,v 1.1 2014/08/12 05:12:05 vapier Exp $
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="auth plugin allowing use the use of OAuth 2.0 credentials for Google Cloud Storage in the Boto library"
+HOMEPAGE="https://pypi.python.org/pypi/gcs-oauth2-boto-plugin"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+PATCHES=(
+ "${FILESDIR}/${P}-use-friendy-version-checks.patch"
+)
+
+# Keep versions in sync with setup.py.
+RDEPEND="${PYTHON_DEPS}"
+DEPEND="${RDEPEND}
+ >=dev-python/boto-2.29.1[${PYTHON_USEDEP}]
+ >=dev-python/httplib2-0.8[${PYTHON_USEDEP}]
+ >=dev-python/pyopenssl-0.13[${PYTHON_USEDEP}]
+ >=dev-python/google-api-python-client-1.1[${PYTHON_USEDEP}]
+ >=dev-python/python-gflags-2.0[${PYTHON_USEDEP}]
+ >=dev-python/retry-decorator-1.0.0[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/socksipy-1.01[${PYTHON_USEDEP}]"
diff --git a/dev-python/gcs-oauth2-boto-plugin/metadata.xml b/dev-python/gcs-oauth2-boto-plugin/metadata.xml
new file mode 100644
index 000000000000..de483c53568f
--- /dev/null
+++ b/dev-python/gcs-oauth2-boto-plugin/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>python</herd>
+</pkgmetadata>