summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2013-06-09 16:36:06 +0000
committerIan Delaney <idella4@gentoo.org>2013-06-09 16:36:06 +0000
commit7048c44c7e59a3e20567d8c3befad5af026562d7 (patch)
tree901839b73be1c88caf5b27d57869233d27e0e6c3 /dev-python/flask-login
parentReassigning due to Zlogene became Gentoo developer, remove proxy maintainers ... (diff)
downloadgentoo-2-7048c44c7e59a3e20567d8c3befad5af026562d7.tar.gz
gentoo-2-7048c44c7e59a3e20567d8c3befad5af026562d7.tar.bz2
gentoo-2-7048c44c7e59a3e20567d8c3befad5af026562d7.zip
revbump, migrate -> distutils-r1, drop old
(Portage version: 2.1.11.63/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/flask-login')
-rw-r--r--dev-python/flask-login/ChangeLog9
-rw-r--r--dev-python/flask-login/flask-login-0.1.3-r1.ebuild26
-rw-r--r--dev-python/flask-login/flask-login-0.1.3.ebuild53
3 files changed, 33 insertions, 55 deletions
diff --git a/dev-python/flask-login/ChangeLog b/dev-python/flask-login/ChangeLog
index d1080f030f0d..564437b30a92 100644
--- a/dev-python/flask-login/ChangeLog
+++ b/dev-python/flask-login/ChangeLog
@@ -1,7 +1,12 @@
# ChangeLog for dev-python/flask-login
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/flask-login/ChangeLog,v 1.2 2013/01/13 19:02:40 zx2c4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/flask-login/ChangeLog,v 1.3 2013/06/09 16:36:06 idella4 Exp $
+
+*flask-login-0.1.3-r1 (09 Jun 2013)
+
+ 09 Jun 2013; Ian Delaney <idella4@gentoo.org> +flask-login-0.1.3-r1.ebuild,
+ -flask-login-0.1.3.ebuild:
+ revbump, migrate -> distutils-r1, drop old
13 Jan 2013; Jason A. Donenfeld <zx2c4@gentoo.org> Manifest:
Initial import.
-
diff --git a/dev-python/flask-login/flask-login-0.1.3-r1.ebuild b/dev-python/flask-login/flask-login-0.1.3-r1.ebuild
new file mode 100644
index 000000000000..5e884ab6297a
--- /dev/null
+++ b/dev-python/flask-login/flask-login-0.1.3-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/flask-login/flask-login-0.1.3-r1.ebuild,v 1.1 2013/06/09 16:36:06 idella4 Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_5,2_6,2_7} pypy2_0 )
+
+inherit distutils-r1
+
+MY_PN="Flask-Login"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Login session support for Flask"
+HOMEPAGE="http://pypi.python.org/pypi/Flask-Login"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-python/flask-0.3[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}/${MY_P}"
diff --git a/dev-python/flask-login/flask-login-0.1.3.ebuild b/dev-python/flask-login/flask-login-0.1.3.ebuild
deleted file mode 100644
index 50d968be90b6..000000000000
--- a/dev-python/flask-login/flask-login-0.1.3.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/flask-login/flask-login-0.1.3.ebuild,v 1.1 2013/01/08 22:21:55 zx2c4 Exp $
-
-EAPI="3"
-PYTHON_DEPEND="2:2.5"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="2.4 3.*"
-
-inherit distutils
-
-MY_PN="Flask-Login"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Login session support for Flask"
-HOMEPAGE="http://pypi.python.org/pypi/Flask-Login"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc examples"
-
-RDEPEND=">=dev-python/flask-0.3"
-DEPEND="${RDEPEND}
- dev-python/setuptools"
-
-S="${WORKDIR}/${MY_P}"
-
-PYTHON_MODNAME="flask_login.py"
-
-src_compile() {
- distutils_src_compile
-
- if use doc; then
- einfo "Generation of documentation"
- cd docs
- PYTHONPATH=".." emake html || die "Generation of documentation failed"
- fi
-}
-
-src_install() {
- distutils_src_install
-
- if use doc; then
- dohtml -r docs/_build/html/* || die "Installation of documentation failed"
- fi
-
- if use examples; then
- insinto /usr/share/doc/${PF}
- doins -r example || die "Installation of examples failed"
- fi
-}