summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2013-12-11 16:18:21 +0000
committerMatthew Thode <prometheanfire@gentoo.org>2013-12-11 16:18:21 +0000
commitb1e7b014d5dd360b48f0f49ae1344f269be9df65 (patch)
tree845565a36f308f10d357a53c4bfe267cec801de8 /dev-python/fixtures
parentupdate maintainer (diff)
downloadgentoo-2-b1e7b014d5dd360b48f0f49ae1344f269be9df65.tar.gz
gentoo-2-b1e7b014d5dd360b48f0f49ae1344f269be9df65.tar.bz2
gentoo-2-b1e7b014d5dd360b48f0f49ae1344f269be9df65.zip
fixtures-0.3.14-r1 for bug 493926
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0x2471eb3e40ac5ac3)
Diffstat (limited to 'dev-python/fixtures')
-rw-r--r--dev-python/fixtures/ChangeLog8
-rw-r--r--dev-python/fixtures/fixtures-0.3.14-r1.ebuild31
2 files changed, 38 insertions, 1 deletions
diff --git a/dev-python/fixtures/ChangeLog b/dev-python/fixtures/ChangeLog
index cf8166c599a8..781dbb6b30da 100644
--- a/dev-python/fixtures/ChangeLog
+++ b/dev-python/fixtures/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/fixtures
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/fixtures/ChangeLog,v 1.6 2013/09/26 00:43:09 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/fixtures/ChangeLog,v 1.7 2013/12/11 16:18:21 prometheanfire Exp $
+
+*fixtures-0.3.14-r1 (11 Dec 2013)
+
+ 11 Dec 2013; Matthew Thode <prometheanfire@gentoo.org>
+ +fixtures-0.3.14-r1.ebuild:
+ fixtures-0.3.14-r1 for bug 493926
*fixtures-0.3.14 (26 Sep 2013)
diff --git a/dev-python/fixtures/fixtures-0.3.14-r1.ebuild b/dev-python/fixtures/fixtures-0.3.14-r1.ebuild
new file mode 100644
index 000000000000..b1a5fa780a12
--- /dev/null
+++ b/dev-python/fixtures/fixtures-0.3.14-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/fixtures/fixtures-0.3.14-r1.ebuild,v 1.1 2013/12/11 16:18:21 prometheanfire Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} pypy2_0 )
+
+inherit distutils-r1
+
+DESCRIPTION="Fixtures, reusable state for writing clean tests and more."
+HOMEPAGE="https://launchpad.net/python-fixtures https://pypi.python.org/pypi/fixtures"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="|| ( Apache-2.0 BSD )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+# nose not listed but provides coverage output of tests
+# run of test files by python lacks any output except on fail
+DEPEND="test? ( dev-python/nose[${PYTHON_USEDEP}]
+ >=dev-python/testtools-0.9.22[${PYTHON_USEDEP}]
+ dev-python/extras[${PYTHON_USEDEP}] )"
+RDEPEND=">=dev-python/testtools-0.9.22"
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_test() {
+ pushd "${BUILD_DIR}"/ > /dev/null
+ ln -sf ../README .
+ nosetests lib/${PN}/tests/test_*.py || die "Tests failed under ${EPYTHON}"
+}