summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-01-30 17:58:55 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-01-30 17:58:55 +0000
commit58bb22223674418ae08c06d3de45d8c60571b2e3 (patch)
tree97424146b0d3a59bc48094b68aebaacc38ba38d9 /dev-python/envisageplugins
parentDelete older ebuild. (diff)
downloadgentoo-2-58bb22223674418ae08c06d3de45d8c60571b2e3.tar.gz
gentoo-2-58bb22223674418ae08c06d3de45d8c60571b2e3.tar.bz2
gentoo-2-58bb22223674418ae08c06d3de45d8c60571b2e3.zip
Version bump.
(Portage version: 2.2.0_alpha19_p24/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/envisageplugins')
-rw-r--r--dev-python/envisageplugins/ChangeLog10
-rw-r--r--dev-python/envisageplugins/envisageplugins-3.2.0.ebuild53
2 files changed, 61 insertions, 2 deletions
diff --git a/dev-python/envisageplugins/ChangeLog b/dev-python/envisageplugins/ChangeLog
index f98d4b6c2954..940fd511fe47 100644
--- a/dev-python/envisageplugins/ChangeLog
+++ b/dev-python/envisageplugins/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/envisageplugins
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/envisageplugins/ChangeLog,v 1.8 2010/10/18 14:38:00 arfrever Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/envisageplugins/ChangeLog,v 1.9 2011/01/30 17:58:55 arfrever Exp $
+
+*envisageplugins-3.2.0 (30 Jan 2011)
+
+ 30 Jan 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ -envisageplugins-3.1.3.ebuild, +envisageplugins-3.2.0.ebuild:
+ Version bump.
*envisageplugins-3.1.3 (18 Oct 2010)
diff --git a/dev-python/envisageplugins/envisageplugins-3.2.0.ebuild b/dev-python/envisageplugins/envisageplugins-3.2.0.ebuild
new file mode 100644
index 000000000000..d309e7a98027
--- /dev/null
+++ b/dev-python/envisageplugins/envisageplugins-3.2.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/envisageplugins/envisageplugins-3.2.0.ebuild,v 1.1 2011/01/30 17:58:55 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython"
+DISTUTILS_SRC_TEST="setup.py"
+
+inherit distutils virtualx
+
+MY_PN="EnvisagePlugins"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Enthought Tool Suite: Plug-ins for the Envisage framework"
+HOMEPAGE="http://code.enthought.com/projects/envisage_plugins.php http://pypi.python.org/pypi/EnvisagePlugins"
+SRC_URI="http://www.enthought.com/repo/ETS/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples test"
+
+RDEPEND=">=dev-python/envisagecore-3.2.0
+ >=dev-python/traitsgui-3.6.0"
+DEPEND="${RDEPEND}
+ dev-python/setuptools
+ test? (
+ dev-python/coverage
+ dev-python/nose
+ media-fonts/font-cursor-misc
+ media-fonts/font-misc-misc
+ x11-apps/xhost
+ )"
+
+S="${WORKDIR}/${MY_P}"
+
+PYTHON_MODNAME="enthought"
+
+src_test() {
+ maketype="distutils_src_test" virtualmake
+}
+
+src_install() {
+ find -name "*LICENSE.txt" -delete
+ distutils_src_install
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins -r examples/* || die "Installation of examples failed"
+ fi
+}