summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2014-04-24 05:06:23 +0000
committerTim Harder <radhermit@gentoo.org>2014-04-24 05:06:23 +0000
commit6487f7698ea279c1a7897319a4b541a9bd1c4a6c (patch)
treeab881fa7c29e3baacd50edee8fb770b1d4a5e97d /dev-python/dugong
parentRevbump with ebuild by Fabio Rossi (bug 457830). (diff)
downloadgentoo-2-6487f7698ea279c1a7897319a4b541a9bd1c4a6c.tar.gz
gentoo-2-6487f7698ea279c1a7897319a4b541a9bd1c4a6c.tar.bz2
gentoo-2-6487f7698ea279c1a7897319a4b541a9bd1c4a6c.zip
Version bump, add python3_4 support.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'dev-python/dugong')
-rw-r--r--dev-python/dugong/ChangeLog7
-rw-r--r--dev-python/dugong/dugong-3.0.ebuild30
2 files changed, 36 insertions, 1 deletions
diff --git a/dev-python/dugong/ChangeLog b/dev-python/dugong/ChangeLog
index eea8f5441ecc..d46923a89d60 100644
--- a/dev-python/dugong/ChangeLog
+++ b/dev-python/dugong/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/dugong
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/dugong/ChangeLog,v 1.1 2014/03/17 09:03:32 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/dugong/ChangeLog,v 1.2 2014/04/24 05:06:23 radhermit Exp $
+
+*dugong-3.0 (24 Apr 2014)
+
+ 24 Apr 2014; Tim Harder <radhermit@gentoo.org> +dugong-3.0.ebuild:
+ Version bump, add python3_4 support.
*dugong-2.2 (17 Mar 2014)
diff --git a/dev-python/dugong/dugong-3.0.ebuild b/dev-python/dugong/dugong-3.0.ebuild
new file mode 100644
index 000000000000..b8bcf185c6e0
--- /dev/null
+++ b/dev-python/dugong/dugong-3.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/dugong/dugong-3.0.ebuild,v 1.1 2014/04/24 05:06:23 radhermit Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python3_{3,4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python library for communicating with HTTP 1.1 servers"
+HOMEPAGE="https://bitbucket.org/nikratio/python-dugong/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+python_test() {
+ py.test -v || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/html/. )
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}