summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2008-02-24 17:53:32 +0000
committerTiziano Müller <dev-zero@gentoo.org>2008-02-24 17:53:32 +0000
commita0e2eb5c1a17243e4fef33e5d47756b6ffe2c75b (patch)
tree9dd021598a80f0d6c8b6931ce903f8db8007a6b1 /dev-python/drpython
parentMarking lyx-1.4.4 ppc64 for bug 209465 (diff)
downloadgentoo-2-a0e2eb5c1a17243e4fef33e5d47756b6ffe2c75b.tar.gz
gentoo-2-a0e2eb5c1a17243e4fef33e5d47756b6ffe2c75b.tar.bz2
gentoo-2-a0e2eb5c1a17243e4fef33e5d47756b6ffe2c75b.zip
Added patch to fix broken copy/paste when switching tabs using the keyboard shortcut (bug #210298, thanks to Jon White).
(Portage version: 2.1.4.4)
Diffstat (limited to 'dev-python/drpython')
-rw-r--r--dev-python/drpython/ChangeLog12
-rw-r--r--dev-python/drpython/drpython-165-r2.ebuild (renamed from dev-python/drpython/drpython-165-r1.ebuild)24
-rw-r--r--dev-python/drpython/files/drpython-165-tabswitch.patch12
3 files changed, 36 insertions, 12 deletions
diff --git a/dev-python/drpython/ChangeLog b/dev-python/drpython/ChangeLog
index c5b1228306c9..3c76f4e4efb0 100644
--- a/dev-python/drpython/ChangeLog
+++ b/dev-python/drpython/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-python/drpython
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/drpython/ChangeLog,v 1.15 2007/12/04 07:51:55 hawking Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/drpython/ChangeLog,v 1.16 2008/02/24 17:53:32 dev-zero Exp $
+
+*drpython-165-r2 (24 Feb 2008)
+
+ 24 Feb 2008; Tiziano Müller <dev-zero@gentoo.org>
+ +files/drpython-165-tabswitch.patch, -drpython-165-r1.ebuild,
+ +drpython-165-r2.ebuild:
+ Added patch to fix broken copy/paste when switching tabs using the keyboard
+ shortcut (bug #210298, thanks to Jon White).
*drpython-165-r1 (04 Dec 2007)
diff --git a/dev-python/drpython/drpython-165-r1.ebuild b/dev-python/drpython/drpython-165-r2.ebuild
index 705ea960faab..e364557580f8 100644
--- a/dev-python/drpython/drpython-165-r1.ebuild
+++ b/dev-python/drpython/drpython-165-r2.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/drpython/drpython-165-r1.ebuild,v 1.1 2007/12/04 07:51:55 hawking Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/drpython/drpython-165-r2.ebuild,v 1.1 2008/02/24 17:53:32 dev-zero Exp $
+
+EAPI="1"
inherit distutils eutils multilib
@@ -12,29 +14,31 @@ SLOT="0"
KEYWORDS="~amd64 ~ia64 ~ppc ~x86"
IUSE=""
-RDEPEND="=dev-python/wxpython-2.6*"
+RDEPEND="dev-python/wxpython:2.6"
DEPEND="app-arch/unzip"
-S=${WORKDIR}/${PN}
+S="${WORKDIR}/${PN}"
src_unpack() {
distutils_src_unpack
- epatch "${FILESDIR}"/${P}-wxversion.patch
+ epatch \
+ "${FILESDIR}/${P}-wxversion.patch" \
+ "${FILESDIR}/${P}-tabswitch.patch"
}
src_install() {
distutils_python_version
- local destdir="/usr/$(get_libdir)/python${PYVER}/site-packages/${PN}/"
+ local destdir="/usr/$(get_libdir)/python${PYVER}/site-packages/${PN}"
dodir ${destdir}/bitmaps/{16,24}
- cp -R bitmaps "${D}"/${destdir} || die "Failed to cp bitmaps"
+ cp -R bitmaps "${D}/${destdir}/" || die "failed to cp bitmaps"
distutils_src_install
- #Windows-only setup script:
- rm "${D}"/usr/bin/postinst.py
+ # Windows-only setup script:
+ rm "${D}/usr/bin/postinst.py"
- make_wrapper drpython "python ${destdir}drpython_wx26.py"
+ make_wrapper drpython "python ${destdir}/drpython_wx26.py"
}
pkg_postinst() {
diff --git a/dev-python/drpython/files/drpython-165-tabswitch.patch b/dev-python/drpython/files/drpython-165-tabswitch.patch
new file mode 100644
index 000000000000..4b33ba55d3f0
--- /dev/null
+++ b/dev-python/drpython/files/drpython-165-tabswitch.patch
@@ -0,0 +1,12 @@
+--- drNotebook.py 2008-02-15 22:57:01.000000000 +0000
++++ drNotebook.py.new 2008-02-15 23:07:04.000000000 +0000
+@@ -513,6 +513,9 @@
+ self.grandparent.txtDocumentArray[i].IsActive = True
+ self.grandparent.txtDocumentArray[i].OnModified(None)
+
++ # Bug fix - make sure Cut/Copy/Paste/Run etc. use the right document
++ self.SetTab()
++
+ if event is not None:
+ event.Skip()
+