summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBryan Østergaard <kloeri@gentoo.org>2004-06-12 21:08:12 +0000
committerBryan Østergaard <kloeri@gentoo.org>2004-06-12 21:08:12 +0000
commitbe3e8e8c5cde0d728ce98c7c445a712770f9ac2f (patch)
tree60ac950cc7d64ec094205f178797109aad025f28 /dev-python/docutils/files
parentstable on ppc64 (good job Lv!) (Manifest recommit) (diff)
downloadgentoo-2-be3e8e8c5cde0d728ce98c7c445a712770f9ac2f.tar.gz
gentoo-2-be3e8e8c5cde0d728ce98c7c445a712770f9ac2f.tar.bz2
gentoo-2-be3e8e8c5cde0d728ce98c7c445a712770f9ac2f.zip
Version bump, bug #51422.
Diffstat (limited to 'dev-python/docutils/files')
-rw-r--r--dev-python/docutils/files/digest-docutils-0.3.31
-rw-r--r--dev-python/docutils/files/docutils-0.3.3-extramodules.patch32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/docutils/files/digest-docutils-0.3.3 b/dev-python/docutils/files/digest-docutils-0.3.3
new file mode 100644
index 000000000000..6fd639a7f34c
--- /dev/null
+++ b/dev-python/docutils/files/digest-docutils-0.3.3
@@ -0,0 +1 @@
+MD5 e2ee36b7e878cb53fcee564aaba1f067 docutils-0.3.3-alpha.tar.gz 539340
diff --git a/dev-python/docutils/files/docutils-0.3.3-extramodules.patch b/dev-python/docutils/files/docutils-0.3.3-extramodules.patch
new file mode 100644
index 000000000000..49d49df3dc29
--- /dev/null
+++ b/dev-python/docutils/files/docutils-0.3.3-extramodules.patch
@@ -0,0 +1,32 @@
+--- docutils-0.3.3/setup.py 2003-06-25 02:47:04.000000000 +0100
++++ docutils-0.3.3/setup.py.new 2003-07-08 00:21:59.000000000 +0100
+@@ -78,20 +78,15 @@
+ List of (module name, minimum __version__ string, [attribute names])."""
+
+ def get_extras():
+- extras = []
+- for module_name, version, attributes in extra_modules:
+- try:
+- module = __import__(module_name)
+- if version and module.__version__ < version:
+- raise ValueError
+- for attribute in attributes or []:
+- getattr(module, attribute)
+- print ('"%s" module already present; ignoring extras/%s.py.'
+- % (module_name, module_name))
+- except (ImportError, AttributeError, ValueError):
+- extras.append(module_name)
+- return extras
+-
++ # old method does not work for upgrading/downgrading docutils.
++ # so we use a simple rule, 'optparse' and 'textwrap' are not installed
++ # for >=python-2.3
++
++ pyver = sys.version_info
++ if pyver[0] == 2 and pyver[1] > 2:
++ return ["roman"]
++ else:
++ return ["optparse","textwrap","roman"]
+
+ class dual_build_py(build_py):
+