summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2014-06-04 09:16:33 +0000
committerJustin Lecher <jlec@gentoo.org>2014-06-04 09:16:33 +0000
commit18a5b110f04993c2352ec755f5c3d14f57ab2463 (patch)
tree86d6b53be7c74898210f0320bf46d06d5c3d09bb /dev-python/docopt/docopt-0.6.1.ebuild
parentSupport >=dev-lang/vala-0.24.0 wrt #509512 by Alexandre Rostovtsev. Prefer sy... (diff)
downloadgentoo-2-18a5b110f04993c2352ec755f5c3d14f57ab2463.tar.gz
gentoo-2-18a5b110f04993c2352ec755f5c3d14f57ab2463.tar.bz2
gentoo-2-18a5b110f04993c2352ec755f5c3d14f57ab2463.zip
dev-python/docopt: New addition written by me
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'dev-python/docopt/docopt-0.6.1.ebuild')
-rw-r--r--dev-python/docopt/docopt-0.6.1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/docopt/docopt-0.6.1.ebuild b/dev-python/docopt/docopt-0.6.1.ebuild
new file mode 100644
index 000000000000..f3d3a3bab783
--- /dev/null
+++ b/dev-python/docopt/docopt-0.6.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/docopt/docopt-0.6.1.ebuild,v 1.1 2014/06/04 09:16:33 jlec Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Pythonic argument parser, that will make you smile"
+HOMEPAGE="https://pypi.python.org/pypi/docopt https://github.com/docopt/docopt"
+SRC_URI="
+ mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz
+ https://github.com/docopt/docopt/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+"
+
+python_test() {
+ esetup.py test
+}