summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2013-10-21 07:57:14 +0000
committerPatrick Lauer <patrick@gentoo.org>2013-10-21 07:57:14 +0000
commit3c298a8d51324d83c873e8d33f149e77c5d29d67 (patch)
tree1e72032ea1de75e840b53614e42c775a83bff42a /dev-python/dnspython
parentVersion bump to 113_p20131017; fixes bug #488230, reported by Marc Joliet and... (diff)
downloadgentoo-2-3c298a8d51324d83c873e8d33f149e77c5d29d67.tar.gz
gentoo-2-3c298a8d51324d83c873e8d33f149e77c5d29d67.tar.bz2
gentoo-2-3c298a8d51324d83c873e8d33f149e77c5d29d67.zip
Bump
(Portage version: 2.2.7/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-python/dnspython')
-rw-r--r--dev-python/dnspython/ChangeLog7
-rw-r--r--dev-python/dnspython/dnspython-1.11.1.ebuild46
2 files changed, 52 insertions, 1 deletions
diff --git a/dev-python/dnspython/ChangeLog b/dev-python/dnspython/ChangeLog
index 74c1e12c2902..fcd518d380c6 100644
--- a/dev-python/dnspython/ChangeLog
+++ b/dev-python/dnspython/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/dnspython
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/dnspython/ChangeLog,v 1.81 2013/09/05 18:46:35 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/dnspython/ChangeLog,v 1.82 2013/10/21 07:57:14 patrick Exp $
+
+*dnspython-1.11.1 (21 Oct 2013)
+
+ 21 Oct 2013; Patrick Lauer <patrick@gentoo.org> +dnspython-1.11.1.ebuild:
+ Bump
05 Sep 2013; Michał Górny <mgorny@gentoo.org> dnspython-1.10.0-r1.ebuild:
Clean up PYTHON_COMPAT from old implementations.
diff --git a/dev-python/dnspython/dnspython-1.11.1.ebuild b/dev-python/dnspython/dnspython-1.11.1.ebuild
new file mode 100644
index 000000000000..5443c7ed7c8a
--- /dev/null
+++ b/dev-python/dnspython/dnspython-1.11.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/dnspython/dnspython-1.11.1.ebuild,v 1.1 2013/10/21 07:57:14 patrick Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit distutils-r1
+
+DESCRIPTION="DNS toolkit for Python"
+HOMEPAGE="http://www.dnspython.org/ http://pypi.python.org/pypi/dnspython"
+SRC_URI="http://www.dnspython.org/kits/${PV}/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-solaris"
+IUSE="examples test"
+
+DEPEND="dev-python/pycrypto[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+DOCS=( ChangeLog README )
+
+python_prepare_all() {
+ use test && DISTUTILS_IN_SOURCE_BUILD=1
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ pushd "${BUILD_DIR}"/../tests &> /dev/null
+ local test
+ for test in *.py; do
+ if ! "${PYTHON}" ${test}; then
+ die "test $test failed under ${EPYTHON}"
+ else
+ einfo "test $test"
+ fi
+ done
+ # make some order out of the output salad
+ einfo "Testsuite passed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}