summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-06-05 03:13:42 +0000
committerIan Delaney <idella4@gentoo.org>2014-06-05 03:13:42 +0000
commit59a6b49ce16be0c355f92042ccc901813eba6f88 (patch)
treecb1bea221da709329b430afa4fe1b9f3dc8db86f /dev-python/django-evolution
parentApply security patches #512376 #512374 (diff)
downloadgentoo-2-59a6b49ce16be0c355f92042ccc901813eba6f88.tar.gz
gentoo-2-59a6b49ce16be0c355f92042ccc901813eba6f88.tar.bz2
gentoo-2-59a6b49ce16be0c355f92042ccc901813eba6f88.zip
bump; add pypy support, tidy, closes Bug # 512152 by kensington
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/django-evolution')
-rw-r--r--dev-python/django-evolution/ChangeLog9
-rw-r--r--dev-python/django-evolution/django-evolution-0.7.2.ebuild37
2 files changed, 44 insertions, 2 deletions
diff --git a/dev-python/django-evolution/ChangeLog b/dev-python/django-evolution/ChangeLog
index f751b96a3eee..fca53a984519 100644
--- a/dev-python/django-evolution/ChangeLog
+++ b/dev-python/django-evolution/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/django-evolution
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/django-evolution/ChangeLog,v 1.11 2013/05/22 07:36:02 idella4 Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/django-evolution/ChangeLog,v 1.12 2014/06/05 03:13:42 idella4 Exp $
+
+*django-evolution-0.7.2 (05 Jun 2014)
+
+ 05 Jun 2014; Ian Delaney <idella4@gentoo.org> +django-evolution-0.7.2.ebuild:
+ bump; add pypy support, tidy, closes Bug # 512152 by kensington
*django-evolution-0.6.9 (22 May 2013)
diff --git a/dev-python/django-evolution/django-evolution-0.7.2.ebuild b/dev-python/django-evolution/django-evolution-0.7.2.ebuild
new file mode 100644
index 000000000000..44d33d3cd18d
--- /dev/null
+++ b/dev-python/django-evolution/django-evolution-0.7.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/django-evolution/django-evolution-0.7.2.ebuild,v 1.1 2014/06/05 03:13:42 idella4 Exp $
+
+EAPI=5
+
+# This is NOT py3 compatible
+PYTHON_COMPAT=( python2_7 pypy )
+
+inherit distutils-r1
+
+MY_PN=${PN/-/_}
+MY_P=${MY_PN}-${PV}
+RELEASE="0.7"
+
+DESCRIPTION="A Django application that will run cron jobs for other django apps"
+HOMEPAGE="http://code.google.com/p/django-evolution/ http://pypi.python.org/pypi/django_evolution/"
+SRC_URI="http://downloads.reviewboard.org/releases/${PN}/${RELEASE}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="dev-python/django[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+S=${WORKDIR}/${MY_P}
+DOCS=( AUTHORS NEWS docs/{evolution.txt,faq.txt} )
+
+python_test() {
+ # http://code.google.com/p/django-evolution/issues/detail?id=135
+ # This is tested, any delay in die subsequent to (implicitly inherited) multiprocessing eclass
+ "${PYTHON}" tests/runtests.py || die
+}