summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2013-01-22 07:02:44 +0000
committerPatrick Lauer <patrick@gentoo.org>2013-01-22 07:02:44 +0000
commit4be73c34501d8daeca0f50ff571f2925a9ff00f3 (patch)
tree7a006687c7dbb51c060e3dec3797922999d9d739 /dev-python/deform
parentadd multiple inclusion protection (diff)
downloadgentoo-2-4be73c34501d8daeca0f50ff571f2925a9ff00f3.tar.gz
gentoo-2-4be73c34501d8daeca0f50ff571f2925a9ff00f3.tar.bz2
gentoo-2-4be73c34501d8daeca0f50ff571f2925a9ff00f3.zip
Bump
(Portage version: 2.2.0_alpha159/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-python/deform')
-rw-r--r--dev-python/deform/ChangeLog10
-rw-r--r--dev-python/deform/deform-0.9.6.ebuild44
2 files changed, 51 insertions, 3 deletions
diff --git a/dev-python/deform/ChangeLog b/dev-python/deform/ChangeLog
index dd762db2fcc1..8b2ba4f9a8e4 100644
--- a/dev-python/deform/ChangeLog
+++ b/dev-python/deform/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/deform
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/deform/ChangeLog,v 1.5 2012/05/20 20:03:20 floppym Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/deform/ChangeLog,v 1.6 2013/01/22 07:02:44 patrick Exp $
+
+*deform-0.9.6 (22 Jan 2013)
+
+ 22 Jan 2013; Patrick Lauer <patrick@gentoo.org> +deform-0.9.6.ebuild:
+ Bump
20 May 2012; Mike Gilbert <floppym@gentoo.org> deform-0.9.5.ebuild:
Revert docs code.
@@ -25,4 +30,3 @@
30 Jul 2011; Rafael G. Martins <rafaelmartins@gentoo.org>
+deform-0.9.2.ebuild, +metadata.xml:
Initial version. Based on ebuild by Jan Matějka (bug #368051).
-
diff --git a/dev-python/deform/deform-0.9.6.ebuild b/dev-python/deform/deform-0.9.6.ebuild
new file mode 100644
index 000000000000..fbbc1703cd01
--- /dev/null
+++ b/dev-python/deform/deform-0.9.6.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/deform/deform-0.9.6.ebuild,v 1.1 2013/01/22 07:02:44 patrick Exp $
+
+EAPI="3"
+
+SUPPORT_PYTHON_ABIS=1
+PYTHON_DEPEND="2:2.6 3:3.2"
+RESTRICT_PYTHON_ABIS="2.5 3.0 3.1"
+DISTUTILS_SRC_TEST="setup.py"
+
+inherit distutils
+
+DESCRIPTION="Another form generation library"
+HOMEPAGE="http://docs.pylonsproject.org/projects/deform/en/latest/ http://pypi.python.org/pypi/deform https://github.com/Pylons/deform"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="repoze"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+# Depend on peppercorn, translationstring and colander with Python 3 support
+RDEPEND=">=dev-python/translationstring-1.1
+ >=dev-python/colander-1.0_alpha1
+ >=dev-python/peppercorn-0.4
+ >=dev-python/chameleon-1.2.3"
+DEPEND="${RDEPEND}
+ test? ( dev-python/beautifulsoup:4 )"
+
+# Include COPYRIGHT.txt because the license seems to require it.
+DOCS="CHANGES.txt COPYRIGHT.txt README.txt"
+
+src_install() {
+ distutils_src_install
+
+ # Install only the .rst source, as sphinx processing requires
+ # a theme only available from git that contains hardcoded
+ # references to files on https://static.pylonsproject.org/ (so
+ # the docs would not actually work offline). Install the
+ # source, which is somewhat readable.
+ docinto docs
+ dodoc docs/*.rst || die
+}