summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-03-01 20:08:22 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-03-01 20:08:22 +0000
commit54aaad9bdb6158c6ebc8a5c3a805f47ee4593bd7 (patch)
treefae56242b6dd916a93eef6b275cd3a4d8438eee5 /dev-python/dbus-python
parentRevision bump to add patch to fully fix Bug 143498 (diff)
downloadgentoo-2-54aaad9bdb6158c6ebc8a5c3a805f47ee4593bd7.tar.gz
gentoo-2-54aaad9bdb6158c6ebc8a5c3a805f47ee4593bd7.tar.bz2
gentoo-2-54aaad9bdb6158c6ebc8a5c3a805f47ee4593bd7.zip
Set PYTHON_EXPORT_PHASE_FUNCTIONS instead of PYTHON_DEFINE_DEFAULT_FUNCTIONS.
Simplify installation of documentation. (Portage version: 15511-svn/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/dbus-python')
-rw-r--r--dev-python/dbus-python/dbus-python-0.83.0-r1.ebuild22
1 files changed, 9 insertions, 13 deletions
diff --git a/dev-python/dbus-python/dbus-python-0.83.0-r1.ebuild b/dev-python/dbus-python/dbus-python-0.83.0-r1.ebuild
index 644857c66d63..3bdef46f77e7 100644
--- a/dev-python/dbus-python/dbus-python-0.83.0-r1.ebuild
+++ b/dev-python/dbus-python/dbus-python-0.83.0-r1.ebuild
@@ -1,9 +1,10 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/dbus-python/dbus-python-0.83.0-r1.ebuild,v 1.16 2010/02/17 22:48:13 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/dbus-python/dbus-python-0.83.0-r1.ebuild,v 1.17 2010/03/01 20:08:22 arfrever Exp $
EAPI="2"
-PYTHON_DEFINE_DEFAULT_FUNCTIONS="1"
+PYTHON_DEPEND="2"
+PYTHON_EXPORT_PHASE_FUNCTIONS="1"
SUPPORT_PYTHON_ABIS="1"
inherit multilib python
@@ -18,8 +19,7 @@ LICENSE="MIT"
KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux"
IUSE="doc examples test"
-RDEPEND=">=dev-lang/python-2.4.4-r5
- >=dev-python/pyrex-0.9.3-r2
+RDEPEND=">=dev-python/pyrex-0.9.3-r2
>=dev-libs/dbus-glib-0.71
>=sys-apps/dbus-1.1.1"
DEPEND="${RDEPEND}
@@ -30,8 +30,8 @@ RESTRICT_PYTHON_ABIS="3.*"
src_prepare() {
# Disable compiling of .pyc files.
- mv "${S}"/py-compile "${S}"/py-compile.orig
- ln -s $(type -P true) "${S}"/py-compile
+ mv py-compile py-compile.orig
+ ln -s $(type -P true) py-compile
python_src_prepare
}
@@ -41,7 +41,7 @@ src_configure() {
configuration() {
econf \
- --docdir="${EPREFIX}"/usr/share/doc/${PF} \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}" \
$(use_enable doc api-docs)
}
python_execute_function -s configuration
@@ -51,14 +51,10 @@ src_install() {
python_src_install
if use doc; then
- # Install documentation only once.
- documentation_installed="0"
install_documentation() {
- [[ "${documentation_installed}" == "1" ]] && return
dohtml api/* || return 1
- documentation_installed="1"
}
- python_execute_function -q -s install_documentation
+ python_execute_function -f -q -s install_documentation
fi
if use examples; then
@@ -74,5 +70,5 @@ pkg_postinst() {
}
pkg_postrm() {
- python_mod_cleanup
+ python_mod_cleanup dbus
}