summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2013-06-19 05:41:47 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2013-06-19 05:41:47 +0000
commitb12b2a37a7b39bc8c382ac35b9a5d943ad8be19b (patch)
treea30ea778a4998156d1f20c0b2849665e9950f0ba /dev-python/cvxopt
parentMasked >=sci-mathematics/glpk-4.49 (diff)
downloadgentoo-2-b12b2a37a7b39bc8c382ac35b9a5d943ad8be19b.tar.gz
gentoo-2-b12b2a37a7b39bc8c382ac35b9a5d943ad8be19b.tar.bz2
gentoo-2-b12b2a37a7b39bc8c382ac35b9a5d943ad8be19b.zip
Version bump
(Portage version: 2.2.01.22013-prefix/cvs/Linux x86_64, signed Manifest commit with key 0x13CB1360)
Diffstat (limited to 'dev-python/cvxopt')
-rw-r--r--dev-python/cvxopt/ChangeLog9
-rw-r--r--dev-python/cvxopt/cvxopt-1.1.5.ebuild86
-rw-r--r--dev-python/cvxopt/cvxopt-1.1.6.ebuild (renamed from dev-python/cvxopt/cvxopt-1.1.5-r1.ebuild)47
-rw-r--r--dev-python/cvxopt/files/cvxopt-1.1.6-setup.patch175
4 files changed, 203 insertions, 114 deletions
diff --git a/dev-python/cvxopt/ChangeLog b/dev-python/cvxopt/ChangeLog
index 6498e2df7ef5..ddc7a30fccb4 100644
--- a/dev-python/cvxopt/ChangeLog
+++ b/dev-python/cvxopt/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-python/cvxopt
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/cvxopt/ChangeLog,v 1.13 2013/02/26 20:33:17 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/cvxopt/ChangeLog,v 1.14 2013/06/19 05:41:47 bicatali Exp $
+
+*cvxopt-1.1.6 (19 Jun 2013)
+
+ 19 Jun 2013; Sébastien Fabbro <bicatali@gentoo.org> +cvxopt-1.1.6.ebuild,
+ +files/cvxopt-1.1.6-setup.patch, -cvxopt-1.1.5-r1.ebuild,
+ -cvxopt-1.1.5.ebuild:
+ Version bump
*cvxopt-1.1.5-r2 (26 Feb 2013)
diff --git a/dev-python/cvxopt/cvxopt-1.1.5.ebuild b/dev-python/cvxopt/cvxopt-1.1.5.ebuild
deleted file mode 100644
index 2353abc77a02..000000000000
--- a/dev-python/cvxopt/cvxopt-1.1.5.ebuild
+++ /dev/null
@@ -1,86 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/cvxopt/cvxopt-1.1.5.ebuild,v 1.4 2013/02/26 20:33:17 jlec Exp $
-
-EAPI=4
-
-SUPPORT_PYTHON_ABIS=1
-RESTRICT_PYTHON_ABIS="2.4 2.5 *-jython 2.7-pypy-*"
-
-inherit distutils eutils toolchain-funcs
-
-DESCRIPTION="Python package for convex optimization"
-HOMEPAGE="http://abel.ee.ucla.edu/cvxopt"
-SRC_URI="http://abel.ee.ucla.edu/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="doc +dsdp examples fftw +glpk gsl"
-
-RDEPEND="
- virtual/blas
- virtual/cblas
- virtual/lapack
- sci-libs/cholmod
- sci-libs/umfpack
- dsdp? ( sci-libs/dsdp )
- fftw? ( sci-libs/fftw:3.0 )
- glpk? ( sci-mathematics/glpk )
- gsl? ( sci-libs/gsl )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- doc? ( dev-python/sphinx )"
-
-S="${WORKDIR}/${P}/src"
-
-src_prepare(){
- epatch "${FILESDIR}"/${P}-setup.patch
- rm -rf src/C/SuiteSparse*/
- rm -rf ../doc/build # 413905
-
- pkg_lib() {
- local pylib=\'$($(tc-getPKG_CONFIG) --libs-only-l ${1} | sed \
- -e 's/^-l//' \
- -e "s/ -l/\',\'/g" \
- -e 's/.,.pthread//g' \
- -e "s: ::")\'
- sed -i -e "/_LIB = /s:\(.*\)'${1}'\(.*\):\1${pylib}\2:" setup.py
- }
-
- use_cvx() {
- if use ${1}; then
- sed -i \
- -e "s/\(BUILD_${1^^} =\) 0/\1 1/" \
- setup.py || die
- fi
- }
-
- pkg_lib blas
- pkg_lib lapack
- use_cvx gsl
- use_cvx fftw
- use_cvx glpk
- use_cvx dsdp
- distutils_src_prepare
-}
-
-src_compile() {
- distutils_src_compile
- use doc && emake -C "${WORKDIR}"/${P}/doc -B html
-}
-
-src_test() {
- cd "${WORKDIR}"/${P}/examples/doc/chap8
- testing() {
- PYTHONPATH="$(ls -d ${S}/build-${PYTHON_ABI}/lib.*)" "$(PYTHON)" lp.py
- }
- python_execute_function testing
-}
-
-src_install() {
- distutils_src_install
- use doc && dohtml -r "${WORKDIR}"/${P}/doc/build/html/*
- insinto /usr/share/doc/${PF}
- use examples && doins -r "${WORKDIR}"/${P}/examples
-}
diff --git a/dev-python/cvxopt/cvxopt-1.1.5-r1.ebuild b/dev-python/cvxopt/cvxopt-1.1.6.ebuild
index e6658da86331..dd2b45c6d1af 100644
--- a/dev-python/cvxopt/cvxopt-1.1.5-r1.ebuild
+++ b/dev-python/cvxopt/cvxopt-1.1.6.ebuild
@@ -1,17 +1,16 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/cvxopt/cvxopt-1.1.5-r1.ebuild,v 1.3 2013/02/25 07:21:24 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/cvxopt/cvxopt-1.1.6.ebuild,v 1.1 2013/06/19 05:41:47 bicatali Exp $
-EAPI=4
+EAPI=5
-SUPPORT_PYTHON_ABIS=1
-RESTRICT_PYTHON_ABIS="2.4 2.5 3.3 *-jython 2.7-pypy-*"
+PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} )
-inherit distutils eutils toolchain-funcs
+inherit distutils-r1 toolchain-funcs
DESCRIPTION="Python package for convex optimization"
-HOMEPAGE="http://abel.ee.ucla.edu/cvxopt"
-SRC_URI="http://abel.ee.ucla.edu/${PN}/${P}.tar.gz"
+HOMEPAGE="http://cvxopt.org/"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="GPL-3"
SLOT="0"
@@ -32,12 +31,11 @@ DEPEND="${RDEPEND}
virtual/pkgconfig
doc? ( dev-python/sphinx )"
-S="${WORKDIR}/${P}/src"
+python_prepare_all(){
+ local PATCHES=( "${FILESDIR}"/${PN}-1.1.6-setup.patch )
+ rm -r src/C/SuiteSparse*/ || die
-src_prepare(){
- epatch "${FILESDIR}"/${P}-setup.patch
- rm -r C/SuiteSparse*/ || die
- rm -r ../doc/build || die # 413905
+ distutils-r1_python_prepare_all
pkg_lib() {
local pylib=\'$($(tc-getPKG_CONFIG) --libs-only-l ${1} | sed \
@@ -45,7 +43,7 @@ src_prepare(){
-e "s/ -l/\',\'/g" \
-e 's/.,.pthread//g' \
-e "s:[[:space:]]::g")\'
- sed -i -e "/_LIB = /s:\(.*\)'${1}'\(.*\):\1${pylib}\2:" setup.py
+ sed -i -e "/_LIB = /s:\(.*\)'${1}'\(.*\):\1${pylib}\2:" setup.py || die
}
use_cvx() {
@@ -62,25 +60,20 @@ src_prepare(){
use_cvx fftw
use_cvx glpk
use_cvx dsdp
- distutils_src_prepare
}
-src_compile() {
- distutils_src_compile
- use doc && emake -C "${WORKDIR}"/${P}/doc -B html
+python_compile_all() {
+ use doc && emake -C doc -B html
}
-src_test() {
- cd "${WORKDIR}"/${P}/examples/doc/chap8
- testing() {
- PYTHONPATH="$(ls -d ${S}/build-${PYTHON_ABI}/lib.*)" "$(PYTHON)" lp.py
- }
- python_execute_function testing
+python_test() {
+ cd examples/doc/chap8
+ "${EPYTHON}" lp.py || die
}
-src_install() {
- distutils_src_install
- use doc && dohtml -r "${WORKDIR}"/${P}/doc/build/html/*
+python_install_all() {
+ use doc && HTML_DOCS=( doc/build/html/. )
insinto /usr/share/doc/${PF}
- use examples && doins -r "${WORKDIR}"/${P}/examples
+ use examples && doins -r examples
+ distutils-r1_python_install_all
}
diff --git a/dev-python/cvxopt/files/cvxopt-1.1.6-setup.patch b/dev-python/cvxopt/files/cvxopt-1.1.6-setup.patch
new file mode 100644
index 000000000000..440e1158ef93
--- /dev/null
+++ b/dev-python/cvxopt/files/cvxopt-1.1.6-setup.patch
@@ -0,0 +1,175 @@
+--- setup.py.orig 2013-05-16 21:36:29.616510963 +1200
++++ setup.py 2013-05-16 21:51:08.456347311 +1200
+@@ -2,7 +2,7 @@
+ from glob import glob
+
+ # Modifiy this if BLAS and LAPACK libraries are not in /usr/lib.
+-BLAS_LIB_DIR = '/usr/lib'
++BLAS_LIB_DIR = ''
+
+ # Default names of BLAS and LAPACK libraries
+ BLAS_LIB = ['blas']
+@@ -18,37 +18,37 @@
+ BUILD_GSL = 0
+
+ # Directory containing libgsl (used only when BUILD_GSL = 1).
+-GSL_LIB_DIR = '/usr/lib'
++GSL_LIB_DIR = ''
+
+ # Directory containing the GSL header files (used only when BUILD_GSL = 1).
+-GSL_INC_DIR = '/usr/include/gsl'
++GSL_INC_DIR = ''
+
+ # Set to 1 if you are installing the fftw module.
+ BUILD_FFTW = 0
+
+ # Directory containing libfftw3 (used only when BUILD_FFTW = 1).
+-FFTW_LIB_DIR = '/usr/lib'
++FFTW_LIB_DIR = ''
+
+ # Directory containing fftw.h (used only when BUILD_FFTW = 1).
+-FFTW_INC_DIR = '/usr/include'
++FFTW_INC_DIR = ''
+
+ # Set to 1 if you are installing the glpk module.
+ BUILD_GLPK = 0
+
+ # Directory containing libglpk (used only when BUILD_GLPK = 1).
+-GLPK_LIB_DIR = '/usr/lib'
++GLPK_LIB_DIR = ''
+
+ # Directory containing glpk.h (used only when BUILD_GLPK = 1).
+-GLPK_INC_DIR = '/usr/include'
++GLPK_INC_DIR = ''
+
+ # Set to 1 if you are installing the DSDP module.
+ BUILD_DSDP = 0
+
+ # Directory containing libdsdp (used only when BUILD_DSDP = 1).
+-DSDP_LIB_DIR = '/usr/lib'
++DSDP_LIB_DIR = ''
+
+ # Directory containing dsdp5.h (used only when BUILD_DSDP = 1).
+-DSDP_INC_DIR = '/usr/include/dsdp'
++DSDP_INC_DIR = ''
+
+ # No modifications should be needed below this line.
+
+@@ -61,39 +61,32 @@
+ # optional modules
+
+ if BUILD_GSL:
+- gsl = Extension('gsl', libraries = ['m', 'gsl'] + BLAS_LIB,
+- include_dirs = [ GSL_INC_DIR ],
+- library_dirs = [ GSL_LIB_DIR, BLAS_LIB_DIR ],
+- extra_link_args = BLAS_EXTRA_LINK_ARGS,
++ gsl = Extension('gsl', libraries = ['gsl'],
++ library_dirs = [ GSL_LIB_DIR ],
+ sources = ['src/C/gsl.c'] )
+ extmods += [gsl];
+
+ if BUILD_FFTW:
+- fftw = Extension('fftw', libraries = ['fftw3'] + BLAS_LIB,
+- include_dirs = [ FFTW_INC_DIR ],
+- library_dirs = [ FFTW_LIB_DIR, BLAS_LIB_DIR ],
+- extra_link_args = BLAS_EXTRA_LINK_ARGS,
++ fftw = Extension('fftw', libraries = ['fftw3'],
++ library_dirs = [ FFTW_LIB_DIR ],
+ sources = ['src/C/fftw.c'] )
+ extmods += [fftw];
+
+ if BUILD_GLPK:
+ glpk = Extension('glpk', libraries = ['glpk'],
+- include_dirs = [ GLPK_INC_DIR ],
+ library_dirs = [ GLPK_LIB_DIR ],
+ sources = ['src/C/glpk.c'] )
+ extmods += [glpk];
+
+ if BUILD_DSDP:
+- dsdp = Extension('dsdp', libraries = ['dsdp'] + LAPACK_LIB + BLAS_LIB,
+- include_dirs = [ DSDP_INC_DIR ],
+- library_dirs = [ DSDP_LIB_DIR, BLAS_LIB_DIR ],
+- extra_link_args = BLAS_EXTRA_LINK_ARGS,
++ dsdp = Extension('dsdp', libraries = ['dsdp'],
++ library_dirs = [ DSDP_LIB_DIR ],
+ sources = ['src/C/dsdp.c'] )
+ extmods += [dsdp];
+
+ # Required modules
+
+-base = Extension('base', libraries = ['m'] + LAPACK_LIB + BLAS_LIB,
++base = Extension('base', libraries = ['m'] + LAPACK_LIB,
+ library_dirs = [ BLAS_LIB_DIR ],
+ define_macros = MACROS,
+ extra_link_args = BLAS_EXTRA_LINK_ARGS,
+@@ -105,61 +98,35 @@
+ extra_link_args = BLAS_EXTRA_LINK_ARGS,
+ sources = ['src/C/blas.c'] )
+
+-lapack = Extension('lapack', libraries = LAPACK_LIB + BLAS_LIB,
++lapack = Extension('lapack', libraries = LAPACK_LIB,
+ library_dirs = [ BLAS_LIB_DIR ],
+ define_macros = MACROS,
+ extra_link_args = BLAS_EXTRA_LINK_ARGS,
+ sources = ['src/C/lapack.c'] )
+
+ umfpack = Extension('umfpack',
+- include_dirs = [ 'src/C/SuiteSparse/UMFPACK/Include',
+- 'src/C/SuiteSparse/AMD/Include',
+- 'src/C/SuiteSparse/AMD/Source',
+- 'src/C/SuiteSparse/SuiteSparse_config' ],
+ library_dirs = [ BLAS_LIB_DIR ],
+ define_macros = MACROS + [('NTIMER', '1'), ('NCHOLMOD', '1')],
+- libraries = LAPACK_LIB + BLAS_LIB,
++ libraries = [ 'umfpack' ],
+ extra_compile_args = ['-Wno-unknown-pragmas'],
+- extra_link_args = BLAS_EXTRA_LINK_ARGS,
+- sources = [ 'src/C/umfpack.c',
+- 'src/C/SuiteSparse/UMFPACK/Source/umfpack_global.c',
+- 'src/C/SuiteSparse/UMFPACK/Source/umfpack_tictoc.c' ] +
+- ['src/C/SuiteSparse/SuiteSparse_config/SuiteSparse_config.c'] +
+- glob('src/C/SuiteSparse_cvxopt_extra/umfpack/*'))
++ sources = [ 'src/C/umfpack.c' ])
+
+ # Build for int or long?
+ import sys
+ if sys.maxsize > 2**31: MACROS += [('DLONG',None)]
+
+ cholmod = Extension('cholmod',
+- library_dirs = [ BLAS_LIB_DIR ],
+- libraries = LAPACK_LIB + BLAS_LIB,
+- include_dirs = [ 'src/C/SuiteSparse/CHOLMOD/Include',
+- 'src/C/SuiteSparse/COLAMD',
+- 'src/C/SuiteSparse/AMD/Include',
+- 'src/C/SuiteSparse/COLAMD/Include',
+- 'src/C/SuiteSparse/SuiteSparse_config' ],
+- define_macros = MACROS + [('NPARTITION', '1'), ('NTIMER', '1')],
+- extra_link_args = BLAS_EXTRA_LINK_ARGS,
+- sources = [ 'src/C/cholmod.c' ] +
+- ['src/C/SuiteSparse/AMD/Source/' + s for s in ['amd_global.c',
+- 'amd_postorder.c', 'amd_post_tree.c', 'amd_2.c']] +
+- ['src/C/SuiteSparse/COLAMD/Source/' + s for s in ['colamd.c',
+- 'colamd_global.c']] +
+- ['src/C/SuiteSparse/SuiteSparse_config/SuiteSparse_config.c'] +
+- glob('src/C/SuiteSparse/CHOLMOD/Core/c*.c') +
+- glob('src/C/SuiteSparse/CHOLMOD/Cholesky/c*.c') +
+- ['src/C/SuiteSparse/CHOLMOD/Check/cholmod_check.c'] +
+- glob('src/C/SuiteSparse/CHOLMOD/Supernodal/c*.c') )
++ libraries = ['cholmod'] + BLAS_LIB,
++ define_macros = MACROS + [('NPARTITION', '1'), ('NTIMER', '1')],
++ sources = [ 'src/C/cholmod.c' ])
+
+ amd = Extension('amd',
+- include_dirs = [ 'src/C/SuiteSparse/AMD/Include',
+- 'src/C/SuiteSparse/SuiteSparse_config' ],
+ define_macros = MACROS,
+- sources = [ 'src/C/amd.c' ] + glob('src/C/SuiteSparse/AMD/Source/*.c') )
++ libraries = ['amd'],
++ sources = [ 'src/C/amd.c' ])
+
+ misc_solvers = Extension('misc_solvers',
+- libraries = LAPACK_LIB + BLAS_LIB,
++ libraries = LAPACK_LIB,
+ library_dirs = [ BLAS_LIB_DIR ],
+ define_macros = MACROS,
+ extra_link_args = BLAS_EXTRA_LINK_ARGS,