summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2005-09-28 10:20:32 +0000
committerHanno Böck <hanno@gentoo.org>2005-09-28 10:20:32 +0000
commit6812130a233e7200f34ef983904381fe20714934 (patch)
tree71169c6bb394abc77d552430cb4fdeec6c5fea90 /dev-python/ctypes
parentremoving aqhbci (replaced by aqbanking) (diff)
downloadgentoo-2-6812130a233e7200f34ef983904381fe20714934.tar.gz
gentoo-2-6812130a233e7200f34ef983904381fe20714934.tar.bz2
gentoo-2-6812130a233e7200f34ef983904381fe20714934.zip
ctypes bump and gcc4 fix
(Portage version: 2.0.52-r1)
Diffstat (limited to 'dev-python/ctypes')
-rw-r--r--dev-python/ctypes/ChangeLog8
-rw-r--r--dev-python/ctypes/ctypes-0.9.6.ebuild21
-rw-r--r--dev-python/ctypes/files/ctypes-gcc411
-rw-r--r--dev-python/ctypes/files/digest-ctypes-0.9.61
4 files changed, 40 insertions, 1 deletions
diff --git a/dev-python/ctypes/ChangeLog b/dev-python/ctypes/ChangeLog
index e2a8bb25d3fe..23d5a382a5a1 100644
--- a/dev-python/ctypes/ChangeLog
+++ b/dev-python/ctypes/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/ctypes
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/ctypes/ChangeLog,v 1.2 2005/07/12 11:01:44 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/ctypes/ChangeLog,v 1.3 2005/09/28 10:20:32 hanno Exp $
+
+*ctypes-0.9.6 (28 Sep 2005)
+
+ 28 Sep 2005; Hanno Boeck <hanno@gentoo.org> +files/ctypes-gcc4,
+ +ctypes-0.9.6.ebuild:
+ Version bump and gcc4 fix.
12 Jul 2005; David Holm <dholm@gentoo.org> ctypes-0.9.2.ebuild:
Added to ~ppc.
diff --git a/dev-python/ctypes/ctypes-0.9.6.ebuild b/dev-python/ctypes/ctypes-0.9.6.ebuild
new file mode 100644
index 000000000000..a3198eb82b54
--- /dev/null
+++ b/dev-python/ctypes/ctypes-0.9.6.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/ctypes/ctypes-0.9.6.ebuild,v 1.1 2005/09/28 10:20:32 hanno Exp $
+
+inherit eutils distutils
+
+DESCRIPTION="Python module allowing to create and manipulate C data types."
+HOMEPAGE="http://starship.python.net/crew/theller/ctypes/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~ppc ~x86"
+IUSE=""
+DEPEND=">=dev-lang/python-2.3.3"
+
+DOCS="README.txt NEWS.txt LICENSE.txt samples/* docs/*"
+
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/ctypes-gcc4
+}
diff --git a/dev-python/ctypes/files/ctypes-gcc4 b/dev-python/ctypes/files/ctypes-gcc4
new file mode 100644
index 000000000000..1834e462b45b
--- /dev/null
+++ b/dev-python/ctypes/files/ctypes-gcc4
@@ -0,0 +1,11 @@
+--- ctypes-0.9.6/source/_ctypes.c 2004-10-26 03:05:46.000000000 +0200
++++ ctypes-0.9.6-gcc4/source/_ctypes.c 2005-09-26 11:36:41.231754000 +0200
+@@ -3880,7 +3880,7 @@
+ (inquiry)Pointer_nonzero, /* nb_nonzero */
+ };
+
+-static PyTypeObject Pointer_Type = {
++PyTypeObject Pointer_Type = {
+ PyObject_HEAD_INIT(NULL)
+ 0,
+ "_ctypes._Pointer",
diff --git a/dev-python/ctypes/files/digest-ctypes-0.9.6 b/dev-python/ctypes/files/digest-ctypes-0.9.6
new file mode 100644
index 000000000000..7507e4e3db0e
--- /dev/null
+++ b/dev-python/ctypes/files/digest-ctypes-0.9.6
@@ -0,0 +1 @@
+MD5 9f6bfdb21f7016da2518020beb326da0 ctypes-0.9.6.tar.gz 510038