summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2014-05-12 07:01:01 +0000
committerTim Harder <radhermit@gentoo.org>2014-05-12 07:01:01 +0000
commitd814e74a2433fc5720d9cd46fe38dcc951095015 (patch)
tree78a78e317ca42b81ebab2e7baf60f8322eac6f14 /dev-python/configobj
parentwww-servers/spawn-fcgi: Move from /var/run to /run (diff)
downloadgentoo-2-d814e74a2433fc5720d9cd46fe38dcc951095015.tar.gz
gentoo-2-d814e74a2433fc5720d9cd46fe38dcc951095015.tar.bz2
gentoo-2-d814e74a2433fc5720d9cd46fe38dcc951095015.zip
Version bump.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'dev-python/configobj')
-rw-r--r--dev-python/configobj/ChangeLog7
-rw-r--r--dev-python/configobj/configobj-5.0.5.ebuild30
2 files changed, 36 insertions, 1 deletions
diff --git a/dev-python/configobj/ChangeLog b/dev-python/configobj/ChangeLog
index fa384ca23088..f490b76d6fa2 100644
--- a/dev-python/configobj/ChangeLog
+++ b/dev-python/configobj/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/configobj
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/configobj/ChangeLog,v 1.50 2014/04/23 08:37:56 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/configobj/ChangeLog,v 1.51 2014/05/12 07:01:01 radhermit Exp $
+
+*configobj-5.0.5 (12 May 2014)
+
+ 12 May 2014; Tim Harder <radhermit@gentoo.org> +configobj-5.0.5.ebuild:
+ Version bump.
23 Apr 2014; Ian Delaney <idella4@gentoo.org> configobj-5.0.4.ebuild:
deal with un-needed _version.py reported by Arfrever
diff --git a/dev-python/configobj/configobj-5.0.5.ebuild b/dev-python/configobj/configobj-5.0.5.ebuild
new file mode 100644
index 000000000000..162e195aa51c
--- /dev/null
+++ b/dev-python/configobj/configobj-5.0.5.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/configobj/configobj-5.0.5.ebuild,v 1.1 2014/05/12 07:01:01 radhermit Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_2,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Simple config file reader and writer"
+HOMEPAGE="http://www.voidspace.org.uk/python/configobj.html http://code.google.com/p/configobj/ http://pypi.python.org/pypi/configobj"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+
+python_prepare_all() {
+ # Not to install un-needed _version.py
+ sed -e "/^MODULES =/s/, '_version'//" -i setup.py
+ sed -e "s/^from _version import __version__$/__version__ = '${PV}'/" -i configobj.py
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ "${PYTHON}" validate.py -v || die "Tests fail with ${EPYTHON}"
+}