summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-07-03 23:01:50 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-07-03 23:01:50 +0000
commite6d3bf9b854fe0c4bf6d0c99ad141b0349281816 (patch)
tree5e2b21d3926982ab302fb39790a271351f98041e /dev-python/cherrytemplate
parentppc64 stable wrt #322867 (diff)
downloadgentoo-2-e6d3bf9b854fe0c4bf6d0c99ad141b0349281816.tar.gz
gentoo-2-e6d3bf9b854fe0c4bf6d0c99ad141b0349281816.tar.bz2
gentoo-2-e6d3bf9b854fe0c4bf6d0c99ad141b0349281816.zip
Set SUPPORT_PYTHON_ABIS.
(Portage version: HEAD/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/cherrytemplate')
-rw-r--r--dev-python/cherrytemplate/ChangeLog8
-rw-r--r--dev-python/cherrytemplate/cherrytemplate-1.0.0.ebuild15
2 files changed, 16 insertions, 7 deletions
diff --git a/dev-python/cherrytemplate/ChangeLog b/dev-python/cherrytemplate/ChangeLog
index b58d028071a9..dd15220b4886 100644
--- a/dev-python/cherrytemplate/ChangeLog
+++ b/dev-python/cherrytemplate/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/cherrytemplate
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/cherrytemplate/ChangeLog,v 1.7 2009/02/15 22:06:08 patrick Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/cherrytemplate/ChangeLog,v 1.8 2010/07/03 23:01:50 arfrever Exp $
+
+ 03 Jul 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ cherrytemplate-1.0.0.ebuild:
+ Set SUPPORT_PYTHON_ABIS.
15 Feb 2009; Patrick Lauer <patrick@gentoo.org>
cherrytemplate-1.0.0.ebuild:
diff --git a/dev-python/cherrytemplate/cherrytemplate-1.0.0.ebuild b/dev-python/cherrytemplate/cherrytemplate-1.0.0.ebuild
index e675f55ce29f..5e5ef3aceb4f 100644
--- a/dev-python/cherrytemplate/cherrytemplate-1.0.0.ebuild
+++ b/dev-python/cherrytemplate/cherrytemplate-1.0.0.ebuild
@@ -1,12 +1,17 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/cherrytemplate/cherrytemplate-1.0.0.ebuild,v 1.6 2009/02/15 22:06:08 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/cherrytemplate/cherrytemplate-1.0.0.ebuild,v 1.7 2010/07/03 23:01:50 arfrever Exp $
-NEED_PYTHON=2.3
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
inherit distutils
-MY_P="CherryTemplate-${PV}"
+MY_PN="CherryTemplate"
+MY_P="${MY_PN}-${PV}"
+
DESCRIPTION="Easy and powerful templating module for Python"
HOMEPAGE="http://cherrytemplate.python-hosting.com/"
SRC_URI="mirror://sourceforge/cherrypy/${MY_P}.tar.gz"
@@ -19,4 +24,4 @@ IUSE=""
DEPEND=""
RDEPEND=""
-S=${WORKDIR}/${MY_P}
+S="${WORKDIR}/${MY_P}"