summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-04-24 14:58:43 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-04-24 14:58:43 +0000
commitf9f385d90f005fff52ca14abe7c356ed80405f3e (patch)
tree056365a8ed0b88f5a8a58f65ffc1413177e22d24 /dev-python/bsddb3
parentBump to 1.7a (diff)
downloadgentoo-2-f9f385d90f005fff52ca14abe7c356ed80405f3e.tar.gz
gentoo-2-f9f385d90f005fff52ca14abe7c356ed80405f3e.tar.bz2
gentoo-2-f9f385d90f005fff52ca14abe7c356ed80405f3e.zip
Remove old
(Portage version: 2.2_rc31/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/bsddb3')
-rw-r--r--dev-python/bsddb3/ChangeLog6
-rw-r--r--dev-python/bsddb3/bsddb3-4.7.0.ebuild55
-rw-r--r--dev-python/bsddb3/bsddb3-4.7.3.ebuild60
-rw-r--r--dev-python/bsddb3/bsddb3-4.7.4.ebuild60
4 files changed, 5 insertions, 176 deletions
diff --git a/dev-python/bsddb3/ChangeLog b/dev-python/bsddb3/ChangeLog
index a811ade76e86..62b36bbb9bba 100644
--- a/dev-python/bsddb3/ChangeLog
+++ b/dev-python/bsddb3/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/bsddb3
# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/bsddb3/ChangeLog,v 1.29 2009/02/15 12:02:41 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/bsddb3/ChangeLog,v 1.30 2009/04/24 14:58:43 patrick Exp $
+
+ 24 Apr 2009; Patrick Lauer <patrick@gentoo.org> -bsddb3-4.7.0.ebuild,
+ -bsddb3-4.7.3.ebuild, -bsddb3-4.7.4.ebuild:
+ Remove old
*bsddb3-4.7.5 (15 Feb 2009)
diff --git a/dev-python/bsddb3/bsddb3-4.7.0.ebuild b/dev-python/bsddb3/bsddb3-4.7.0.ebuild
deleted file mode 100644
index aaa58afbfd0f..000000000000
--- a/dev-python/bsddb3/bsddb3-4.7.0.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/bsddb3/bsddb3-4.7.0.ebuild,v 1.3 2008/06/29 09:44:17 armin76 Exp $
-
-EAPI="1"
-
-NEED_PYTHON=2.5
-
-inherit distutils db-use multilib
-
-DESCRIPTION="Python bindings for BerkeleyDB"
-HOMEPAGE="http://www.jcea.es/programacion/pybsddb.htm"
-SRC_URI="http://pypi.python.org/packages/source/${PN:0:1}/${PN}/${P}.tar.gz"
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86"
-IUSE="doc"
-
-RDEPEND="sys-libs/db:4.6"
-DEPEND="${RDEPEND}
- dev-python/setuptools
- doc? ( dev-python/sphinx )"
-
-src_compile() {
- DB_VER="4.6"
-
- sed -i \
- -e "s/dblib = 'db'/dblib = '$(db_libname ${DB_VER})'/" \
- setup.py
-
- distutils_src_compile \
- "--berkeley-db=/usr" \
- "--berkeley-db-incdir=$(db_includedir ${DB_VER})" \
- "--berkeley-db-libdir=/usr/$(get_libdir)"
-
- if use doc ; then
- mkdir html
- sphinx-build docs html || die "building docs failed"
- fi
-}
-
-src_install() {
- DOCS="TODO.txt"
- distutils_src_install
-
- distutils_python_version
- rm -rf "${D}/usr/$(get_libdir)/python${PYVER}/site-packages/${PN}/tests"
-
- use doc && dohtml -r html/*
-}
-
-src_test() {
- distutils_python_version
- "${python}" test.py || die "tests failed"
-}
diff --git a/dev-python/bsddb3/bsddb3-4.7.3.ebuild b/dev-python/bsddb3/bsddb3-4.7.3.ebuild
deleted file mode 100644
index 3aa6b9c368e1..000000000000
--- a/dev-python/bsddb3/bsddb3-4.7.3.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/bsddb3/bsddb3-4.7.3.ebuild,v 1.2 2008/10/25 17:48:22 hawking Exp $
-
-EAPI="1"
-
-NEED_PYTHON=2.5
-
-inherit distutils db-use multilib
-
-DESCRIPTION="Python bindings for BerkeleyDB"
-HOMEPAGE="http://www.jcea.es/programacion/pybsddb.htm"
-SRC_URI="http://pypi.python.org/packages/source/${PN:0:1}/${PN}/${P}.tar.gz"
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86"
-IUSE="doc"
-
-RDEPEND=">=sys-libs/db-4.6"
-DEPEND="${RDEPEND}
- dev-python/setuptools
- doc? ( dev-python/sphinx )"
-
-src_compile() {
- local DB_VER
- if has_version sys-libs/db:4.7; then
- DB_VER="4.7"
- else
- DB_VER="4.6"
- fi
-
- sed -i \
- -e "s/dblib = 'db'/dblib = '$(db_libname ${DB_VER})'/" \
- setup2.py setup3.py || die "sed failed"
-
- distutils_src_compile \
- "--berkeley-db=/usr" \
- "--berkeley-db-incdir=$(db_includedir ${DB_VER})" \
- "--berkeley-db-libdir=/usr/$(get_libdir)"
-
- if use doc ; then
- mkdir html
- sphinx-build docs html || die "building docs failed"
- fi
-}
-
-src_install() {
- DOCS="TODO.txt"
- distutils_src_install
-
- distutils_python_version
- rm -rf "${D}/usr/$(get_libdir)/python${PYVER}/site-packages/${PN}/tests"
-
- use doc && dohtml -r html/*
-}
-
-src_test() {
- distutils_python_version
- "${python}" test.py || die "tests failed"
-}
diff --git a/dev-python/bsddb3/bsddb3-4.7.4.ebuild b/dev-python/bsddb3/bsddb3-4.7.4.ebuild
deleted file mode 100644
index a1b599157b9a..000000000000
--- a/dev-python/bsddb3/bsddb3-4.7.4.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/bsddb3/bsddb3-4.7.4.ebuild,v 1.1 2009/02/01 00:13:58 patrick Exp $
-
-EAPI="1"
-
-NEED_PYTHON=2.5
-
-inherit distutils db-use multilib
-
-DESCRIPTION="Python bindings for BerkeleyDB"
-HOMEPAGE="http://www.jcea.es/programacion/pybsddb.htm"
-SRC_URI="http://pypi.python.org/packages/source/${PN:0:1}/${PN}/${P}.tar.gz"
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86"
-IUSE="doc"
-
-RDEPEND=">=sys-libs/db-4.6"
-DEPEND="${RDEPEND}
- dev-python/setuptools
- doc? ( dev-python/sphinx )"
-
-src_compile() {
- local DB_VER
- if has_version sys-libs/db:4.7; then
- DB_VER="4.7"
- else
- DB_VER="4.6"
- fi
-
- sed -i \
- -e "s/dblib = 'db'/dblib = '$(db_libname ${DB_VER})'/" \
- setup2.py setup3.py || die "sed failed"
-
- distutils_src_compile \
- "--berkeley-db=/usr" \
- "--berkeley-db-incdir=$(db_includedir ${DB_VER})" \
- "--berkeley-db-libdir=/usr/$(get_libdir)"
-
- if use doc ; then
- mkdir html
- sphinx-build docs html || die "building docs failed"
- fi
-}
-
-src_install() {
- DOCS="TODO.txt"
- distutils_src_install
-
- distutils_python_version
- rm -rf "${D}/usr/$(get_libdir)/python${PYVER}/site-packages/${PN}/tests"
-
- use doc && dohtml -r html/*
-}
-
-src_test() {
- distutils_python_version
- "${python}" test.py || die "tests failed"
-}