summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2012-11-03 13:07:46 +0000
committerIan Delaney <idella4@gentoo.org>2012-11-03 13:07:46 +0000
commitf51d8ffd137992a3f7d157ce92bbc721352d9822 (patch)
tree2f3e11b08cd7671c4f403199f6f2c3340544eedc /dev-python/bottle
parentStable on amd64, wrt bug #440834 (diff)
downloadgentoo-2-f51d8ffd137992a3f7d157ce92bbc721352d9822.tar.gz
gentoo-2-f51d8ffd137992a3f7d157ce92bbc721352d9822.tar.bz2
gentoo-2-f51d8ffd137992a3f7d157ce92bbc721352d9822.zip
version bump to bottle-0.11.3
(Portage version: 2.1.11.30/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-python/bottle')
-rw-r--r--dev-python/bottle/ChangeLog8
-rw-r--r--dev-python/bottle/bottle-0.11.3.ebuild50
2 files changed, 56 insertions, 2 deletions
diff --git a/dev-python/bottle/ChangeLog b/dev-python/bottle/ChangeLog
index d730f2f0724a..a4265097897f 100644
--- a/dev-python/bottle/ChangeLog
+++ b/dev-python/bottle/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/bottle
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/bottle/ChangeLog,v 1.2 2012/05/20 16:50:29 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/bottle/ChangeLog,v 1.3 2012/11/03 13:07:46 idella4 Exp $
+
+*bottle-0.11.3 (04 Nov 2012)
+
+ 04 Nov 2012; Ian Delaney <idella4@gentoo.org> +bottle-0.11.3.ebuild:
+ version bump to bottle-0.11.3
20 May 2012; Kacper Kowalik <xarthisius@gentoo.org> bottle-0.10.9.ebuild:
Don't inherit eutils.eclass since it's not used, drop unnecessary dependecy on
@@ -14,4 +19,3 @@
Mike MacDonald (crazymykl) <crazymykl@gmail.com> and Johan Bergström
(jbergstroem) <bugs@bergstroem.nu> for their work on this ebuild in Sunrise
overlay
-
diff --git a/dev-python/bottle/bottle-0.11.3.ebuild b/dev-python/bottle/bottle-0.11.3.ebuild
new file mode 100644
index 000000000000..c74b5b508342
--- /dev/null
+++ b/dev-python/bottle/bottle-0.11.3.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/bottle/bottle-0.11.3.ebuild,v 1.1 2012/11/03 13:07:46 idella4 Exp $
+
+EAPI=4
+
+SUPPORT_PYTHON_ABIS=1
+RESTRICT_PYTHON_ABIS="*-jython"
+
+inherit distutils
+
+DESCRIPTION="A fast and simple micro-framework for small web-applications"
+HOMEPAGE="http://pypi.python.org/pypi/bottle http://bottlepy.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/simplejson"
+RDEPEND="${DEPEND}"
+
+PYTHON_MODNAME=bottle.py
+
+src_prepare() {
+ distutils_src_prepare
+
+ sed -e "/^sys.path.insert/d" -i test/{servertest.py,testall.py} || die
+
+ 2to3_tests() {
+ local p_maj=$(python_get_version -l --major)
+
+ if [[ ! -d test-${p_maj} ]]; then
+ cp -r test test-${p_maj}
+ if [[ $p_maj == 3 ]]; then
+ 2to3-${PYTHON_ABI} -nw --no-diffs test-${p_maj}
+ fi
+ fi
+ }
+ python_execute_function 2to3_tests
+}
+
+src_test() {
+ testing() {
+ local p_maj=$(python_get_version -l --major)
+ PYTHONPATH="build-${PYTHON_ABI}/lib/" "$(PYTHON)" test-${p_maj}/testall.py
+ }
+ python_execute_function testing
+}