summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStanislav Ochotnicky <sochotnicky@gentoo.org>2013-06-08 16:38:36 +0000
committerStanislav Ochotnicky <sochotnicky@gentoo.org>2013-06-08 16:38:36 +0000
commitff4a34c6fd1632f1a4fad7b388bd248744922646 (patch)
tree8ab54f62b0501a0b0e9e2e9670e0a489b5b9b77c /dev-python/bluelet
parentDon't install em.py symlink in /usr/bin; this causes pythonpath conflicts. (diff)
downloadgentoo-2-ff4a34c6fd1632f1a4fad7b388bd248744922646.tar.gz
gentoo-2-ff4a34c6fd1632f1a4fad7b388bd248744922646.tar.bz2
gentoo-2-ff4a34c6fd1632f1a4fad7b388bd248744922646.zip
Version bump. Update to EAPI5, Add examples USE flag
(Portage version: 2.1.11.63/cvs/Linux x86_64, signed Manifest commit with key 7B087241)
Diffstat (limited to 'dev-python/bluelet')
-rw-r--r--dev-python/bluelet/ChangeLog10
-rw-r--r--dev-python/bluelet/bluelet-0.2.0.ebuild29
2 files changed, 37 insertions, 2 deletions
diff --git a/dev-python/bluelet/ChangeLog b/dev-python/bluelet/ChangeLog
index fe9e94fccc29..31760886ad78 100644
--- a/dev-python/bluelet/ChangeLog
+++ b/dev-python/bluelet/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/bluelet
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/bluelet/ChangeLog,v 1.2 2012/05/29 17:14:42 jdhore Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/bluelet/ChangeLog,v 1.3 2013/06/08 16:38:36 sochotnicky Exp $
+
+*bluelet-0.2.0 (08 Jun 2013)
+
+ 08 Jun 2013; Stanislav Ochotnicky <sochotnicky@gentoo.org>
+ +bluelet-0.2.0.ebuild:
+ Version bump. Update to EAPI5, Add examples USE flag
29 May 2012; Jeff Horelick <jdhore@gentoo.org> bluelet-0.1.ebuild:
Keyword ~x86
diff --git a/dev-python/bluelet/bluelet-0.2.0.ebuild b/dev-python/bluelet/bluelet-0.2.0.ebuild
new file mode 100644
index 000000000000..de1fbb075fc2
--- /dev/null
+++ b/dev-python/bluelet/bluelet-0.2.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/bluelet/bluelet-0.2.0.ebuild,v 1.1 2013/06/08 16:38:36 sochotnicky Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7,3_1,3_2,3_3} )
+
+inherit distutils-r1
+
+DESCRIPTION="Module for pure Python asynchronous I/O using coroutines"
+HOMEPAGE="http://pypi.python.org/pypi/bluelet"
+SRC_URI="https://github.com/sampsyo/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+python_install_all() {
+ if use examples; then
+ docompress -x usr/share/doc/${P}/demo
+ dodoc -r demo/
+ fi
+}
+