summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2014-02-22 23:53:06 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2014-02-22 23:53:06 +0000
commita6fe19f96f93c0fd76fbb558251b49c188055798 (patch)
treeb5d7f02ee38036c6af15694909b657cf6a91fece /dev-python/blaze
parentVersion bump (diff)
downloadgentoo-2-a6fe19f96f93c0fd76fbb558251b49c188055798.tar.gz
gentoo-2-a6fe19f96f93c0fd76fbb558251b49c188055798.tar.bz2
gentoo-2-a6fe19f96f93c0fd76fbb558251b49c188055798.zip
Version bump
(Portage version: 2.2.8-prefix/cvs/Linux x86_64, signed Manifest commit with key 0x13CB1360)
Diffstat (limited to 'dev-python/blaze')
-rw-r--r--dev-python/blaze/ChangeLog7
-rw-r--r--dev-python/blaze/blaze-0.4.2.ebuild48
2 files changed, 54 insertions, 1 deletions
diff --git a/dev-python/blaze/ChangeLog b/dev-python/blaze/ChangeLog
index 567d011ab269..8ca15b54f427 100644
--- a/dev-python/blaze/ChangeLog
+++ b/dev-python/blaze/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/blaze
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/blaze/ChangeLog,v 1.2 2014/02/13 20:43:47 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/blaze/ChangeLog,v 1.3 2014/02/22 23:53:06 bicatali Exp $
+
+*blaze-0.4.2 (22 Feb 2014)
+
+ 22 Feb 2014; Sébastien Fabbro <bicatali@gentoo.org> +blaze-0.4.2.ebuild:
+ Version bump
13 Feb 2014; Sébastien Fabbro <bicatali@gentoo.org> blaze-0.4.1.ebuild:
after better testing, remove python-3.2 support
diff --git a/dev-python/blaze/blaze-0.4.2.ebuild b/dev-python/blaze/blaze-0.4.2.ebuild
new file mode 100644
index 000000000000..768f65e64f08
--- /dev/null
+++ b/dev-python/blaze/blaze-0.4.2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/blaze/blaze-0.4.2.ebuild,v 1.1 2014/02/22 23:53:06 bicatali Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7,3_3} )
+
+inherit distutils-r1
+
+DESCRIPTION="Next generation Python numpy"
+HOMEPAGE="http://blaze.pydata.org/"
+SRC_URI="https://github.com/ContinuumIO/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+IUSE="examples test"
+
+RDEPEND="
+ dev-python/llvmpy[${PYTHON_USEDEP}]
+ dev-python/blz[${PYTHON_USEDEP}]
+ dev-python/datashape[${PYTHON_USEDEP}]
+ dev-python/dynd-python[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.6[${PYTHON_USEDEP}]
+ dev-python/numba[${PYTHON_USEDEP}]
+ dev-python/pykit[${PYTHON_USEDEP}]
+ virtual/python-argparse[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ >=dev-python/cython-0.18[${PYTHON_USEDEP}]
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ cd "${BUILD_DIR}"/lib || die
+ ${PYTHON} -c 'import blaze; blaze.test()' || die
+}
+
+python_install_all() {
+ # doc needs obsolete sphnxjp package
+ #use doc && local HTML_DOCS=( docs/_build/html )
+ use examples && local EXAMPLES=( samples )
+ distutils-r1_python_install_all
+}