summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2015-06-06 10:53:40 +0000
committerIan Delaney <idella4@gentoo.org>2015-06-06 10:53:40 +0000
commit61ec3c9b9b5ff3db1d248e0c31d89b10804ebbd8 (patch)
tree14155cfbc0b07f4459e2003dc754913e85aec6a9 /dev-python/blaze
parentAdd github to remote-id in metadata.xml (diff)
downloadgentoo-2-61ec3c9b9b5ff3db1d248e0c31d89b10804ebbd8.tar.gz
gentoo-2-61ec3c9b9b5ff3db1d248e0c31d89b10804ebbd8.tar.bz2
gentoo-2-61ec3c9b9b5ff3db1d248e0c31d89b10804ebbd8.zip
bump one remove
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/blaze')
-rw-r--r--dev-python/blaze/ChangeLog8
-rw-r--r--dev-python/blaze/blaze-0.8.0.ebuild (renamed from dev-python/blaze/blaze-0.7.2-r1.ebuild)41
2 files changed, 29 insertions, 20 deletions
diff --git a/dev-python/blaze/ChangeLog b/dev-python/blaze/ChangeLog
index 142c01660dd6..40998ab04185 100644
--- a/dev-python/blaze/ChangeLog
+++ b/dev-python/blaze/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/blaze
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/blaze/ChangeLog,v 1.18 2015/03/17 07:02:36 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/blaze/ChangeLog,v 1.19 2015/06/06 10:53:40 idella4 Exp $
+
+*blaze-0.8.0 (06 Jun 2015)
+
+ 06 Jun 2015; Ian Delaney <idella4@gentoo.org> +blaze-0.8.0.ebuild,
+ -blaze-0.7.2-r1.ebuild:
+ bump one remove
*blaze-0.7.3 (17 Mar 2015)
diff --git a/dev-python/blaze/blaze-0.7.2-r1.ebuild b/dev-python/blaze/blaze-0.8.0.ebuild
index 41bd3ee62632..83fa49ade7b2 100644
--- a/dev-python/blaze/blaze-0.7.2-r1.ebuild
+++ b/dev-python/blaze/blaze-0.8.0.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/blaze/blaze-0.7.2-r1.ebuild,v 1.1 2015/03/01 14:55:36 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/blaze/blaze-0.8.0.ebuild,v 1.1 2015/06/06 10:53:40 idella4 Exp $
EAPI=5
PYTHON_COMPAT=( python{2_7,3_3,3_4} )
# Tests attempt to import mystery modules in datashape
-RESTRICT="test"
+#RESTRICT="test"
inherit distutils-r1
@@ -24,40 +24,40 @@ KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
IUSE="doc examples test"
# pyspark appears an optional dep not in portage. pyskit appears to be dropped
-# pyparsing looks to be required still despite its absence from requirements.txt
+# some p0ackages including pyparsing appear required despite their absence from requirements.txt
+
PY2_USEDEP=$(python_gen_usedep python2_7)
RDEPEND="
- >=dev-python/blz-0.6.2[${PYTHON_USEDEP}]
- =dev-python/datashape-0.4*[${PYTHON_USEDEP}]
+ <dev-python/datashape-0.4.4[${PYTHON_USEDEP}]
>=dev-python/dynd-python-0.6.5[${PYTHON_USEDEP}]
>=dev-python/numpy-1.7[${PYTHON_USEDEP}]
dev-python/pyparsing[${PYTHON_USEDEP}]
dev-python/toolz[${PYTHON_USEDEP}]
dev-python/cytoolz[${PYTHON_USEDEP}]
- dev-python/pandas[${PYTHON_USEDEP}]
+ >=dev-python/pandas-0.15.0[${PYTHON_USEDEP}]
dev-python/h5py[${PYTHON_USEDEP}]
dev-python/unicodecsv[${PY2_USEDEP}]
>=dev-python/multipledispatch-0.4.7[${PYTHON_USEDEP}]
dev-python/requests[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
>=dev-python/flask-0.10.1[${PY2_USEDEP}]
- dev-python/sqlalchemy[${PYTHON_USEDEP}]
- dev-python/pytables[${PYTHON_USEDEP}]
- dev-python/pymongo[${PYTHON_USEDEP}]
+ >=dev-python/sqlalchemy-0.8.0[${PYTHON_USEDEP}]
+ >=dev-python/pytables-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/pymongo-2.8[${PYTHON_USEDEP}]
dev-python/xlrd[${PYTHON_USEDEP}]
dev-python/psutil[${PYTHON_USEDEP}]
dev-python/into[${PYTHON_USEDEP}]
dev-python/networkx[${PYTHON_USEDEP}]
- dev-python/numba[${PYTHON_USEDEP}]
+ <dev-python/numba-0.18.2[${PYTHON_USEDEP}]
dev-python/bcolz[${PYTHON_USEDEP}]
- "
+ >=dev-python/odo-0.3.1[${PYTHON_USEDEP}]"
DEPEND="
>=dev-python/cython-0.18[${PYTHON_USEDEP}]
doc? ( dev-python/sphinx[${PYTHON_USEDEP}]
>=dev-python/numpy-1.7[${PYTHON_USEDEP}]
dev-python/toolz[${PYTHON_USEDEP}]
dev-python/bokeh[${PYTHON_USEDEP}] )
- test? ( ${RDEPEND}
+ test? ( ${RDEPEND}
+ dev-python/pytest[${PYTHON_USEDEP}]
dev-python/pyyaml[${PYTHON_USEDEP}] )
"
# Currently doc build fails, reason unclear but appears it's tied to use of
@@ -70,14 +70,17 @@ python_prepare_all() {
distutils-r1_python_prepare_all
}
-#python_compile_all() {
-# use doc && emake -C docs html
-#}
+python_compile_all() {
+ use doc && emake -C docs html
+}
python_test() {
- # https://github.com/ContinuumIO/blaze/issues/791
- cd "${BUILD_DIR}"/lib || die
- "${PYTHON}" -c 'import blaze; blaze.test()' || die
+ # https://github.com/ContinuumIO/blaze/issues/1117
+ # skip test requiring a server daemon
+ # 3 known test failures + 1 error but all 4 already resolved upstream
+ # For now await next release
+ py.test --ignore blaze/compute/tests/test_mongo_compute.py blaze \
+ || die "Tests failed under ${EPYTHON}"
}
python_install_all() {