summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-06-18 11:09:36 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-06-18 11:09:36 +0000
commiteeff590ccc98a31d1b4c31eb9e36848c632b31e3 (patch)
treeccca71a1fb042a98754a79eb0bd403ef045e986d /dev-python/beautifulsoup
parentRemove dependency on sys-libs/e2fsprogs-libs. (diff)
downloadgentoo-2-eeff590ccc98a31d1b4c31eb9e36848c632b31e3.tar.gz
gentoo-2-eeff590ccc98a31d1b4c31eb9e36848c632b31e3.tar.bz2
gentoo-2-eeff590ccc98a31d1b4c31eb9e36848c632b31e3.zip
Version bump.
(Portage version: HEAD/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/beautifulsoup')
-rw-r--r--dev-python/beautifulsoup/ChangeLog8
-rw-r--r--dev-python/beautifulsoup/beautifulsoup-3.0.8.1.ebuild36
2 files changed, 43 insertions, 1 deletions
diff --git a/dev-python/beautifulsoup/ChangeLog b/dev-python/beautifulsoup/ChangeLog
index 6de7a0c4581e..00ead4aa921f 100644
--- a/dev-python/beautifulsoup/ChangeLog
+++ b/dev-python/beautifulsoup/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/beautifulsoup
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/beautifulsoup/ChangeLog,v 1.34 2010/05/22 16:15:36 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/beautifulsoup/ChangeLog,v 1.35 2010/06/18 11:09:36 arfrever Exp $
+
+*beautifulsoup-3.0.8.1 (18 Jun 2010)
+
+ 18 Jun 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ -beautifulsoup-3.0.7.ebuild, +beautifulsoup-3.0.8.1.ebuild:
+ Version bump.
22 May 2010; Raúl Porcel <armin76@gentoo.org> beautifulsoup-3.0.7.ebuild,
beautifulsoup-3.0.8.ebuild, beautifulsoup-3.1.0.1-r1.ebuild:
diff --git a/dev-python/beautifulsoup/beautifulsoup-3.0.8.1.ebuild b/dev-python/beautifulsoup/beautifulsoup-3.0.8.1.ebuild
new file mode 100644
index 000000000000..ba139c2ea8b8
--- /dev/null
+++ b/dev-python/beautifulsoup/beautifulsoup-3.0.8.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/beautifulsoup/beautifulsoup-3.0.8.1.ebuild,v 1.1 2010/06/18 11:09:36 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit distutils
+
+MY_PN="BeautifulSoup"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="HTML/XML parser for quick-turnaround applications like screen-scraping."
+HOMEPAGE="http://www.crummy.com/software/BeautifulSoup/ http://pypi.python.org/pypi/BeautifulSoup"
+SRC_URI="http://www.crummy.com/software/${MY_PN}/download/3.x/${MY_P}.tar.gz"
+
+LICENSE="PSF-2.3"
+SLOT="3.0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux"
+IUSE=""
+
+DEPEND=""
+RDEPEND="!dev-python/beautifulsoup:0"
+
+S="${WORKDIR}/${MY_P}"
+
+PYTHON_MODNAME="BeautifulSoup.py BeautifulSoupTests.py"
+
+src_test() {
+ testing() {
+ PYTHONPATH="build-${PYTHON_ABI}/lib" "$(PYTHON)" BeautifulSoupTests.py
+ }
+ python_execute_function testing
+}