summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-09-17 05:31:39 +0000
committerIan Delaney <idella4@gentoo.org>2014-09-17 05:31:39 +0000
commitb50c95e639ac920ddc5acab6e5c0526943dbf9e5 (patch)
tree3e628302624f4b51ef039ef5a4ca7aacc32f6c3f /dev-python/autopep8
parentVersion bump. (diff)
downloadgentoo-2-b50c95e639ac920ddc5acab6e5c0526943dbf9e5.tar.gz
gentoo-2-b50c95e639ac920ddc5acab6e5c0526943dbf9e5.tar.bz2
gentoo-2-b50c95e639ac920ddc5acab6e5c0526943dbf9e5.zip
bump
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/autopep8')
-rw-r--r--dev-python/autopep8/ChangeLog7
-rw-r--r--dev-python/autopep8/autopep8-1.0.4.ebuild41
2 files changed, 47 insertions, 1 deletions
diff --git a/dev-python/autopep8/ChangeLog b/dev-python/autopep8/ChangeLog
index 1f41b7884a67..4f70bebe316e 100644
--- a/dev-python/autopep8/ChangeLog
+++ b/dev-python/autopep8/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/autopep8
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/autopep8/ChangeLog,v 1.49 2014/06/12 04:57:30 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/autopep8/ChangeLog,v 1.50 2014/09/17 05:31:39 idella4 Exp $
+
+*autopep8-1.0.4 (17 Sep 2014)
+
+ 17 Sep 2014; Ian Delaney <idella4@gentoo.org> +autopep8-1.0.4.ebuild:
+ bump
*autopep8-1.0.3 (12 Jun 2014)
diff --git a/dev-python/autopep8/autopep8-1.0.4.ebuild b/dev-python/autopep8/autopep8-1.0.4.ebuild
new file mode 100644
index 000000000000..91377efb9b1a
--- /dev/null
+++ b/dev-python/autopep8/autopep8-1.0.4.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/autopep8/autopep8-1.0.4.ebuild,v 1.1 2014/09/17 05:31:39 idella4 Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="Automatically formats Python code to conform to the PEP 8 style guide"
+HOMEPAGE="https://github.com/hhatto/autopep8 http://pypi.python.org/pypi/autopep8"
+SRC_URI="https://github.com/hhatto/${PN}/tarball/ver${PV} -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND=">=dev-python/pep8-1.5.7[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=""
+
+python_prepare_all() {
+ # Prevent UnicodeDecodeError with LANG=C
+ sed -e "/é/d" -i MANIFEST.in || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ esetup.py test
+}
+
+pkg_postinst() {
+ ewarn "Since this version of autopep depends on >=dev-python/pep8-1.3"
+ ewarn "it is affected by https://github.com/jcrocholl/pep8/issues/45"
+ ewarn "(indentation checks inside triple-quotes)."
+ ewarn "If you do not want to be affected by this, then add the"
+ ewarn "following lines to your local package.mask:"
+ ewarn " >=dev-python/pep8-1.3"
+ ewarn " >=dev-python/autopep8-0.6"
+}