summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2013-02-22 03:37:01 +0000
committerPatrick Lauer <patrick@gentoo.org>2013-02-22 03:37:01 +0000
commitb2cdcfc1d00509c251d40f3542b9eb5a15d3c5e7 (patch)
tree4318c4711418e07a1608664223518a57ce8f050d /dev-python/authres
parentBump (diff)
downloadgentoo-2-b2cdcfc1d00509c251d40f3542b9eb5a15d3c5e7.tar.gz
gentoo-2-b2cdcfc1d00509c251d40f3542b9eb5a15d3c5e7.tar.bz2
gentoo-2-b2cdcfc1d00509c251d40f3542b9eb5a15d3c5e7.zip
Bump
(Portage version: 2.2.0_alpha163/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-python/authres')
-rw-r--r--dev-python/authres/ChangeLog9
-rw-r--r--dev-python/authres/authres-0.500.ebuild29
2 files changed, 36 insertions, 2 deletions
diff --git a/dev-python/authres/ChangeLog b/dev-python/authres/ChangeLog
index 0c767b0ed2bb..34095188311c 100644
--- a/dev-python/authres/ChangeLog
+++ b/dev-python/authres/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/authres
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/authres/ChangeLog,v 1.7 2012/06/28 06:05:53 patrick Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/authres/ChangeLog,v 1.8 2013/02/22 03:37:01 patrick Exp $
+
+*authres-0.500 (22 Feb 2013)
+
+ 22 Feb 2013; Patrick Lauer <patrick@gentoo.org> +authres-0.500.ebuild:
+ Bump
*authres-0.402 (28 Jun 2012)
diff --git a/dev-python/authres/authres-0.500.ebuild b/dev-python/authres/authres-0.500.ebuild
new file mode 100644
index 000000000000..266d7b194168
--- /dev/null
+++ b/dev-python/authres/authres-0.500.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/authres/authres-0.500.ebuild,v 1.1 2013/02/22 03:37:01 patrick Exp $
+
+EAPI=4
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.5"
+
+inherit distutils
+
+DESCRIPTION="Authentication Results Header Module"
+HOMEPAGE="https://launchpad.net/authentication-results-python http://pypi.python.org/pypi/authres"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE=""
+
+DOCS="CHANGES README"
+
+src_test() {
+ testing() {
+ PYTHONPATH="$(ls -d build-${PYTHON_ABI}/lib*)" "$(PYTHON)" \
+ -c "import sys, ${PN}, doctest; f, t = doctest.testfile('${PN}/tests'); \
+ sys.exit(bool(f))" || return
+ }
+ python_execute_function testing
+}