summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2015-07-02 10:40:44 +0000
committerManuel Rüger <mrueg@gentoo.org>2015-07-02 10:40:44 +0000
commit6587c8dc139eaf2c3364d1df37b47f305a752657 (patch)
tree3d2676d14fbb56fbfe50e44da822287a0dcb2134 /dev-python/astroid
parentpycadf-0.8.0.ebuild; tidy & correction to deps: 1 missing dep for doc build, ... (diff)
downloadgentoo-2-6587c8dc139eaf2c3364d1df37b47f305a752657.tar.gz
gentoo-2-6587c8dc139eaf2c3364d1df37b47f305a752657.tar.bz2
gentoo-2-6587c8dc139eaf2c3364d1df37b47f305a752657.zip
Remove old.
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-python/astroid')
-rw-r--r--dev-python/astroid/ChangeLog6
-rw-r--r--dev-python/astroid/astroid-1.0.1-r1.ebuild52
-rw-r--r--dev-python/astroid/astroid-1.0.1.ebuild48
-rw-r--r--dev-python/astroid/astroid-1.1.1.ebuild51
-rw-r--r--dev-python/astroid/astroid-1.3.2.ebuild43
5 files changed, 5 insertions, 195 deletions
diff --git a/dev-python/astroid/ChangeLog b/dev-python/astroid/ChangeLog
index f75fd309eefb..e976a97cea37 100644
--- a/dev-python/astroid/ChangeLog
+++ b/dev-python/astroid/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/astroid
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/astroid/ChangeLog,v 1.23 2015/06/07 19:17:49 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/astroid/ChangeLog,v 1.24 2015/07/02 10:40:44 mrueg Exp $
+
+ 02 Jul 2015; Manuel Rüger <mrueg@gentoo.org> -astroid-1.0.1-r1.ebuild,
+ -astroid-1.0.1.ebuild, -astroid-1.1.1.ebuild, -astroid-1.3.2.ebuild:
+ Remove old.
07 Jun 2015; Justin Lecher <jlec@gentoo.org> metadata.xml:
Add bitbucket to remote-id in metadata.xml
diff --git a/dev-python/astroid/astroid-1.0.1-r1.ebuild b/dev-python/astroid/astroid-1.0.1-r1.ebuild
deleted file mode 100644
index 669497646b6f..000000000000
--- a/dev-python/astroid/astroid-1.0.1-r1.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/astroid/astroid-1.0.1-r1.ebuild,v 1.4 2015/04/08 08:05:25 mgorny Exp $
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_7,3_3} pypy )
-
-inherit distutils-r1
-
-DESCRIPTION="Abstract Syntax Tree for logilab packages"
-HOMEPAGE="http://bitbucket.org/logilab/astroid http://pypi.python.org/pypi/astroid"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x64-macos ~x86-macos"
-IUSE="test"
-
-PY23_USEDEP=$(python_gen_usedep 'python2*' 'python3*')
-RDEPEND=">=dev-python/logilab-common-0.60.0[${PYTHON_USEDEP}]"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( ${RDEPEND}
- >=dev-python/pylint-1.1.0[${PY23_USEDEP}] )"
-# Required for tests
-DISTUTILS_IN_SOURCE_BUILD=1
-
-PY23_REQUSE="|| ( $(python_gen_useflags python2* python3*) )"
-REQUIRED_USE="test? ( ${PY23_REQUSE} )"
-
-python_prepare_all() {
- # https://bitbucket.org/logilab/astroid/issue/8/
- sed -e "s/test_numpy_crash/_&/" -i test/unittest_regrtest.py
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- # https://bitbucket.org/logilab/astroid/issue/1/test-suite-fails-in-0243-under-py32-pypy
- # https://bitbucket.org/logilab/astroid/issue/16/1-test-fail-test_socket_build-under-pypy
- # test_hashlib fails only in py3.2
- python setup.py build
-
- pushd build/lib > /dev/null
- if [[ "${EPYTHON}" == pypy* ]]; then
- sed -e 's:test_socket_build:_&:' -i ${PN}/test/unittest_builder.py || die
- elif [[ "${EPYTHON}" == 'python3.2' ]]; then
- sed -e 's:test_hashlib:_&:' -i ${PN}/test/unittest_brain.py || die
- fi
- PYTHONPATH=. pytest || die "Tests fail with ${EPYTHON}"
- popd > /dev/null
-}
diff --git a/dev-python/astroid/astroid-1.0.1.ebuild b/dev-python/astroid/astroid-1.0.1.ebuild
deleted file mode 100644
index 23ea46a8ed18..000000000000
--- a/dev-python/astroid/astroid-1.0.1.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/astroid/astroid-1.0.1.ebuild,v 1.3 2015/04/08 08:05:25 mgorny Exp $
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_7,3_3} pypy )
-
-inherit distutils-r1
-
-DESCRIPTION="Abstract Syntax Tree for logilab packages"
-HOMEPAGE="http://bitbucket.org/logilab/astroid http://pypi.python.org/pypi/astroid"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x64-macos ~x86-macos"
-IUSE="test"
-
-# Version specified in __pkginfo__.py.
-RDEPEND=">=dev-python/logilab-common-0.60.0[${PYTHON_USEDEP}]"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( ${RDEPEND} )"
-# Required for tests
-DISTUTILS_IN_SOURCE_BUILD=1
-
-python_prepare_all() {
- # https://bitbucket.org/logilab/astroid/issue/8/
- sed -e "s/test_numpy_crash/_&/" -i test/unittest_regrtest.py
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- # https://bitbucket.org/logilab/astroid/issue/1/test-suite-fails-in-0243-under-py32-pypy
- # https://bitbucket.org/logilab/astroid/issue/16/1-test-fail-test_socket_build-under-pypy
- # test_hashlib fails only in py3.2
- python setup.py build
-
- pushd build/lib > /dev/null
- if [[ "${EPYTHON}" == pypy* ]]; then
- sed -e 's:test_socket_build:_&:' -i ${PN}/test/unittest_builder.py || die
- elif [[ "${EPYTHON}" == 'python3.2' ]]; then
- sed -e 's:test_hashlib:_&:' -i ${PN}/test/unittest_brain.py || die
- fi
- PYTHONPATH=. pytest || die "Tests fail with ${EPYTHON}"
- popd > /dev/null
-}
diff --git a/dev-python/astroid/astroid-1.1.1.ebuild b/dev-python/astroid/astroid-1.1.1.ebuild
deleted file mode 100644
index 2a434b9aedf2..000000000000
--- a/dev-python/astroid/astroid-1.1.1.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/astroid/astroid-1.1.1.ebuild,v 1.1 2014/05/08 09:37:16 idella4 Exp $
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
-
-inherit distutils-r1
-
-DESCRIPTION="Abstract Syntax Tree for logilab packages"
-HOMEPAGE="http://bitbucket.org/logilab/astroid http://pypi.python.org/pypi/astroid"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x64-macos ~x86-macos"
-IUSE="test"
-
-# Version specified in __pkginfo__.py.
-RDEPEND=">=dev-python/logilab-common-0.60.0[${PYTHON_USEDEP}]"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( ${RDEPEND}
- >=dev-python/pylint-1.1.0[${PYTHON_USEDEP}] )"
-# Required for tests
-DISTUTILS_IN_SOURCE_BUILD=1
-
-python_prepare_all() {
- # https://bitbucket.org/logilab/astroid/issue/8/
- sed -e "s/test_numpy_crash/_&/" -i test/unittest_regrtest.py
-
- distutils-r1_python_prepare_all
-}
-
-# Restrict to test phase, required because suite fails horribly without it
-src_test() {
- local DISTUTILS_NO_PARALLEL_BUILD=1
- distutils-r1_src_test
-}
-
-python_test() {
- # https://bitbucket.org/logilab/astroid/issue/16/1-test-fail-test_socket_build-under-pypy
- python setup.py build
-
- pushd build/lib > /dev/null
- if [[ "${EPYTHON}" == pypy* ]]; then
- sed -e 's:test_socket_build:_&:' -i ${PN}/test/unittest_builder.py || die
- fi
- PYTHONPATH=. pytest || die "Tests fail with ${EPYTHON}"
- popd > /dev/null
-}
diff --git a/dev-python/astroid/astroid-1.3.2.ebuild b/dev-python/astroid/astroid-1.3.2.ebuild
deleted file mode 100644
index 1b90dfb9b9b1..000000000000
--- a/dev-python/astroid/astroid-1.3.2.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/astroid/astroid-1.3.2.ebuild,v 1.1 2014/12/10 07:51:39 patrick Exp $
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
-RESTRICT="test" # False is not True ;)
-
-inherit distutils-r1
-
-DESCRIPTION="Abstract Syntax Tree for logilab packages"
-HOMEPAGE="http://bitbucket.org/logilab/astroid http://pypi.python.org/pypi/astroid"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x64-macos ~x86-macos"
-IUSE="test"
-
-# Version specified in __pkginfo__.py.
-RDEPEND=">=dev-python/logilab-common-0.60.0[${PYTHON_USEDEP}]"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- app-arch/unzip
- test? ( ${RDEPEND}
- >=dev-python/pylint-1.4.0[${PYTHON_USEDEP}]
- $(python_gen_cond_dep 'dev-python/egenix-mx-base[${PYTHON_USEDEP}]' python2_7) )"
-# Required for tests
-DISTUTILS_IN_SOURCE_BUILD=1
-
-# Restrict to test phase, required because suite fails horribly without it
-src_test() {
- local DISTUTILS_NO_PARALLEL_BUILD=1
- distutils-r1_src_test
-}
-
-python_test() {
- "${PYTHON}" setup.py build
-
- pushd build/lib > /dev/null
- PYTHONPATH=. pytest || die "Tests fail with ${EPYTHON}"
- popd > /dev/null
-}