summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-11-04 11:02:55 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-11-04 11:02:55 +0000
commit7724a2e5cef1a49bd08fc32c120b3f0c522fdf25 (patch)
tree610a7a3335551250683e0419e83e371d180db326 /dev-python/argparse
parentDie more often. (diff)
downloadgentoo-2-7724a2e5cef1a49bd08fc32c120b3f0c522fdf25.tar.gz
gentoo-2-7724a2e5cef1a49bd08fc32c120b3f0c522fdf25.tar.bz2
gentoo-2-7724a2e5cef1a49bd08fc32c120b3f0c522fdf25.zip
Define src_test(). Update HOMEPAGE. Support Python 3.
(Portage version: 14775-svn/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/argparse')
-rw-r--r--dev-python/argparse/ChangeLog6
-rw-r--r--dev-python/argparse/argparse-1.0.1.ebuild13
2 files changed, 15 insertions, 4 deletions
diff --git a/dev-python/argparse/ChangeLog b/dev-python/argparse/ChangeLog
index 8f95b27a93ff..de59ede447f3 100644
--- a/dev-python/argparse/ChangeLog
+++ b/dev-python/argparse/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/argparse
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/argparse/ChangeLog,v 1.1 2009/10/20 19:46:33 djc Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/argparse/ChangeLog,v 1.2 2009/11/04 11:02:55 arfrever Exp $
+
+ 04 Nov 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ argparse-1.0.1.ebuild:
+ Define src_test(). Update HOMEPAGE. Support Python 3.
*argparse-1.0.1 (20 Oct 2009)
diff --git a/dev-python/argparse/argparse-1.0.1.ebuild b/dev-python/argparse/argparse-1.0.1.ebuild
index 8a51a0c476a6..ea2833b4cfeb 100644
--- a/dev-python/argparse/argparse-1.0.1.ebuild
+++ b/dev-python/argparse/argparse-1.0.1.ebuild
@@ -1,13 +1,14 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/argparse/argparse-1.0.1.ebuild,v 1.1 2009/10/20 19:46:33 djc Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/argparse/argparse-1.0.1.ebuild,v 1.2 2009/11/04 11:02:55 arfrever Exp $
+EAPI="2"
SUPPORT_PYTHON_ABIS="1"
inherit distutils
DESCRIPTION="Provides an easy, declarative interface for creating command line tools."
-HOMEPAGE="http://code.google.com/p/argparse/"
+HOMEPAGE="http://code.google.com/p/argparse/ http://pypi.python.org/pypi/argparse"
SRC_URI="http://argparse.googlecode.com/files/${P}.zip"
LICENSE="Apache-2.0"
@@ -17,4 +18,10 @@ IUSE=""
DEPEND=""
RDEPEND=""
-RESTRICT_PYTHON_ABIS="3.*"
+
+src_test() {
+ testing() {
+ PYTHONPATH="build-${PYTHON_ABI}/lib" "$(PYTHON)" test/test_argparse.py
+ }
+ python_execute_function testing
+}