summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2015-06-07 02:45:00 +0000
committerIan Delaney <idella4@gentoo.org>2015-06-07 02:45:00 +0000
commitf8abd7534ea16c74d40ce1f67dbdd0358b16cee5 (patch)
treea84da93aa59ee264406a1fbf9dfae9125bcc27c6 /dev-python/argcomplete
parentInitial commit. (diff)
downloadgentoo-2-f8abd7534ea16c74d40ce1f67dbdd0358b16cee5.tar.gz
gentoo-2-f8abd7534ea16c74d40ce1f67dbdd0358b16cee5.tar.bz2
gentoo-2-f8abd7534ea16c74d40ce1f67dbdd0358b16cee5.zip
bump
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/argcomplete')
-rw-r--r--dev-python/argcomplete/ChangeLog8
-rw-r--r--dev-python/argcomplete/argcomplete-0.6.5.ebuild22
-rw-r--r--dev-python/argcomplete/argcomplete-0.8.9.ebuild (renamed from dev-python/argcomplete/argcomplete-0.6.5-r1.ebuild)21
3 files changed, 23 insertions, 28 deletions
diff --git a/dev-python/argcomplete/ChangeLog b/dev-python/argcomplete/ChangeLog
index 021619d0d76d..6302e77a574d 100644
--- a/dev-python/argcomplete/ChangeLog
+++ b/dev-python/argcomplete/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/argcomplete
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/argcomplete/ChangeLog,v 1.13 2015/06/03 12:19:59 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/argcomplete/ChangeLog,v 1.14 2015/06/07 02:45:00 idella4 Exp $
+
+*argcomplete-0.8.9 (07 Jun 2015)
+
+ 07 Jun 2015; Ian Delaney <idella4@gentoo.org> +argcomplete-0.8.9.ebuild,
+ -argcomplete-0.6.5-r1.ebuild, -argcomplete-0.6.5.ebuild:
+ bump
03 Jun 2015; Justin Lecher <jlec@gentoo.org> metadata.xml:
Add pypi to remote-id in metadata.xml
diff --git a/dev-python/argcomplete/argcomplete-0.6.5.ebuild b/dev-python/argcomplete/argcomplete-0.6.5.ebuild
deleted file mode 100644
index 7a7eb632e6da..000000000000
--- a/dev-python/argcomplete/argcomplete-0.6.5.ebuild
+++ /dev/null
@@ -1,22 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/argcomplete/argcomplete-0.6.5.ebuild,v 1.7 2015/04/08 08:04:54 mgorny Exp $
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_7,3_3,3_4} )
-
-inherit distutils-r1
-
-DESCRIPTION="Bash tab completion for argparse"
-HOMEPAGE="https://pypi.python.org/pypi/argcomplete"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-SLOT="0"
-LICENSE="Apache-2.0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~x64-macos"
-IUSE=""
-
-RDEPEND=""
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]"
diff --git a/dev-python/argcomplete/argcomplete-0.6.5-r1.ebuild b/dev-python/argcomplete/argcomplete-0.8.9.ebuild
index fd9a2f1f746b..bb44f3fa4b39 100644
--- a/dev-python/argcomplete/argcomplete-0.6.5-r1.ebuild
+++ b/dev-python/argcomplete/argcomplete-0.8.9.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/argcomplete/argcomplete-0.6.5-r1.ebuild,v 1.2 2015/04/08 08:04:54 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/argcomplete/argcomplete-0.8.9.ebuild,v 1.1 2015/06/07 02:45:00 idella4 Exp $
EAPI=5
PYTHON_COMPAT=( python{2_7,3_3,3_4} )
-inherit distutils-r1
+inherit distutils-r1 bash-completion-r1
DESCRIPTION="Bash tab completion for argparse"
HOMEPAGE="https://pypi.python.org/pypi/argcomplete"
@@ -17,12 +17,23 @@ LICENSE="Apache-2.0"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~x64-macos"
IUSE=""
-RDEPEND=""
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
python_prepare_all() {
# purge test folder to avoid file collisions
sed -e "s:find_packages():find_packages(exclude=['test','test.*']):" -i setup.py || die
distutils-r1_python_prepare_all
}
+
+python_test() {
+ ${EPYTHON} test/test.py || die
+}
+
+python_install_all() {
+ sed \
+ -e "/complete /d" \
+ -i argcomplete/bash_completion.d/python-argcomplete.sh || die
+
+ distutils-r1_python_install_all
+ newbashcomp "${S}"/${PN}/bash_completion.d/python-argcomplete.sh python-${PN}
+}