summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2013-03-11 06:26:09 +0000
committerPatrick Lauer <patrick@gentoo.org>2013-03-11 06:26:09 +0000
commit5578f0ff7338743457e1ace9bc65c4c63caf4a94 (patch)
treee26513edf3825039761005ad2a27cbcd3b3a9695 /dev-python/ansi2html/ansi2html-0.9.4.ebuild
parentBump (diff)
downloadgentoo-2-5578f0ff7338743457e1ace9bc65c4c63caf4a94.tar.gz
gentoo-2-5578f0ff7338743457e1ace9bc65c4c63caf4a94.tar.bz2
gentoo-2-5578f0ff7338743457e1ace9bc65c4c63caf4a94.zip
Bump
(Portage version: 2.2.0_alpha166/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-python/ansi2html/ansi2html-0.9.4.ebuild')
-rw-r--r--dev-python/ansi2html/ansi2html-0.9.4.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/ansi2html/ansi2html-0.9.4.ebuild b/dev-python/ansi2html/ansi2html-0.9.4.ebuild
new file mode 100644
index 000000000000..b9892b0cfb2c
--- /dev/null
+++ b/dev-python/ansi2html/ansi2html-0.9.4.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/ansi2html/ansi2html-0.9.4.ebuild,v 1.1 2013/03/11 06:26:09 patrick Exp $
+
+EAPI=5
+
+# ordereddict is need for < 2.7, but it's not packaged (yet)
+PYTHON_COMPAT=( python{2_7,3_1,3_2,3_3} pypy{1_9,2_0} )
+
+inherit distutils-r1
+
+DESCRIPTION="Convert text with ANSI color codes to HTML"
+HOMEPAGE="http://pypi.python.org/pypi/ansi2html https://github.com/ralphbean/ansi2html"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ nosetests -w tests \
+ || die "Tests fail with ${EPYTHON}"
+}