summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2014-08-10 12:18:56 +0000
committerTiziano Müller <dev-zero@gentoo.org>2014-08-10 12:18:56 +0000
commit92fc2fcd6757c6d048c48a8cba135bedfcab4377 (patch)
treeec054933bc3389862a73e953a5cc07fb27b50508 /dev-python/amara
parentForce acl for netatalk, #516626 (diff)
downloadgentoo-2-92fc2fcd6757c6d048c48a8cba135bedfcab4377.tar.gz
gentoo-2-92fc2fcd6757c6d048c48a8cba135bedfcab4377.tar.bz2
gentoo-2-92fc2fcd6757c6d048c48a8cba135bedfcab4377.zip
Version bump, un-unbundle expat to fix bug #452962 (tests segfault). Disable tests since notoriously broken.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0x1A5D023975B0583D!)
Diffstat (limited to 'dev-python/amara')
-rw-r--r--dev-python/amara/ChangeLog12
-rw-r--r--dev-python/amara/amara-2.0.0.ebuild54
-rw-r--r--dev-python/amara/amara-2.0.0_alpha6-r1.ebuild49
-rw-r--r--dev-python/amara/amara-2.0.0_alpha6.ebuild45
-rw-r--r--dev-python/amara/files/2.0.0_alpha6-unbundle-expat.patch45
5 files changed, 64 insertions, 141 deletions
diff --git a/dev-python/amara/ChangeLog b/dev-python/amara/ChangeLog
index 3f7326e32b79..34a079b12d55 100644
--- a/dev-python/amara/ChangeLog
+++ b/dev-python/amara/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-python/amara
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/amara/ChangeLog,v 1.6 2013/06/18 07:07:23 radhermit Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/amara/ChangeLog,v 1.7 2014/08/10 12:18:56 dev-zero Exp $
+
+*amara-2.0.0 (10 Aug 2014)
+
+ 10 Aug 2014; Tiziano Müller <dev-zero@gentoo.org> +amara-2.0.0.ebuild,
+ -amara-2.0.0_alpha6-r1.ebuild, -amara-2.0.0_alpha6.ebuild,
+ -files/2.0.0_alpha6-unbundle-expat.patch:
+ Version bump, un-unbundle expat to fix bug #452962 (tests segfault). Disable
+ tests since notoriously broken.
18 Jun 2013; Tim Harder <radhermit@gentoo.org> amara-2.0.0_alpha6-r1.ebuild:
Drop python2_5 support to match versions supported by html5lib-1.0_beta1.
diff --git a/dev-python/amara/amara-2.0.0.ebuild b/dev-python/amara/amara-2.0.0.ebuild
new file mode 100644
index 000000000000..9683e5fa0b61
--- /dev/null
+++ b/dev-python/amara/amara-2.0.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/amara/amara-2.0.0.ebuild,v 1.1 2014/08/10 12:18:56 dev-zero Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE='wide-unicode(+)'
+
+inherit distutils-r1
+
+MY_PN="Amara"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Library for XML processing in Python"
+HOMEPAGE="http://wiki.xml3k.org/Amara2"
+SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples test"
+
+RDEPEND="dev-python/html5lib[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=(
+ "${FILESDIR}/2.0.0_alpha6-unbundle-python-libs.patch"
+)
+
+# Maintainter notes:
+# * Bundles expat-2.0.0 but since it is patched we can not simply unbundle it.
+# Unbundling expat leads to a segfault, see bug #452962
+# * Many tests still fail. Documentation suggests that they came from 4suite/amara-1.x
+# and are not fully adapted to amara-2.x. Therefore disabling them.
+
+RESTRICT="test"
+
+python_test() {
+ nosetests -w test -P --exe -v || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r demo
+ docompress -x "${INSDESTTREE}"/demo
+ fi
+}
diff --git a/dev-python/amara/amara-2.0.0_alpha6-r1.ebuild b/dev-python/amara/amara-2.0.0_alpha6-r1.ebuild
deleted file mode 100644
index 22d404dbf1b0..000000000000
--- a/dev-python/amara/amara-2.0.0_alpha6-r1.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/amara/amara-2.0.0_alpha6-r1.ebuild,v 1.3 2013/06/18 07:07:23 radhermit Exp $
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_6,2_7} )
-PYTHON_REQ_USE='wide-unicode(+)'
-
-inherit distutils-r1
-
-MY_PN="Amara"
-MY_P="${MY_PN}-${PV/_alpha/a}"
-
-DESCRIPTION="Library for XML processing in Python"
-HOMEPAGE="http://wiki.xml3k.org/Amara2"
-SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.bz2"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="examples test"
-
-RDEPEND=">=dev-libs/expat-2.1.0-r2[unicode]
- dev-python/html5lib[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- test? ( dev-python/nose[${PYTHON_USEDEP}] )"
-
-S="${WORKDIR}/${MY_P}"
-
-PATCHES=(
- "${FILESDIR}/${PV}-unbundle-expat.patch"
- "${FILESDIR}/${PV}-unbundle-python-libs.patch"
-)
-
-python_test() {
- nosetests -w test --exe \
- || die "Tests fail with ${EPYTHON}"
-}
-
-python_install_all() {
- distutils-r1_python_install_all
-
- if use examples; then
- insinto /usr/share/doc/${PF}
- doins -r demo
- docompress -x "${INSDESTTREE}"/demo
- fi
-}
diff --git a/dev-python/amara/amara-2.0.0_alpha6.ebuild b/dev-python/amara/amara-2.0.0_alpha6.ebuild
deleted file mode 100644
index 73ac902393b4..000000000000
--- a/dev-python/amara/amara-2.0.0_alpha6.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/amara/amara-2.0.0_alpha6.ebuild,v 1.1 2012/05/16 09:39:14 dev-zero Exp $
-
-EAPI=4
-
-inherit distutils eutils
-
-MY_PN="Amara"
-MY_P="${MY_PN}-${PV/_alpha/a}"
-
-DESCRIPTION="Library for XML processing in Python."
-HOMEPAGE="http://wiki.xml3k.org/Amara2"
-SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.bz2"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="examples"
-
-DEPEND=">=dev-libs/expat-2.1.0-r2[unicode]
- dev-lang/python[wide-unicode]
- dev-python/html5lib"
-RDEPEND="${DEPEND}"
-
-S="${WORKDIR}/${MY_P}"
-
-src_prepare() {
- distutils_src_prepare
-
- epatch \
- "${FILESDIR}/${PV}-unbundle-expat.patch" \
- "${FILESDIR}/${PV}-unbundle-python-libs.patch"
-}
-
-src_install() {
- DOCS="CHANGES"
-
- distutils_src_install
-
- if use examples ; then
- insinto /usr/share/doc/${PF}
- doins -r demo
- fi
-}
diff --git a/dev-python/amara/files/2.0.0_alpha6-unbundle-expat.patch b/dev-python/amara/files/2.0.0_alpha6-unbundle-expat.patch
deleted file mode 100644
index 5a82e6f7f1b8..000000000000
--- a/dev-python/amara/files/2.0.0_alpha6-unbundle-expat.patch
+++ /dev/null
@@ -1,45 +0,0 @@
-diff --git a/lib/src/expat/expat.c b/lib/src/expat/expat.c
-index 4a9bf65..8e8e0a5 100644
---- a/lib/src/expat/expat.c
-+++ b/lib/src/expat/expat.c
-@@ -64,7 +64,7 @@ Expat wrapper library";
- #define XmlString_SHARED
- #include "xmlstring.h"
- #include "cStringIO.h"
--#include "lib/expat.h" /* Expat library */
-+#include <expat.h> /* Expat library */
- #include "xmlchar.h" /* XML_Char to PyUnicode support */
- #include "stack.h" /* Stack_* routines */
- #include "hash_table.h" /* XML_Char-keyed HashTable */
-diff --git a/lib/src/expat/xmlchar.h b/lib/src/expat/xmlchar.h
-index c1378b0..be4f3ac 100644
---- a/lib/src/expat/xmlchar.h
-+++ b/lib/src/expat/xmlchar.h
-@@ -6,7 +6,7 @@ extern "C" {
- #endif
-
- #include "Python.h"
--#include "lib/expat_external.h"
-+#include <expat_external.h>
-
- #ifndef XML_UNICODE
- #error ExpatReader requires a Unicode-enabled Expat
-diff --git a/setup.py b/setup.py
-index 6a0e650..f3856e3 100755
---- a/setup.py
-+++ b/setup.py
-@@ -303,12 +303,11 @@ setup(name='Amara',
- Extension('amara._expat',
- define_macros=[('HAVE_EXPAT_CONFIG_H', None),
- ('Expat_BUILDING_MODULE', None),
-+ ('XML_UNICODE_WCHAR_T', None),
- ],
- include_dirs=['lib/src', 'lib/src/expat'],
-+ libraries=['expatw'],
- sources=[# Expat XML parser
-- 'lib/src/expat/lib/xmlparse.c',
-- 'lib/src/expat/lib/xmlrole.c',
-- 'lib/src/expat/lib/xmltok.c',
- # Miscellaneous supporting routines
- 'lib/src/expat/util.c',
- # XML_Char <-> PyUnicode