summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2015-03-07 00:10:39 +0000
committerBrian Evans <grknight@gentoo.org>2015-03-07 00:10:39 +0000
commite9053454f234117f779c3f379c19598eaef8896c (patch)
tree47097e8aef3d5e15519f1d66784ff31819935700 /dev-php
parentDrop dependency on media-libs/lcms:0, which will be removed for security reas... (diff)
downloadgentoo-2-e9053454f234117f779c3f379c19598eaef8896c.tar.gz
gentoo-2-e9053454f234117f779c3f379c19598eaef8896c.tar.bz2
gentoo-2-e9053454f234117f779c3f379c19598eaef8896c.zip
Drop old
(Portage version: 2.2.17/cvs/Linux x86_64, signed Manifest commit with key 0xD1F781EFF9F4A3B6)
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/xdebug/ChangeLog6
-rw-r--r--dev-php/xdebug/xdebug-2.2.3.ebuild89
-rw-r--r--dev-php/xdebug/xdebug-2.2.5.ebuild89
3 files changed, 5 insertions, 179 deletions
diff --git a/dev-php/xdebug/ChangeLog b/dev-php/xdebug/ChangeLog
index a0903b3ebcb3..9b18eb6113d9 100644
--- a/dev-php/xdebug/ChangeLog
+++ b/dev-php/xdebug/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-php/xdebug
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/xdebug/ChangeLog,v 1.74 2015/02/25 15:44:43 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/xdebug/ChangeLog,v 1.75 2015/03/07 00:10:39 grknight Exp $
+
+ 07 Mar 2015; Brian Evans <grknight@gentoo.org> -xdebug-2.2.3.ebuild,
+ -xdebug-2.2.5.ebuild:
+ Drop old
25 Feb 2015; Agostino Sarubbo <ago@gentoo.org> xdebug-2.2.6.ebuild:
Stable for x86, wrt bug #538554
diff --git a/dev-php/xdebug/xdebug-2.2.3.ebuild b/dev-php/xdebug/xdebug-2.2.3.ebuild
deleted file mode 100644
index 30e6ab2447f0..000000000000
--- a/dev-php/xdebug/xdebug-2.2.3.ebuild
+++ /dev/null
@@ -1,89 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/xdebug/xdebug-2.2.3.ebuild,v 1.5 2013/08/23 13:41:34 ago Exp $
-
-EAPI="5"
-PHP_EXT_NAME="xdebug"
-PHP_EXT_INI="yes"
-PHP_EXT_ZENDEXT="yes"
-
-USE_PHP="php5-5 php5-3 php5-4"
-
-MY_PV="${PV/_/}"
-MY_PV="${MY_PV/rc/RC}"
-
-S="${WORKDIR}/${PN}-${MY_PV}"
-
-inherit php-ext-source-r2
-
-KEYWORDS="amd64 ~hppa ppc ppc64 x86"
-
-DESCRIPTION="A PHP debugging and profiling extension"
-HOMEPAGE="http://www.xdebug.org/"
-SRC_URI="http://pecl.php.net/get/${PN}-${MY_PV}.tgz"
-LICENSE="Xdebug"
-SLOT="0"
-IUSE=""
-
-DEPEND=""
-RDEPEND="${DEPEND}
- ~dev-php/xdebug-client-${PV}"
-
-src_install() {
- dodoc NEWS README CREDITS
- php-ext-source-r2_src_install
-
- php-ext-source-r2_addtoinifiles "xdebug.auto_trace" '"0"'
- php-ext-source-r2_addtoinifiles "xdebug.trace_output_dir" '"/tmp"'
- php-ext-source-r2_addtoinifiles "xdebug.trace_output_name" '"trace.%c"'
- php-ext-source-r2_addtoinifiles "xdebug.trace_format" '"0"'
- php-ext-source-r2_addtoinifiles "xdebug.trace_options" '"0"'
- php-ext-source-r2_addtoinifiles "xdebug.collect_includes" '"1"'
- php-ext-source-r2_addtoinifiles "xdebug.collect_params" '"0"'
- php-ext-source-r2_addtoinifiles "xdebug.collect_return" '"0"'
- php-ext-source-r2_addtoinifiles "xdebug.collect_vars" '"0"'
- php-ext-source-r2_addtoinifiles "xdebug.default_enable" '"1"'
- php-ext-source-r2_addtoinifiles "xdebug.extended_info" '"1"'
- php-ext-source-r2_addtoinifiles "xdebug.manual_url" '"http://www.php.net"'
- php-ext-source-r2_addtoinifiles "xdebug.max_nesting_level" '"100"'
- php-ext-source-r2_addtoinifiles "xdebug.show_exception_trace" '"0"'
- php-ext-source-r2_addtoinifiles "xdebug.show_local_vars" '"0"'
- php-ext-source-r2_addtoinifiles "xdebug.show_mem_delta" '"0"'
- php-ext-source-r2_addtoinifiles "xdebug.dump.COOKIE" '"NULL"'
- php-ext-source-r2_addtoinifiles "xdebug.dump.ENV" '"NULL"'
- php-ext-source-r2_addtoinifiles "xdebug.dump.FILES" '"NULL"'
- php-ext-source-r2_addtoinifiles "xdebug.dump.GET" '"NULL"'
- php-ext-source-r2_addtoinifiles "xdebug.dump.POST" '"NULL"'
- php-ext-source-r2_addtoinifiles "xdebug.dump.REQUEST" '"NULL"'
- php-ext-source-r2_addtoinifiles "xdebug.dump.SERVER" '"NULL"'
- php-ext-source-r2_addtoinifiles "xdebug.dump.SESSION" '"NULL"'
- php-ext-source-r2_addtoinifiles "xdebug.dump_globals" '"1"'
- php-ext-source-r2_addtoinifiles "xdebug.dump_once" '"1"'
- php-ext-source-r2_addtoinifiles "xdebug.dump_undefined" '"0"'
- php-ext-source-r2_addtoinifiles "xdebug.profiler_enable" '"0"'
- php-ext-source-r2_addtoinifiles "xdebug.profiler_output_dir" '"/tmp"'
- php-ext-source-r2_addtoinifiles "xdebug.profiler_output_name" '"cachegrind.out.%p"'
- php-ext-source-r2_addtoinifiles "xdebug.profiler_enable_trigger" '"0"'
- php-ext-source-r2_addtoinifiles "xdebug.profiler_append" '"0"'
- php-ext-source-r2_addtoinifiles "xdebug.profiler_aggregate" '"0"'
- php-ext-source-r2_addtoinifiles "xdebug.remote_enable" '"0"'
- php-ext-source-r2_addtoinifiles "xdebug.remote_handler" '"dbgp"'
- php-ext-source-r2_addtoinifiles "xdebug.remote_host" '"localhost"'
- php-ext-source-r2_addtoinifiles "xdebug.remote_mode" '"req"'
- php-ext-source-r2_addtoinifiles "xdebug.remote_port" '"9000"'
- php-ext-source-r2_addtoinifiles "xdebug.remote_autostart" '"0"'
- php-ext-source-r2_addtoinifiles "xdebug.remote_log" '""'
- php-ext-source-r2_addtoinifiles "xdebug.idekey" '""'
- php-ext-source-r2_addtoinifiles "xdebug.var_display_max_data" '"512"'
- php-ext-source-r2_addtoinifiles "xdebug.var_display_max_depth" '"2"'
- php-ext-source-r2_addtoinifiles "xdebug.var_display_max_children" '"128"'
-
-}
-
-pkg_postinst() {
- ewarn "We have set xdebug.default_enable to 0 (off), as xdebug can be"
- ewarn "installed as a dependency, and not all users will want xdebug to be"
- ewarn "enabled by default. If you want to enable it, you should edit the"
- ewarn "ini file and set xdebug.default_enable to 1. Alternatively you can"
- ewarn "call xdebug_enable() in your code."
-}
diff --git a/dev-php/xdebug/xdebug-2.2.5.ebuild b/dev-php/xdebug/xdebug-2.2.5.ebuild
deleted file mode 100644
index 854a17f288a6..000000000000
--- a/dev-php/xdebug/xdebug-2.2.5.ebuild
+++ /dev/null
@@ -1,89 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/xdebug/xdebug-2.2.5.ebuild,v 1.1 2014/10/02 15:09:37 grknight Exp $
-
-EAPI="5"
-PHP_EXT_NAME="xdebug"
-PHP_EXT_INI="yes"
-PHP_EXT_ZENDEXT="yes"
-
-USE_PHP="php5-5 php5-4"
-
-MY_PV="${PV/_/}"
-MY_PV="${MY_PV/rc/RC}"
-
-S="${WORKDIR}/${PN}-${MY_PV}"
-
-inherit php-ext-source-r2
-
-KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86"
-
-DESCRIPTION="A PHP debugging and profiling extension"
-HOMEPAGE="http://www.xdebug.org/"
-SRC_URI="http://pecl.php.net/get/${PN}-${MY_PV}.tgz"
-LICENSE="Xdebug"
-SLOT="0"
-IUSE=""
-
-DEPEND=""
-RDEPEND="${DEPEND}
- ~dev-php/xdebug-client-${PV}"
-
-src_install() {
- dodoc NEWS README CREDITS
- php-ext-source-r2_src_install
-
- php-ext-source-r2_addtoinifiles "xdebug.auto_trace" '"0"'
- php-ext-source-r2_addtoinifiles "xdebug.trace_output_dir" '"/tmp"'
- php-ext-source-r2_addtoinifiles "xdebug.trace_output_name" '"trace.%c"'
- php-ext-source-r2_addtoinifiles "xdebug.trace_format" '"0"'
- php-ext-source-r2_addtoinifiles "xdebug.trace_options" '"0"'
- php-ext-source-r2_addtoinifiles "xdebug.collect_includes" '"1"'
- php-ext-source-r2_addtoinifiles "xdebug.collect_params" '"0"'
- php-ext-source-r2_addtoinifiles "xdebug.collect_return" '"0"'
- php-ext-source-r2_addtoinifiles "xdebug.collect_vars" '"0"'
- php-ext-source-r2_addtoinifiles "xdebug.default_enable" '"1"'
- php-ext-source-r2_addtoinifiles "xdebug.extended_info" '"1"'
- php-ext-source-r2_addtoinifiles "xdebug.manual_url" '"http://www.php.net"'
- php-ext-source-r2_addtoinifiles "xdebug.max_nesting_level" '"100"'
- php-ext-source-r2_addtoinifiles "xdebug.show_exception_trace" '"0"'
- php-ext-source-r2_addtoinifiles "xdebug.show_local_vars" '"0"'
- php-ext-source-r2_addtoinifiles "xdebug.show_mem_delta" '"0"'
- php-ext-source-r2_addtoinifiles "xdebug.dump.COOKIE" '"NULL"'
- php-ext-source-r2_addtoinifiles "xdebug.dump.ENV" '"NULL"'
- php-ext-source-r2_addtoinifiles "xdebug.dump.FILES" '"NULL"'
- php-ext-source-r2_addtoinifiles "xdebug.dump.GET" '"NULL"'
- php-ext-source-r2_addtoinifiles "xdebug.dump.POST" '"NULL"'
- php-ext-source-r2_addtoinifiles "xdebug.dump.REQUEST" '"NULL"'
- php-ext-source-r2_addtoinifiles "xdebug.dump.SERVER" '"NULL"'
- php-ext-source-r2_addtoinifiles "xdebug.dump.SESSION" '"NULL"'
- php-ext-source-r2_addtoinifiles "xdebug.dump_globals" '"1"'
- php-ext-source-r2_addtoinifiles "xdebug.dump_once" '"1"'
- php-ext-source-r2_addtoinifiles "xdebug.dump_undefined" '"0"'
- php-ext-source-r2_addtoinifiles "xdebug.profiler_enable" '"0"'
- php-ext-source-r2_addtoinifiles "xdebug.profiler_output_dir" '"/tmp"'
- php-ext-source-r2_addtoinifiles "xdebug.profiler_output_name" '"cachegrind.out.%p"'
- php-ext-source-r2_addtoinifiles "xdebug.profiler_enable_trigger" '"0"'
- php-ext-source-r2_addtoinifiles "xdebug.profiler_append" '"0"'
- php-ext-source-r2_addtoinifiles "xdebug.profiler_aggregate" '"0"'
- php-ext-source-r2_addtoinifiles "xdebug.remote_enable" '"0"'
- php-ext-source-r2_addtoinifiles "xdebug.remote_handler" '"dbgp"'
- php-ext-source-r2_addtoinifiles "xdebug.remote_host" '"localhost"'
- php-ext-source-r2_addtoinifiles "xdebug.remote_mode" '"req"'
- php-ext-source-r2_addtoinifiles "xdebug.remote_port" '"9000"'
- php-ext-source-r2_addtoinifiles "xdebug.remote_autostart" '"0"'
- php-ext-source-r2_addtoinifiles "xdebug.remote_log" '""'
- php-ext-source-r2_addtoinifiles "xdebug.idekey" '""'
- php-ext-source-r2_addtoinifiles "xdebug.var_display_max_data" '"512"'
- php-ext-source-r2_addtoinifiles "xdebug.var_display_max_depth" '"2"'
- php-ext-source-r2_addtoinifiles "xdebug.var_display_max_children" '"128"'
-
-}
-
-pkg_postinst() {
- ewarn "We have set xdebug.default_enable to 0 (off), as xdebug can be"
- ewarn "installed as a dependency, and not all users will want xdebug to be"
- ewarn "enabled by default. If you want to enable it, you should edit the"
- ewarn "ini file and set xdebug.default_enable to 1. Alternatively you can"
- ewarn "call xdebug_enable() in your code."
-}