summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2003-06-10 19:14:31 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2003-06-10 19:14:31 +0000
commita29cd9dc52537bfa49af544f6663efa3de70fff2 (patch)
tree6a57b1784f7a285328092b0300c152e2a2dfe519 /dev-php
parentHopefully fix the dual apache bug (diff)
downloadgentoo-2-a29cd9dc52537bfa49af544f6663efa3de70fff2.tar.gz
gentoo-2-a29cd9dc52537bfa49af544f6663efa3de70fff2.tar.bz2
gentoo-2-a29cd9dc52537bfa49af544f6663efa3de70fff2.zip
Hopefully fix the dual apache bug
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/mod_php/ChangeLog9
-rw-r--r--dev-php/mod_php/Manifest4
-rw-r--r--dev-php/mod_php/files/digest-mod_php-4.3.2-r11
-rw-r--r--dev-php/mod_php/mod_php-4.3.2-r1.ebuild99
4 files changed, 110 insertions, 3 deletions
diff --git a/dev-php/mod_php/ChangeLog b/dev-php/mod_php/ChangeLog
index dec8734fb4eb..013821eca650 100644
--- a/dev-php/mod_php/ChangeLog
+++ b/dev-php/mod_php/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-php/mod_php
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/mod_php/ChangeLog,v 1.80 2003/06/05 20:06:36 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/mod_php/ChangeLog,v 1.81 2003/06/10 19:14:28 robbat2 Exp $
+
+*mod_php-4.3.2-r1 (10 June 2003)
+
+ 10 June 2003; Robin H. Johnson <robbat2@gentoo.org> mod_php-4.3.2.ebuild:
+ Try to fix bug #22352. mod_php is now SLOTed by the major version of Apache
+ that you are building it for. This SHOULD enable you to have mod_php
+ installed on both at the same time, but is is experimental at this time.
*mod_php-4.3.2 (31 May 2003)
diff --git a/dev-php/mod_php/Manifest b/dev-php/mod_php/Manifest
index 9952314e412c..5935ba9da8af 100644
--- a/dev-php/mod_php/Manifest
+++ b/dev-php/mod_php/Manifest
@@ -2,10 +2,10 @@ MD5 136c8a948544ac163e93e4c45e46092c mod_php-4.3.2.ebuild 2740
MD5 31e28f7f7df06e387c40cdad216265ab mod_php-4.3.1-r3.ebuild 2589
MD5 a00cd3eced04951a9aa6a5d38bd7f6b6 mod_php-4.3.1.ebuild 9225
MD5 c99a00bf82ec9a082399ab1dd931c415 mod_php-4.3.1-r2.ebuild 9241
-MD5 e952390bd3a40f266b137ea5896c1000 mod_php-4.3.2-r1.ebuild 2673
+MD5 171b138769aa006ffa4393144555cba3 mod_php-4.3.2-r1.ebuild 2676
MD5 6de98d80b82a71ed8845884b0bd5676e mod_php-4.2.3-r2.ebuild 8071
MD5 dfc6bd16160024127fa9b0c242fc8ab5 mod_php-4.3.0-r2.ebuild 8634
-MD5 9f3b347e6e065ff248fa6a42f2345726 ChangeLog 17166
+MD5 ff9a6e7f019d6dac9c127f55270db8b5 ChangeLog 17166
MD5 c585d6d5154fe64839f25db957301433 mod_php-4.3.1-r1.ebuild 9135
MD5 cceddd5c262e0ffef31d45b7da269851 files/mod_php.conf 148
MD5 77023a54f39bae40733118d5cabd8f7f files/70_mod_php.conf 853
diff --git a/dev-php/mod_php/files/digest-mod_php-4.3.2-r1 b/dev-php/mod_php/files/digest-mod_php-4.3.2-r1
new file mode 100644
index 000000000000..8271dab4f822
--- /dev/null
+++ b/dev-php/mod_php/files/digest-mod_php-4.3.2-r1
@@ -0,0 +1 @@
+MD5 8aec1bb2dbcca1c92835c71e2e30d9c5 php-4.3.2.tar.bz2 3697581
diff --git a/dev-php/mod_php/mod_php-4.3.2-r1.ebuild b/dev-php/mod_php/mod_php-4.3.2-r1.ebuild
new file mode 100644
index 000000000000..447d882f6959
--- /dev/null
+++ b/dev-php/mod_php/mod_php-4.3.2-r1.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/mod_php/mod_php-4.3.2-r1.ebuild,v 1.1 2003/06/10 19:14:28 robbat2 Exp $
+
+inherit php eutils
+
+IUSE="${IUSE} apache2"
+
+DESCRIPTION="Apache module for PHP"
+KEYWORDS="~x86 ~sparc ~ppc ~alpha ~hppa ~arm ~sparc"
+EXCLUDE_DB4_FIX=1
+EXCLUDE_PEAR_FIX=1
+
+DEPEND="${DEPEND}
+ >=net-www/apache-1.3.26-r2
+ apache2? ( >=net-www/apache-2.0.43-r1 ) "
+
+APACHEVER='1'
+use apache2 && APACHEVER='2'
+SLOT="${APACHEVER}"
+[ "${APACHEVER}" -eq '2' ] && USE_APACHE2='2' || USE_APACHE2=''
+
+src_compile() {
+ #no readline on server SAPI
+ myconf="${myconf} --without-readline"
+
+ # Every Apache2 MPM EXCEPT prefork needs Zend Thread Safety
+ if [ -n "${USE_APACHE2}" ]; then
+ APACHE2_MPM="`apache2 -l |egrep 'worker|prechild|leader|threadpool|prefork'|xargs|cut -d. -f1`"
+ case "${APACHE2_MPM}" in
+ prefork) ;;
+ *) myconf="${myconf} --enable-experimental-zts" ;;
+ esac;
+ fi
+
+ # optional support for apache2
+ #&& myconf="${myconf} --with-apxs2=/usr/sbin/apxs2" \
+ #|| myconf="${myconf} --with-apxs=/usr/sbin/apxs"
+
+ #use apache2 \
+ myconf="${myconf} --with-apxs${USE_APACHE2}=/usr/sbin/apxs${USE_APACHE2}"
+
+ #php CGI stuff
+ #--enable-discard-path --enable-force-cgi-redirect
+
+ php_src_compile
+}
+
+
+src_install() {
+ php_src_install
+
+ cp php.ini-dist php.ini
+ insinto /etc/php4
+ doins php.ini
+ dosym /etc/php4/php.ini /etc/apache${USE_APACHE2}/conf/php.ini
+
+ dosym /usr/lib/apache${USE_APACHE2}-extramodules /etc/php4/lib
+ exeinto /usr/lib/apache${USE_APACHE2}-extramodules
+ doexe .libs/libphp4.so
+
+ if [ -n "${USE_APACHE2}" ] ; then
+ insinto /etc/apache2/conf/modules.d
+ doins ${FILESDIR}/70_mod_php.conf
+ else
+ insinto /etc/apache/conf/addon-modules
+ doins ${FILESDIR}/mod_php.conf
+ dosym /etc/php4/php.ini /etc/apache/conf/addon-modules/php.ini
+ fi
+}
+
+apache2msg() {
+ einfo "Edit /etc/conf.d/apache2 and add \"-D PHP\""
+}
+
+pkg_postinst() {
+ einfo "To have Apache run php programs, please do the following:"
+ if [ "`use apache2`" ] ; then
+ apache2msg
+ else
+ einfo "1. Execute the command:"
+ einfo " \"ebuild /var/db/pkg/dev-php/${PF}/${PF}.ebuild config\""
+ einfo "2. Edit /etc/conf.d/apache and add \"-D PHP\""
+ einfo "That will include the php mime types in your configuration"
+ einfo "automagically and setup Apache to load php when it starts."
+ fi
+}
+
+pkg_config() {
+ if [ -n "${USE_APACHE2}" ] ; then
+ apache2msg
+ else
+ ${ROOT}/usr/sbin/apacheaddmod \
+ ${ROOT}/etc/apache/conf/apache.conf \
+ extramodules/libphp4.so mod_php4.c php4_module \
+ before=perl define=PHP4 addconf=conf/addon-modules/mod_php.conf
+ :;
+ fi
+}