summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2010-03-06 16:53:03 +0000
committerBen de Groot <yngwin@gentoo.org>2010-03-06 16:53:03 +0000
commit191322940fe22690bb9b529a534ef9ddf9badb19 (patch)
tree1f3f0249ef90197d26b35e7a9bc67b1e492f1895 /dev-php5
parentadd removal date (diff)
downloadgentoo-2-191322940fe22690bb9b529a534ef9ddf9badb19.tar.gz
gentoo-2-191322940fe22690bb9b529a534ef9ddf9badb19.tar.bz2
gentoo-2-191322940fe22690bb9b529a534ef9ddf9badb19.zip
Migrate to eapi-2. Block suhosin as it results in mem limit error.
(Portage version: 2.2_rc63/cvs/Linux x86_64)
Diffstat (limited to 'dev-php5')
-rw-r--r--dev-php5/symfony/ChangeLog5
-rw-r--r--dev-php5/symfony/symfony-1.4.3.ebuild13
2 files changed, 8 insertions, 10 deletions
diff --git a/dev-php5/symfony/ChangeLog b/dev-php5/symfony/ChangeLog
index e2f777526a8c..bff4ad69d8fd 100644
--- a/dev-php5/symfony/ChangeLog
+++ b/dev-php5/symfony/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-php5/symfony
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php5/symfony/ChangeLog,v 1.11 2010/03/06 14:41:42 yngwin Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/symfony/ChangeLog,v 1.12 2010/03/06 16:53:03 yngwin Exp $
+
+ 06 Mar 2010; Ben de Groot <yngwin@gentoo.org> symfony-1.4.3.ebuild:
+ Migrate to eapi-2. Block suhosin as it results in mem limit error.
*symfony-1.4.3 (06 Mar 2010)
diff --git a/dev-php5/symfony/symfony-1.4.3.ebuild b/dev-php5/symfony/symfony-1.4.3.ebuild
index f0c0d8c8f4d1..245bc8536b13 100644
--- a/dev-php5/symfony/symfony-1.4.3.ebuild
+++ b/dev-php5/symfony/symfony-1.4.3.ebuild
@@ -1,7 +1,8 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php5/symfony/symfony-1.4.3.ebuild,v 1.1 2010/03/06 14:41:42 yngwin Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/symfony/symfony-1.4.3.ebuild,v 1.2 2010/03/06 16:53:03 yngwin Exp $
+EAPI=2
inherit php-pear-lib-r1 depend.php
DESCRIPTION="Open-source PHP5 professional web framework"
@@ -13,12 +14,6 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
-DEPEND=">=dev-php/pear-1.8.1"
+DEPEND="dev-lang/php:5[-suhosin,cli,ctype,reflection,spl,simplexml,xml,pcre,session]
+ dev-php/pear"
RDEPEND="${DEPEND}"
-
-need_php_by_category
-
-pkg_setup() {
- # Symfony needs some features in PHP5 in order to work
- require_php_with_use cli ctype reflection spl simplexml xml pcre session
-}