summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Ullmann <jokey@gentoo.org>2008-01-04 13:29:20 +0000
committerMarkus Ullmann <jokey@gentoo.org>2008-01-04 13:29:20 +0000
commitd425349a1db7b1461844cf8fb5a8e0a4761facc8 (patch)
treee4421a7e462108fa99787452373a6f9b58e50d74 /dev-php5/phpunit
parentVersion bump from project overlay (diff)
downloadgentoo-2-d425349a1db7b1461844cf8fb5a8e0a4761facc8.tar.gz
gentoo-2-d425349a1db7b1461844cf8fb5a8e0a4761facc8.tar.bz2
gentoo-2-d425349a1db7b1461844cf8fb5a8e0a4761facc8.zip
Version bump from project overlay
(Portage version: 2.1.4_rc14)
Diffstat (limited to 'dev-php5/phpunit')
-rw-r--r--dev-php5/phpunit/ChangeLog12
-rw-r--r--dev-php5/phpunit/files/digest-phpunit-3.2.83
-rw-r--r--dev-php5/phpunit/phpunit-3.2.8.ebuild35
3 files changed, 48 insertions, 2 deletions
diff --git a/dev-php5/phpunit/ChangeLog b/dev-php5/phpunit/ChangeLog
index a28629a7a5cb..2ecaa3aecdf2 100644
--- a/dev-php5/phpunit/ChangeLog
+++ b/dev-php5/phpunit/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-php5/phpunit
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php5/phpunit/ChangeLog,v 1.10 2007/12/24 14:49:25 armin76 Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/phpunit/ChangeLog,v 1.11 2008/01/04 13:29:19 jokey Exp $
+
+*phpunit-3.2.8 (04 Jan 2008)
+
+ 04 Jan 2008; Markus Ullmann <jokey@gentoo.org> +phpunit-3.2.8.ebuild:
+ Version bump from project overlay
+
+ 03 Jan 2008; Jakub Moc <jakub@gentoo.org> +phpunit-3.2.8.ebuild:
+ Version bump
*phpunit-3.2.5 (24 Dec 2007)
diff --git a/dev-php5/phpunit/files/digest-phpunit-3.2.8 b/dev-php5/phpunit/files/digest-phpunit-3.2.8
new file mode 100644
index 000000000000..8ef3873354ae
--- /dev/null
+++ b/dev-php5/phpunit/files/digest-phpunit-3.2.8
@@ -0,0 +1,3 @@
+MD5 cb18ffe416417d70107a53dd7540431c PHPUnit-3.2.8.tgz 197668
+RMD160 b91baa277eeced93f85298be89d9b34d302bca83 PHPUnit-3.2.8.tgz 197668
+SHA256 3cd338ec35ae3d6b23afa1da87b865e787fa69fb24042f22684939114a58766b PHPUnit-3.2.8.tgz 197668
diff --git a/dev-php5/phpunit/phpunit-3.2.8.ebuild b/dev-php5/phpunit/phpunit-3.2.8.ebuild
new file mode 100644
index 000000000000..b592cad1f3e0
--- /dev/null
+++ b/dev-php5/phpunit/phpunit-3.2.8.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/phpunit/phpunit-3.2.8.ebuild,v 1.1 2008/01/04 13:29:19 jokey Exp $
+
+inherit php-pear-lib-r1
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="Unit Testing framework for PHP 5."
+HOMEPAGE="http://www.phpunit.de/"
+SRC_URI="http://pear.phpunit.de/get/PHPUnit-${PV}.tgz"
+LICENSE="BSD"
+SLOT="0"
+IUSE="minimal"
+
+DEPEND="!dev-php4/phpunit"
+RDEPEND="${DEPEND}
+ !minimal? ( >=dev-php5/xdebug-2.0.0_rc2
+ >=dev-php/PEAR-Image_GraphViz-1.2.1
+ >=dev-php/PEAR-Log-1.8.7-r1
+ >=dev-php/PEAR-Testing_Selenium-0.2.0 )"
+
+S="${WORKDIR}/PHPUnit-${PV}"
+
+need_php_by_category
+
+pkg_setup() {
+ require_php_with_use pcre reflection spl xml tokenizer
+}
+
+pkg_postinst() {
+ has_php
+ elog "${PN} can optionally use json, pdo-sqlite and pdo-mysql features."
+ elog "If you want those, emerge ${PHP_PKG} with USE=\"json pdo sqlite mysql\"."
+}