summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2010-01-01 20:56:06 +0000
committerBen de Groot <yngwin@gentoo.org>2010-01-01 20:56:06 +0000
commit6857c99d5dfd0ad5975c93b6b006f5374e84dd46 (patch)
tree3aa4da9f8bde75cf55756969bf51b35923f62d64 /dev-php5/phpunit
parentfix quoting (diff)
downloadgentoo-2-6857c99d5dfd0ad5975c93b6b006f5374e84dd46.tar.gz
gentoo-2-6857c99d5dfd0ad5975c93b6b006f5374e84dd46.tar.bz2
gentoo-2-6857c99d5dfd0ad5975c93b6b006f5374e84dd46.zip
Version bump, fixes bug 254241.
(Portage version: 2.2_rc61/cvs/Linux x86_64)
Diffstat (limited to 'dev-php5/phpunit')
-rw-r--r--dev-php5/phpunit/ChangeLog9
-rw-r--r--dev-php5/phpunit/phpunit-3.4.6.ebuild36
2 files changed, 43 insertions, 2 deletions
diff --git a/dev-php5/phpunit/ChangeLog b/dev-php5/phpunit/ChangeLog
index 73eb3198feb3..259a9c559c17 100644
--- a/dev-php5/phpunit/ChangeLog
+++ b/dev-php5/phpunit/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-php5/phpunit
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php5/phpunit/ChangeLog,v 1.21 2008/10/18 20:30:15 hoffie Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/phpunit/ChangeLog,v 1.22 2010/01/01 20:56:06 yngwin Exp $
+
+*phpunit-3.4.6 (01 Jan 2010)
+
+ 01 Jan 2010; Ben de Groot <yngwin@gentoo.org> +phpunit-3.4.6.ebuild:
+ Version bump, fixes bug 254241.
*phpunit-3.3.1 (18 Oct 2008)
diff --git a/dev-php5/phpunit/phpunit-3.4.6.ebuild b/dev-php5/phpunit/phpunit-3.4.6.ebuild
new file mode 100644
index 000000000000..68d57cc1c6d0
--- /dev/null
+++ b/dev-php5/phpunit/phpunit-3.4.6.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/phpunit/phpunit-3.4.6.ebuild,v 1.1 2010/01/01 20:56:06 yngwin Exp $
+
+inherit php-pear-lib-r1
+
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~sparc ~x86"
+
+DESCRIPTION="Unit testing framework for PHP5"
+HOMEPAGE="http://www.phpunit.de/"
+SRC_URI="http://pear.phpunit.de/get/PHPUnit-${PV}.tgz"
+LICENSE="BSD"
+SLOT="0"
+IUSE="minimal"
+
+DEPEND="!dev-php4/phpunit
+ >=dev-php/PEAR-PEAR-1.8.1"
+RDEPEND="${DEPEND}
+ !minimal? ( >=dev-php5/xdebug-2.0.5
+ >=dev-php/PEAR-Image_GraphViz-1.2.1
+ >=dev-php/PEAR-Log-1.8.7-r1
+ >=dev-php/PEAR-Testing_Selenium-0.2.0 )"
+
+S="${WORKDIR}/PHPUnit-${PV}"
+
+need_php_by_category
+
+pkg_setup() {
+ require_php_with_use pcre reflection spl xml tokenizer
+}
+
+pkg_postinst() {
+ has_php
+ elog "${PN} can optionally use json, pdo-sqlite and pdo-mysql features."
+ elog "If you want those, emerge ${PHP_PKG} with USE=\"json pdo sqlite mysql\"."
+}