summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2008-02-26 16:38:21 +0000
committerRaúl Porcel <armin76@gentoo.org>2008-02-26 16:38:21 +0000
commit51bea4b0a834a40c439511c27718bb842e4f11d3 (patch)
treeb9b6927c9dc5e222b223171124b43d81ed74adc4 /dev-php5/phpunit
parentVersion bump, import from the php overlay (diff)
downloadgentoo-2-51bea4b0a834a40c439511c27718bb842e4f11d3.tar.gz
gentoo-2-51bea4b0a834a40c439511c27718bb842e4f11d3.tar.bz2
gentoo-2-51bea4b0a834a40c439511c27718bb842e4f11d3.zip
Version bump, import from the php overlay
(Portage version: 2.1.4.4)
Diffstat (limited to 'dev-php5/phpunit')
-rw-r--r--dev-php5/phpunit/ChangeLog10
-rw-r--r--dev-php5/phpunit/phpunit-3.2.13.ebuild35
2 files changed, 44 insertions, 1 deletions
diff --git a/dev-php5/phpunit/ChangeLog b/dev-php5/phpunit/ChangeLog
index 61818cf02917..4a3aa1b19f7c 100644
--- a/dev-php5/phpunit/ChangeLog
+++ b/dev-php5/phpunit/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-php5/phpunit
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php5/phpunit/ChangeLog,v 1.14 2008/02/11 21:29:04 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/phpunit/ChangeLog,v 1.15 2008/02/26 16:38:21 armin76 Exp $
+
+*phpunit-3.2.13 (26 Feb 2008)
+
+ 26 Feb 2008; Raúl Porcel <armin76@gentoo.org> +phpunit-3.2.13.ebuild:
+ Version bump, import from the php overlay
+
+ 19 Feb 2008; Jakub Moc <jakub@gentoo.org> +phpunit-3.2.13.ebuild:
+ Version bump
*phpunit-3.2.10 (11 Feb 2008)
diff --git a/dev-php5/phpunit/phpunit-3.2.13.ebuild b/dev-php5/phpunit/phpunit-3.2.13.ebuild
new file mode 100644
index 000000000000..0df916bdbc73
--- /dev/null
+++ b/dev-php5/phpunit/phpunit-3.2.13.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/phpunit/phpunit-3.2.13.ebuild,v 1.1 2008/02/26 16:38:21 armin76 Exp $
+
+inherit php-pear-lib-r1
+
+KEYWORDS="~alpha ~amd64 ~ia64 ~sparc ~x86"
+
+DESCRIPTION="Unit Testing framework for PHP 5."
+HOMEPAGE="http://www.phpunit.de/"
+SRC_URI="http://pear.phpunit.de/get/PHPUnit-${PV}.tgz"
+LICENSE="BSD"
+SLOT="0"
+IUSE="minimal"
+
+DEPEND="!dev-php4/phpunit"
+RDEPEND="${DEPEND}
+ !minimal? ( >=dev-php5/xdebug-2.0.0_rc2
+ >=dev-php/PEAR-Image_GraphViz-1.2.1
+ >=dev-php/PEAR-Log-1.8.7-r1
+ >=dev-php/PEAR-Testing_Selenium-0.2.0 )"
+
+S="${WORKDIR}/PHPUnit-${PV}"
+
+need_php_by_category
+
+pkg_setup() {
+ require_php_with_use pcre reflection spl xml tokenizer
+}
+
+pkg_postinst() {
+ has_php
+ elog "${PN} can optionally use json, pdo-sqlite and pdo-mysql features."
+ elog "If you want those, emerge ${PHP_PKG} with USE=\"json pdo sqlite mysql\"."
+}