summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Longinotti <chtekk@gentoo.org>2007-03-06 22:52:25 +0000
committerLuca Longinotti <chtekk@gentoo.org>2007-03-06 22:52:25 +0000
commiteafb4fcb6054a3f2524d42940468f8afe2b453ec (patch)
tree725342c81e8237b5d9efb352c8d1a7abf7ee2cbf /dev-php4
parentBump patchset to fix bug 165777 and bug 168893 (diff)
downloadgentoo-2-eafb4fcb6054a3f2524d42940468f8afe2b453ec.tar.gz
gentoo-2-eafb4fcb6054a3f2524d42940468f8afe2b453ec.tar.bz2
gentoo-2-eafb4fcb6054a3f2524d42940468f8afe2b453ec.zip
Vbump.
(Portage version: 2.1.2.1)
Diffstat (limited to 'dev-php4')
-rw-r--r--dev-php4/xdebug/ChangeLog10
-rw-r--r--dev-php4/xdebug/files/digest-xdebug-2.0.0_rc13
-rw-r--r--dev-php4/xdebug/files/digest-xdebug-2.0.0_rc33
-rw-r--r--dev-php4/xdebug/xdebug-2.0.0_rc3.ebuild (renamed from dev-php4/xdebug/xdebug-2.0.0_rc1.ebuild)30
4 files changed, 29 insertions, 17 deletions
diff --git a/dev-php4/xdebug/ChangeLog b/dev-php4/xdebug/ChangeLog
index e498b30d799f..baa445a51ce3 100644
--- a/dev-php4/xdebug/ChangeLog
+++ b/dev-php4/xdebug/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-php4/xdebug
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php4/xdebug/ChangeLog,v 1.11 2006/10/27 19:01:02 sebastian Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php4/xdebug/ChangeLog,v 1.12 2007/03/06 22:52:25 chtekk Exp $
+
+*xdebug-2.0.0_rc3 (06 Mar 2007)
+
+ 06 Mar 2007; Luca Longinotti <chtekk@gentoo.org> -xdebug-2.0.0_rc1.ebuild,
+ +xdebug-2.0.0_rc3.ebuild:
+ Version bump, cleanup.
27 Oct 2006; Sebastian Bergmann <sebastian@gentoo.org>
xdebug-2.0.0_rc1.ebuild:
diff --git a/dev-php4/xdebug/files/digest-xdebug-2.0.0_rc1 b/dev-php4/xdebug/files/digest-xdebug-2.0.0_rc1
deleted file mode 100644
index 114e5ad1bff2..000000000000
--- a/dev-php4/xdebug/files/digest-xdebug-2.0.0_rc1
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 a048de3dbb5a16489921f2096b8003e1 xdebug-2.0.0rc1.tgz 252286
-RMD160 421ef0a9535954f17ddd585e57cf949582e55533 xdebug-2.0.0rc1.tgz 252286
-SHA256 f3b8a65430f2e727460f8fa1ee9c6b2187befa939f99a10d2cf1fa1042bd42f5 xdebug-2.0.0rc1.tgz 252286
diff --git a/dev-php4/xdebug/files/digest-xdebug-2.0.0_rc3 b/dev-php4/xdebug/files/digest-xdebug-2.0.0_rc3
new file mode 100644
index 000000000000..ded54d29e220
--- /dev/null
+++ b/dev-php4/xdebug/files/digest-xdebug-2.0.0_rc3
@@ -0,0 +1,3 @@
+MD5 5cc4bd38b26074f91bbf3d0237b8d21e xdebug-2.0.0RC3.tgz 261735
+RMD160 6f012836117f4fdb8c3979078266135989dbcf43 xdebug-2.0.0RC3.tgz 261735
+SHA256 263cfe074b86f0453bd62bf594cb7be79f514ee92d54491beb5858b87f048635 xdebug-2.0.0RC3.tgz 261735
diff --git a/dev-php4/xdebug/xdebug-2.0.0_rc1.ebuild b/dev-php4/xdebug/xdebug-2.0.0_rc3.ebuild
index b0f8dd6c84e8..9cd8ad39f9e7 100644
--- a/dev-php4/xdebug/xdebug-2.0.0_rc1.ebuild
+++ b/dev-php4/xdebug/xdebug-2.0.0_rc3.ebuild
@@ -1,24 +1,30 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php4/xdebug/xdebug-2.0.0_rc1.ebuild,v 1.4 2006/10/27 19:04:26 sebastian Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php4/xdebug/xdebug-2.0.0_rc3.ebuild,v 1.1 2007/03/06 22:52:25 chtekk Exp $
-PHP_EXT_ZENDEXT="yes"
PHP_EXT_NAME="xdebug"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="yes"
inherit php-ext-source-r1
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+
+MY_PV="${PV/_/}"
+MY_PV="${MY_PV/rc/RC}"
+
DESCRIPTION="A PHP Debugging and Profiling extension."
HOMEPAGE="http://www.xdebug.org/"
-SLOT="0"
-MY_P="${P/_/}"
-SRC_URI="http://pecl.php.net/get/${MY_P}.tgz"
-S="${WORKDIR}/xdebug-2.0.0RC1"
+SRC_URI="http://pecl.php.net/get/${PN}-${MY_PV}.tgz"
LICENSE="Xdebug"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+SLOT="0"
+IUSE=""
+
+S="${WORKDIR}/${PN}-${MY_PV}"
-RDEPEND="${RDEPEND}
- !dev-php5/ZendOptimizer
- dev-php/xdebug-client"
+DEPEND="!dev-php4/ZendOptimizer"
+RDEPEND="${DEPEND}
+ dev-php/xdebug-client"
need_php_by_category
@@ -66,8 +72,8 @@ src_install() {
php-ext-base-r1_addtoinifiles "xdebug.remote_port" '"9000"'
php-ext-base-r1_addtoinifiles "xdebug.remote_autostart" '"0"'
php-ext-base-r1_addtoinifiles "xdebug.remote_log" '""'
- php-ext-base-r1_addtoinifiles "xdebug.allowed_clients" '""'
php-ext-base-r1_addtoinifiles "xdebug.idekey" '""'
php-ext-base-r1_addtoinifiles "xdebug.var_display_max_data" '"512"'
php-ext-base-r1_addtoinifiles "xdebug.var_display_max_depth" '"2"'
+ php-ext-base-r1_addtoinifiles "xdebug.var_display_max_children" '"128"'
}