summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOle Markus With <olemarkus@gentoo.org>2012-01-27 13:38:12 +0000
committerOle Markus With <olemarkus@gentoo.org>2012-01-27 13:38:12 +0000
commite46b9771f1e478f9975ee65decec21aed0ca7480 (patch)
tree481218b056a0bcc61e699271d0483db84588f5f9 /dev-php/xdebug-client
parentStable for AMD64, wrt security bug #401005 (diff)
downloadgentoo-2-e46b9771f1e478f9975ee65decec21aed0ca7480.tar.gz
gentoo-2-e46b9771f1e478f9975ee65decec21aed0ca7480.tar.bz2
gentoo-2-e46b9771f1e478f9975ee65decec21aed0ca7480.zip
Version bump
(Portage version: 2.1.10.41/cvs/Linux x86_64)
Diffstat (limited to 'dev-php/xdebug-client')
-rw-r--r--dev-php/xdebug-client/ChangeLog10
-rw-r--r--dev-php/xdebug-client/xdebug-client-2.1.3.ebuild34
2 files changed, 42 insertions, 2 deletions
diff --git a/dev-php/xdebug-client/ChangeLog b/dev-php/xdebug-client/ChangeLog
index 91fcb9c02443..d2e823b0c05c 100644
--- a/dev-php/xdebug-client/ChangeLog
+++ b/dev-php/xdebug-client/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-php/xdebug-client
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/xdebug-client/ChangeLog,v 1.29 2011/07/29 14:16:40 olemarkus Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/xdebug-client/ChangeLog,v 1.30 2012/01/27 13:38:12 olemarkus Exp $
+
+*xdebug-client-2.1.3 (26 Jan 2012)
+
+ 26 Jan 2012; Ole Markus With <olemarkus@gentoo.org>
+ +xdebug-client-2.1.3.ebuild:
+ Version bump
*xdebug-client-2.1.2 (29 Jul 2011)
diff --git a/dev-php/xdebug-client/xdebug-client-2.1.3.ebuild b/dev-php/xdebug-client/xdebug-client-2.1.3.ebuild
new file mode 100644
index 000000000000..d83e2a8f15bd
--- /dev/null
+++ b/dev-php/xdebug-client/xdebug-client-2.1.3.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/xdebug-client/xdebug-client-2.1.3.ebuild,v 1.1 2012/01/27 13:38:12 olemarkus Exp $
+
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+MY_PV="${PV/_/}"
+MY_PV="${MY_PV/rc/RC}"
+
+DESCRIPTION="Xdebug client for the Common Debugger Protocol (DBGP)."
+HOMEPAGE="http://www.xdebug.org/"
+SRC_URI="http://pecl.php.net/get/xdebug-${MY_PV}.tgz"
+LICENSE="Xdebug"
+SLOT="0"
+IUSE="libedit"
+
+S="${WORKDIR}/xdebug-${MY_PV}/debugclient"
+
+DEPEND="libedit? ( dev-libs/libedit )"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ chmod +x "${S}"/configure
+}
+
+src_compile() {
+ econf $(use_with libedit) --disable-dependency-tracking
+ emake || die "Build of debug client failed!"
+}
+
+src_install() {
+ newbin debugclient xdebug
+}