summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOle Markus With <olemarkus@gentoo.org>2012-11-16 10:05:13 +0000
committerOle Markus With <olemarkus@gentoo.org>2012-11-16 10:05:13 +0000
commit42106c0459853ef686137f72a18acb621f6fd0d4 (patch)
tree67a114b03543e0265a45777772e58e2ac315722a /dev-php/xcache
parentmedia-gfx/nvidia-cg-toolkit: Don't mix ABIs in pkd-config deps (diff)
downloadgentoo-2-42106c0459853ef686137f72a18acb621f6fd0d4.tar.gz
gentoo-2-42106c0459853ef686137f72a18acb621f6fd0d4.tar.bz2
gentoo-2-42106c0459853ef686137f72a18acb621f6fd0d4.zip
Version bump. Bug 443458
(Portage version: 2.1.11.9/cvs/Linux x86_64)
Diffstat (limited to 'dev-php/xcache')
-rw-r--r--dev-php/xcache/ChangeLog9
-rw-r--r--dev-php/xcache/xcache-1.3.1.ebuild81
-rw-r--r--dev-php/xcache/xcache-3.0.0.ebuild55
3 files changed, 62 insertions, 83 deletions
diff --git a/dev-php/xcache/ChangeLog b/dev-php/xcache/ChangeLog
index 1b2317487b10..a664b3361fd5 100644
--- a/dev-php/xcache/ChangeLog
+++ b/dev-php/xcache/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-php/xcache
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/xcache/ChangeLog,v 1.10 2012/10/21 09:15:01 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/xcache/ChangeLog,v 1.11 2012/11/16 10:05:13 olemarkus Exp $
+
+*xcache-3.0.0 (16 Nov 2012)
+
+ 16 Nov 2012; Ole Markus With <olemarkus@gentoo.org> +xcache-3.0.0.ebuild,
+ -xcache-1.3.1.ebuild:
+ Version bump. Bug 443458
21 Oct 2012; Markus Meier <maekke@gentoo.org> xcache-2.0.0.ebuild:
x86 stable, bug #427024
@@ -137,4 +143,3 @@
24 Jan 2007; Christian Hoffmann <christian@hoffie.info>
+files/xcache-hardening-0.4.11.patch, +xcache-1.2.0.ebuild:
Initial ebuild for xcache
-
diff --git a/dev-php/xcache/xcache-1.3.1.ebuild b/dev-php/xcache/xcache-1.3.1.ebuild
deleted file mode 100644
index 0bc06059e2fa..000000000000
--- a/dev-php/xcache/xcache-1.3.1.ebuild
+++ /dev/null
@@ -1,81 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/xcache/xcache-1.3.1.ebuild,v 1.3 2012/04/13 19:07:42 ulm Exp $
-
-EAPI="2"
-PHP_EXT_NAME="xcache"
-PHP_EXT_INI="yes"
-PHP_EXT_ZENDEXT="yes"
-PHPSAPILIST="apache2 cgi fpm"
-
-inherit php-ext-source-r2 confutils
-
-DESCRIPTION="A fast and stable PHP opcode cacher"
-HOMEPAGE="http://xcache.lighttpd.net/"
-SRC_URI="http://xcache.lighttpd.net/pub/Releases/${PV}/${P}.tar.bz2"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE=""
-
-# make test would just run php's test and as such need the full php source
-RESTRICT="test"
-
-DEPEND="virtual/httpd-php
-!dev-php/eaccelerator !dev-php/pecl-apc"
-RDEPEND="${DEPEND}"
-
-src_configure() {
-
- my_conf="--enable-xcache=shared \
- --enable-xcache-constant \
- --enable-xcache-optimizer \
- --enable-xcache-coverager \
- --enable-xcache-assembler \
- --enable-xcache-encoder \
- --enable-xcache-decoder"
-
- php-ext-source-r2_src_configure
-}
-
-src_install() {
- php-ext-source-r2_src_install
- dodoc AUTHORS ChangeLog NEWS README THANKS
-
- php-ext-source-r2_addtoinifiles "xcache.admin.enable_auth" '"On"'
- php-ext-source-r2_addtoinifiles "xcache.admin.user" '"admin"'
- php-ext-source-r2_addtoinifiles "xcache.admin.pass" '""'
-
- php-ext-source-r2_addtoinifiles "xcache.cacher" '"On"'
- php-ext-source-r2_addtoinifiles "xcache.size" '"64M"'
- php-ext-source-r2_addtoinifiles "xcache.count" '"2"'
- php-ext-source-r2_addtoinifiles "xcache.slots" '"8k"'
- php-ext-source-r2_addtoinifiles "xcache.ttl" '"0"'
- php-ext-source-r2_addtoinifiles "xcache.gc_interval" '"0"'
- php-ext-source-r2_addtoinifiles "xcache.var_size" '"8M"'
- php-ext-source-r2_addtoinifiles "xcache.var_count" '"1"'
- php-ext-source-r2_addtoinifiles "xcache.var_slots" '"8K"'
- php-ext-source-r2_addtoinifiles "xcache.var_ttl" '"0"'
- php-ext-source-r2_addtoinifiles "xcache.var_maxttl" '"0"'
- php-ext-source-r2_addtoinifiles "xcache.var_gc_interval" '"600"'
- php-ext-source-r2_addtoinifiles "xcache.readonly_protection" '"Off"'
- php-ext-source-r2_addtoinifiles "xcache.mmap_path" '"/dev/zero"'
-
- php-ext-source-r2_addtoinifiles "xcache.coverager" '"Off"'
- php-ext-source-r2_addtoinifiles "xcache.coveragedump_directory" '""'
-
- php-ext-source-r2_addtoinifiles "xcache.optimizer" '"Off"'
-
- insinto "${PHP_EXT_SHARED_DIR}"
- doins Decompiler.class.php
- insinto "${PHP_EXT_SHARED_DIR}/admin"
- doins admin/*
- insinto "${PHP_EXT_SHARED_DIR}/coverager"
- doins coverager/*
-}
-
-pkg_postinst() {
- elog "Decompiler.class.php, the admin/ and the coverager/ directory shipped with this"
- elog "release were installed into ${ROOT}usr/share/php5/xcache/."
-}
diff --git a/dev-php/xcache/xcache-3.0.0.ebuild b/dev-php/xcache/xcache-3.0.0.ebuild
new file mode 100644
index 000000000000..4e6f6e006671
--- /dev/null
+++ b/dev-php/xcache/xcache-3.0.0.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/xcache/xcache-3.0.0.ebuild,v 1.1 2012/11/16 10:05:13 olemarkus Exp $
+
+EAPI="4"
+PHP_EXT_NAME="xcache"
+PHP_EXT_INI="yes"
+PHPSAPILIST="apache2 cgi fpm"
+
+USE_PHP="php5-3 php5-4"
+inherit php-ext-source-r2 confutils
+
+DESCRIPTION="A fast and stable PHP opcode cacher"
+HOMEPAGE="http://xcache.lighttpd.net/"
+SRC_URI="http://xcache.lighttpd.net/pub/Releases/${PV}/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# make test would just run php's test and as such need the full php source
+RESTRICT="test"
+
+DEPEND="virtual/httpd-php
+!dev-php/eaccelerator !dev-php/pecl-apc"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+
+ my_conf="--enable-xcache=shared \
+ --enable-xcache-constant \
+ --enable-xcache-optimizer \
+ --enable-xcache-coverager \
+ --enable-xcache-assembler \
+ --enable-xcache-encoder \
+ --enable-xcache-decoder"
+
+ php-ext-source-r2_src_configure
+}
+
+src_install() {
+ php-ext-source-r2_src_install
+ dodoc AUTHORS ChangeLog NEWS README THANKS
+
+ insinto "${PHP_EXT_SHARED_DIR}"
+ doins lib/Decompiler.class.php
+ insinto "${PHP_EXT_SHARED_DIR}"
+ doins -r htdocs
+}
+
+pkg_postinst() {
+ elog "lib/Decompiler.class.php, and the htdocs/ directory shipped with this"
+ elog "release were installed into ${PHP_EXT_SHARED_DIR}."
+}