summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOle Markus With <olemarkus@gentoo.org>2013-03-05 10:18:15 +0000
committerOle Markus With <olemarkus@gentoo.org>2013-03-05 10:18:15 +0000
commit30f7aa9893539edd2a17a5b1461bbec64825cc4a (patch)
tree1e6fc41d53b493fbcae5884319c144dadd266d5c /dev-php/xcache
parentRemoved older ebuilds (diff)
downloadgentoo-2-30f7aa9893539edd2a17a5b1461bbec64825cc4a.tar.gz
gentoo-2-30f7aa9893539edd2a17a5b1461bbec64825cc4a.tar.bz2
gentoo-2-30f7aa9893539edd2a17a5b1461bbec64825cc4a.zip
Removed older ebuilds
(Portage version: 2.1.11.50/cvs/Linux x86_64, signed Manifest commit with key C4A92BF5)
Diffstat (limited to 'dev-php/xcache')
-rw-r--r--dev-php/xcache/ChangeLog6
-rw-r--r--dev-php/xcache/xcache-1.3.2.ebuild81
-rw-r--r--dev-php/xcache/xcache-2.0.1.ebuild82
-rw-r--r--dev-php/xcache/xcache-3.0.0.ebuild55
4 files changed, 5 insertions, 219 deletions
diff --git a/dev-php/xcache/ChangeLog b/dev-php/xcache/ChangeLog
index ffdbfbe21153..281bf4d49798 100644
--- a/dev-php/xcache/ChangeLog
+++ b/dev-php/xcache/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-php/xcache
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/xcache/ChangeLog,v 1.12 2013/03/01 12:21:36 olemarkus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/xcache/ChangeLog,v 1.13 2013/03/05 10:18:15 olemarkus Exp $
+
+ 05 Mar 2013; Ole Markus With <olemarkus@gentoo.org> -xcache-1.3.2.ebuild,
+ -xcache-2.0.1.ebuild, -xcache-3.0.0.ebuild:
+ Removed older ebuilds
*xcache-3.0.1 (01 Mar 2013)
diff --git a/dev-php/xcache/xcache-1.3.2.ebuild b/dev-php/xcache/xcache-1.3.2.ebuild
deleted file mode 100644
index 3cedfded4912..000000000000
--- a/dev-php/xcache/xcache-1.3.2.ebuild
+++ /dev/null
@@ -1,81 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/xcache/xcache-1.3.2.ebuild,v 1.4 2012/04/13 19:07:42 ulm Exp $
-
-EAPI="2"
-PHP_EXT_NAME="xcache"
-PHP_EXT_INI="yes"
-PHP_EXT_ZENDEXT="yes"
-PHPSAPILIST="apache2 cgi fpm"
-
-inherit php-ext-source-r2 confutils
-
-DESCRIPTION="A fast and stable PHP opcode cacher"
-HOMEPAGE="http://xcache.lighttpd.net/"
-SRC_URI="http://xcache.lighttpd.net/pub/Releases/${PV}/${P}.tar.bz2"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE=""
-
-# make test would just run php's test and as such need the full php source
-RESTRICT="test"
-
-DEPEND="virtual/httpd-php
-!dev-php/eaccelerator !dev-php/pecl-apc"
-RDEPEND="${DEPEND}"
-
-src_configure() {
-
- my_conf="--enable-xcache=shared \
- --enable-xcache-constant \
- --enable-xcache-optimizer \
- --enable-xcache-coverager \
- --enable-xcache-assembler \
- --enable-xcache-encoder \
- --enable-xcache-decoder"
-
- php-ext-source-r2_src_configure
-}
-
-src_install() {
- php-ext-source-r2_src_install
- dodoc AUTHORS ChangeLog NEWS README THANKS
-
- php-ext-source-r2_addtoinifiles "xcache.admin.enable_auth" '"On"'
- php-ext-source-r2_addtoinifiles "xcache.admin.user" '"admin"'
- php-ext-source-r2_addtoinifiles "xcache.admin.pass" '""'
-
- php-ext-source-r2_addtoinifiles "xcache.cacher" '"On"'
- php-ext-source-r2_addtoinifiles "xcache.size" '"64M"'
- php-ext-source-r2_addtoinifiles "xcache.count" '"2"'
- php-ext-source-r2_addtoinifiles "xcache.slots" '"8k"'
- php-ext-source-r2_addtoinifiles "xcache.ttl" '"0"'
- php-ext-source-r2_addtoinifiles "xcache.gc_interval" '"0"'
- php-ext-source-r2_addtoinifiles "xcache.var_size" '"8M"'
- php-ext-source-r2_addtoinifiles "xcache.var_count" '"1"'
- php-ext-source-r2_addtoinifiles "xcache.var_slots" '"8K"'
- php-ext-source-r2_addtoinifiles "xcache.var_ttl" '"0"'
- php-ext-source-r2_addtoinifiles "xcache.var_maxttl" '"0"'
- php-ext-source-r2_addtoinifiles "xcache.var_gc_interval" '"600"'
- php-ext-source-r2_addtoinifiles "xcache.readonly_protection" '"Off"'
- php-ext-source-r2_addtoinifiles "xcache.mmap_path" '"/dev/zero"'
-
- php-ext-source-r2_addtoinifiles "xcache.coverager" '"Off"'
- php-ext-source-r2_addtoinifiles "xcache.coveragedump_directory" '""'
-
- php-ext-source-r2_addtoinifiles "xcache.optimizer" '"Off"'
-
- insinto "${PHP_EXT_SHARED_DIR}"
- doins Decompiler.class.php
- insinto "${PHP_EXT_SHARED_DIR}/admin"
- doins admin/*
- insinto "${PHP_EXT_SHARED_DIR}/coverager"
- doins coverager/*
-}
-
-pkg_postinst() {
- elog "Decompiler.class.php, the admin/ and the coverager/ directory shipped with this"
- elog "release were installed into ${ROOT}usr/share/php5/xcache/."
-}
diff --git a/dev-php/xcache/xcache-2.0.1.ebuild b/dev-php/xcache/xcache-2.0.1.ebuild
deleted file mode 100644
index 099fc32a1be2..000000000000
--- a/dev-php/xcache/xcache-2.0.1.ebuild
+++ /dev/null
@@ -1,82 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/xcache/xcache-2.0.1.ebuild,v 1.1 2012/08/05 15:07:25 olemarkus Exp $
-
-EAPI="4"
-PHP_EXT_NAME="xcache"
-PHP_EXT_INI="yes"
-PHP_EXT_ZENDEXT="yes"
-PHPSAPILIST="apache2 cgi fpm"
-
-USE_PHP="php5-3 php5-4"
-inherit php-ext-source-r2 confutils
-
-DESCRIPTION="A fast and stable PHP opcode cacher"
-HOMEPAGE="http://xcache.lighttpd.net/"
-SRC_URI="http://xcache.lighttpd.net/pub/Releases/${PV}/${P}.tar.bz2"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-# make test would just run php's test and as such need the full php source
-RESTRICT="test"
-
-DEPEND="virtual/httpd-php
-!dev-php/eaccelerator !dev-php/pecl-apc"
-RDEPEND="${DEPEND}"
-
-src_configure() {
-
- my_conf="--enable-xcache=shared \
- --enable-xcache-constant \
- --enable-xcache-optimizer \
- --enable-xcache-coverager \
- --enable-xcache-assembler \
- --enable-xcache-encoder \
- --enable-xcache-decoder"
-
- php-ext-source-r2_src_configure
-}
-
-src_install() {
- php-ext-source-r2_src_install
- dodoc AUTHORS ChangeLog NEWS README THANKS
-
- php-ext-source-r2_addtoinifiles "xcache.admin.enable_auth" '"On"'
- php-ext-source-r2_addtoinifiles "xcache.admin.user" '"admin"'
- php-ext-source-r2_addtoinifiles "xcache.admin.pass" '""'
-
- php-ext-source-r2_addtoinifiles "xcache.cacher" '"On"'
- php-ext-source-r2_addtoinifiles "xcache.size" '"64M"'
- php-ext-source-r2_addtoinifiles "xcache.count" '"2"'
- php-ext-source-r2_addtoinifiles "xcache.slots" '"8k"'
- php-ext-source-r2_addtoinifiles "xcache.ttl" '"0"'
- php-ext-source-r2_addtoinifiles "xcache.gc_interval" '"0"'
- php-ext-source-r2_addtoinifiles "xcache.var_size" '"8M"'
- php-ext-source-r2_addtoinifiles "xcache.var_count" '"1"'
- php-ext-source-r2_addtoinifiles "xcache.var_slots" '"8K"'
- php-ext-source-r2_addtoinifiles "xcache.var_ttl" '"0"'
- php-ext-source-r2_addtoinifiles "xcache.var_maxttl" '"0"'
- php-ext-source-r2_addtoinifiles "xcache.var_gc_interval" '"600"'
- php-ext-source-r2_addtoinifiles "xcache.readonly_protection" '"Off"'
- php-ext-source-r2_addtoinifiles "xcache.mmap_path" '"/dev/zero"'
-
- php-ext-source-r2_addtoinifiles "xcache.coverager" '"Off"'
- php-ext-source-r2_addtoinifiles "xcache.coveragedump_directory" '""'
-
- php-ext-source-r2_addtoinifiles "xcache.optimizer" '"Off"'
-
- insinto "${PHP_EXT_SHARED_DIR}"
- doins Decompiler.class.php
- insinto "${PHP_EXT_SHARED_DIR}/admin"
- doins admin/*
- insinto "${PHP_EXT_SHARED_DIR}/coverager"
- doins coverager/*
-}
-
-pkg_postinst() {
- elog "Decompiler.class.php, the admin/ and the coverager/ directory shipped with this"
- elog "release were installed into ${ROOT}usr/share/php5/xcache/."
-}
diff --git a/dev-php/xcache/xcache-3.0.0.ebuild b/dev-php/xcache/xcache-3.0.0.ebuild
deleted file mode 100644
index 2b11e5311560..000000000000
--- a/dev-php/xcache/xcache-3.0.0.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/xcache/xcache-3.0.0.ebuild,v 1.2 2013/03/01 12:21:36 olemarkus Exp $
-
-EAPI="5"
-PHP_EXT_NAME="xcache"
-PHP_EXT_INI="yes"
-PHPSAPILIST="apache2 cgi fpm"
-
-USE_PHP="php5-3 php5-4"
-inherit php-ext-source-r2 confutils
-
-DESCRIPTION="A fast and stable PHP opcode cacher"
-HOMEPAGE="http://xcache.lighttpd.net/"
-SRC_URI="http://xcache.lighttpd.net/pub/Releases/${PV}/${P}.tar.bz2"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-# make test would just run php's test and as such need the full php source
-RESTRICT="test"
-
-DEPEND="virtual/httpd-php
-!dev-php/eaccelerator !dev-php/pecl-apc"
-RDEPEND="${DEPEND}"
-
-src_configure() {
-
- my_conf="--enable-xcache=shared \
- --enable-xcache-constant \
- --enable-xcache-optimizer \
- --enable-xcache-coverager \
- --enable-xcache-assembler \
- --enable-xcache-encoder \
- --enable-xcache-decoder"
-
- php-ext-source-r2_src_configure
-}
-
-src_install() {
- php-ext-source-r2_src_install
- dodoc AUTHORS ChangeLog NEWS README THANKS
-
- insinto "${PHP_EXT_SHARED_DIR}"
- doins lib/Decompiler.class.php
- insinto "${PHP_EXT_SHARED_DIR}"
- doins -r htdocs
-}
-
-pkg_postinst() {
- elog "lib/Decompiler.class.php, and the htdocs/ directory shipped with this"
- elog "release were installed into ${PHP_EXT_SHARED_DIR}."
-}