summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOle Markus With <olemarkus@gentoo.org>2011-03-26 11:43:06 +0000
committerOle Markus With <olemarkus@gentoo.org>2011-03-26 11:43:06 +0000
commit890ead352357e0378e372aa62fff4bb9b03ba650 (patch)
tree50f50ab267d2d89c75a459742b284947dabf741d /dev-php/phpunit
parentVersion bump. (diff)
downloadgentoo-2-890ead352357e0378e372aa62fff4bb9b03ba650.tar.gz
gentoo-2-890ead352357e0378e372aa62fff4bb9b03ba650.tar.bz2
gentoo-2-890ead352357e0378e372aa62fff4bb9b03ba650.zip
Version bump
(Portage version: 2.1.9.25/cvs/Linux i686)
Diffstat (limited to 'dev-php/phpunit')
-rw-r--r--dev-php/phpunit/ChangeLog11
-rw-r--r--dev-php/phpunit/phpunit-3.5.13.ebuild35
2 files changed, 43 insertions, 3 deletions
diff --git a/dev-php/phpunit/ChangeLog b/dev-php/phpunit/ChangeLog
index 44846ebd3dbd..5901f17220fe 100644
--- a/dev-php/phpunit/ChangeLog
+++ b/dev-php/phpunit/ChangeLog
@@ -1,6 +1,11 @@
-# ChangeLog for dev-php5/phpunit
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/phpunit/ChangeLog,v 1.1 2011/03/26 11:31:20 olemarkus Exp $
+# ChangeLog for dev-php/phpunit
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/phpunit/ChangeLog,v 1.2 2011/03/26 11:43:06 olemarkus Exp $
+
+*phpunit-3.5.13 (26 Mar 2011)
+
+ 26 Mar 2011; Ole Markus With <olemarkus@gentoo.org> +phpunit-3.5.13.ebuild:
+ Version bump
05 Nov 2010; Jeroen Roovers <jer@gentoo.org> phpunit-3.4.13.ebuild:
Stable for HPPA (bug #336869).
diff --git a/dev-php/phpunit/phpunit-3.5.13.ebuild b/dev-php/phpunit/phpunit-3.5.13.ebuild
new file mode 100644
index 000000000000..f4bbf8bd3848
--- /dev/null
+++ b/dev-php/phpunit/phpunit-3.5.13.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/phpunit/phpunit-3.5.13.ebuild,v 1.1 2011/03/26 11:43:06 olemarkus Exp $
+
+EAPI="2"
+PHP_PEAR_CHANNEL="pear.phpunit.de"
+PHP_PEAR_PN="PHP_TokenStream"
+
+inherit php-pear-lib-r1
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="Unit testing framework for PHP5"
+HOMEPAGE="http://www.phpunit.de/"
+SRC_URI="http://pear.phpunit.de/get/PHPUnit-${PV}.tgz"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+DEPEND=">=dev-php/PEAR-PEAR-1.9.1"
+RDEPEND="${DEPEND}
+ >=dev-lang/php-5.2.7[simplexml,xml,tokenizer]
+ || ( <dev-lang/php-5.3[pcre,reflection,spl] >=dev-lang/php-5.3 )
+ >=dev-php/PEAR-Image_GraphViz-1.2.1
+ >=dev-php/PEAR-Log-1.8.7-r1
+ dev-php/dbunit
+ dev-php/php-codecoverage
+ dev-php5/PEAR-PHP_Timer
+ dev-php5/phpunit-mockobject
+ dev-php5/phpunit-selenium"
+
+pkg_postinst() {
+ elog "${PN} can optionally use json, pdo-sqlite and pdo-mysql features."
+ elog "If you want those, emerge dev-lang/php with USE=\"json pdo sqlite mysql\"."
+}