summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-05-31 03:28:21 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-05-31 03:28:21 +0000
commit6c9b167ab9840ef9c39f8096f308ded7dde2c048 (patch)
treeec23cadd472aa5c3b24def6deb5ce2a1994d8672 /dev-perl
parentupdate to pygame 1.5 (diff)
downloadgentoo-2-6c9b167ab9840ef9c39f8096f308ded7dde2c048.tar.gz
gentoo-2-6c9b167ab9840ef9c39f8096f308ded7dde2c048.tar.bz2
gentoo-2-6c9b167ab9840ef9c39f8096f308ded7dde2c048.zip
version bump
Diffstat (limited to 'dev-perl')
-rw-r--r--dev-perl/SDL-sdlpl/ChangeLog9
-rw-r--r--dev-perl/SDL-sdlpl/SDL-sdlpl-1.18.ebuild (renamed from dev-perl/SDL-sdlpl/SDL-sdlpl-1.12.ebuild)36
-rw-r--r--dev-perl/SDL-sdlpl/files/digest-SDL-sdlpl-1.121
-rw-r--r--dev-perl/SDL-sdlpl/files/digest-SDL-sdlpl-1.12-r11
-rw-r--r--dev-perl/SDL-sdlpl/files/digest-SDL-sdlpl-1.181
5 files changed, 24 insertions, 24 deletions
diff --git a/dev-perl/SDL-sdlpl/ChangeLog b/dev-perl/SDL-sdlpl/ChangeLog
index 84e9768a6fc0..26b7b87defbb 100644
--- a/dev-perl/SDL-sdlpl/ChangeLog
+++ b/dev-perl/SDL-sdlpl/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for <CATEGORY>/<PACKAGE_NAME>
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/SDL-sdlpl/ChangeLog,v 1.2 2002/05/21 03:32:25 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/SDL-sdlpl/ChangeLog,v 1.3 2002/05/31 03:28:21 seemant Exp $
+
+*SDL-sdlpl-1.18 (30 May 2002)
+
+ 30 May 2002; Seemant Kulleen <seemant@gentoo.orG> SDL-sdlpl-1.18.ebuild
+ files/digest-SDL-sdlpl-1.18 :
+
+ Version bump thanks to: subdcc@501.xor.pl (Pawel SUchanecki) in bug#3227
*SDL-sdlpl-1.17 (20 May 2002)
diff --git a/dev-perl/SDL-sdlpl/SDL-sdlpl-1.12.ebuild b/dev-perl/SDL-sdlpl/SDL-sdlpl-1.18.ebuild
index 0b038cfdb2e2..b2b94182482c 100644
--- a/dev-perl/SDL-sdlpl/SDL-sdlpl-1.12.ebuild
+++ b/dev-perl/SDL-sdlpl/SDL-sdlpl-1.18.ebuild
@@ -1,18 +1,24 @@
# Copyright 2002 Gentoo Technologies, Inc.
# distributed under the terms of the GNU General Pulic License, v2.
# Author: Defresne Sylvain (keiichi) <kamisama@free.fr>
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/SDL-sdlpl/SDL-sdlpl-1.12.ebuild,v 1.2 2002/04/27 23:08:36 bangert Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/SDL-sdlpl/SDL-sdlpl-1.18.ebuild,v 1.1 2002/05/31 03:28:21 seemant Exp $
-S=${WORKDIR}/${P}
+
+inherit perl-module
+
+MY_P="SDL_perl"-${PV}
+S=${WORKDIR}/${MY_P}
DESCRIPTION="SDL binding for perl"
HOMEPAGE="http://sdlperl.org/"
-SRC_URI="http://sdlperl.org/${P}.tar.gz"
+SRC_URI="http://sdlperl.org/downloads/${MY_P}.tar.gz"
-DEPEND="virtual/glibc
+DEPEND="${DEPEND}
virtual/opengl
- >=sys-devel/perl-5.6.1
>=media-libs/sdl-mixer-1.0.5
- >=media-libs/sdl-image-1.0.0"
+ >=media-libs/sdl-image-1.0.0
+ truetype? ( >=media-libs/sdl-ttf-2.0.5 )"
+
+mydoc="BUGS COPYING TODO"
src_unpack()
{
@@ -20,20 +26,8 @@ src_unpack()
# Patch 'Makefile.PL' to use '/usr/include/SDL'
# instead of '/usr/local/include/SDL' ...
- cp "${P}/Makefile.PL" "${P}/Makefile.PL.orig"
- sed 's:/usr/local/include:/usr/include:g' < "${P}/Makefile.PL.orig" > "${P}/Makefile.PL"
+ cp "${MY_P}/Makefile.PL" "${MY_P}/Makefile.PL.orig"
+ sed 's:/usr/local/include:/usr/include:g' < "${MY_P}/Makefile.PL.orig" \
+ > "${MY_P}/Makefile.PL"
assert "Patching Makefile.PL failed !"
}
-
-src_compile ()
-{
- perl Makefile.PL || die
- make || die
-}
-
-src_install ()
-{
- make PREFIX="${D}/usr" INSTALLMAN3DIR="${D}/usr/share/man/man3" install || die
- dodoc BUGS COPYING README TODO
-}
-
diff --git a/dev-perl/SDL-sdlpl/files/digest-SDL-sdlpl-1.12 b/dev-perl/SDL-sdlpl/files/digest-SDL-sdlpl-1.12
deleted file mode 100644
index 848b6c1c29bd..000000000000
--- a/dev-perl/SDL-sdlpl/files/digest-SDL-sdlpl-1.12
+++ /dev/null
@@ -1 +0,0 @@
-MD5 e6f19fdfe4df0358c6bc4c458dc9bce5 SDL-sdlpl-1.12.tar.gz 164394
diff --git a/dev-perl/SDL-sdlpl/files/digest-SDL-sdlpl-1.12-r1 b/dev-perl/SDL-sdlpl/files/digest-SDL-sdlpl-1.12-r1
deleted file mode 100644
index 848b6c1c29bd..000000000000
--- a/dev-perl/SDL-sdlpl/files/digest-SDL-sdlpl-1.12-r1
+++ /dev/null
@@ -1 +0,0 @@
-MD5 e6f19fdfe4df0358c6bc4c458dc9bce5 SDL-sdlpl-1.12.tar.gz 164394
diff --git a/dev-perl/SDL-sdlpl/files/digest-SDL-sdlpl-1.18 b/dev-perl/SDL-sdlpl/files/digest-SDL-sdlpl-1.18
new file mode 100644
index 000000000000..d33c627bf666
--- /dev/null
+++ b/dev-perl/SDL-sdlpl/files/digest-SDL-sdlpl-1.18
@@ -0,0 +1 @@
+MD5 ad9c9f6adea4ad71069fd4a43004c98f SDL_perl-1.18.tar.gz 624529