summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-05-20 14:08:04 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-05-20 14:08:04 +0000
commit3915d45d79cfdc048f6e60020e5ae58ab5ed302c (patch)
tree39529fbb2ae688eafbc4a59451094f1c17ded5b3 /dev-perl
parentHave c_rehash default to /etc/ssl #416717 by Marc Schiffbauer. (diff)
downloadgentoo-2-3915d45d79cfdc048f6e60020e5ae58ab5ed302c.tar.gz
gentoo-2-3915d45d79cfdc048f6e60020e5ae58ab5ed302c.tar.bz2
gentoo-2-3915d45d79cfdc048f6e60020e5ae58ab5ed302c.zip
Use virtualx.eclass to ensure DISPLAY is set for FEATURES="test" wrt #416729 by Paweł Hajdan, Jr.
(Portage version: 2.2.0_alpha107/cvs/Linux x86_64)
Diffstat (limited to 'dev-perl')
-rw-r--r--dev-perl/Gtk2-Notify/ChangeLog6
-rw-r--r--dev-perl/Gtk2-Notify/Gtk2-Notify-0.05.ebuild8
2 files changed, 11 insertions, 3 deletions
diff --git a/dev-perl/Gtk2-Notify/ChangeLog b/dev-perl/Gtk2-Notify/ChangeLog
index 3a517fa53c70..bf1a5415ced1 100644
--- a/dev-perl/Gtk2-Notify/ChangeLog
+++ b/dev-perl/Gtk2-Notify/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-perl/Gtk2-Notify
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/Gtk2-Notify/ChangeLog,v 1.3 2012/05/20 09:41:23 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Gtk2-Notify/ChangeLog,v 1.4 2012/05/20 14:08:04 ssuominen Exp $
+
+ 20 May 2012; Samuli Suominen <ssuominen@gentoo.org> Gtk2-Notify-0.05.ebuild:
+ Use virtualx.eclass to ensure DISPLAY is set for FEATURES="test" wrt #416729
+ by Paweł Hajdan, Jr.
20 May 2012; Agostino Sarubbo <ago@gentoo.org> Gtk2-Notify-0.05.ebuild:
Stable for amd64, wrt bug #416121
diff --git a/dev-perl/Gtk2-Notify/Gtk2-Notify-0.05.ebuild b/dev-perl/Gtk2-Notify/Gtk2-Notify-0.05.ebuild
index 3a019d503cc6..3538da86acd0 100644
--- a/dev-perl/Gtk2-Notify/Gtk2-Notify-0.05.ebuild
+++ b/dev-perl/Gtk2-Notify/Gtk2-Notify-0.05.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/Gtk2-Notify/Gtk2-Notify-0.05.ebuild,v 1.2 2012/05/20 09:41:23 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Gtk2-Notify/Gtk2-Notify-0.05.ebuild,v 1.3 2012/05/20 14:08:04 ssuominen Exp $
EAPI=4
MODULE_AUTHOR=FLORA
-inherit perl-module
+inherit perl-module virtualx
DESCRIPTION="A perl interface to the notification library"
@@ -26,3 +26,7 @@ DEPEND="${RDEPEND}
SRC_TEST="do"
PATCHES=( "${FILESDIR}"/${P}-libnotify.patch )
+
+src_test() {
+ VIRTUALX_COMMAND="perl-module_src_test" virtualmake #416729
+}