summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2002-11-07 13:14:29 +0000
committerMartin Schlemmer <azarah@gentoo.org>2002-11-07 13:14:29 +0000
commit32d82049ef0aed25132533f8911192b06d71e215 (patch)
treee52e2a0585658f93c732b6cfc04cd6e13b020f0e /dev-perl/gtk-perl
parentchase latest; major cleanups :) (diff)
downloadgentoo-2-32d82049ef0aed25132533f8911192b06d71e215.tar.gz
gentoo-2-32d82049ef0aed25132533f8911192b06d71e215.tar.bz2
gentoo-2-32d82049ef0aed25132533f8911192b06d71e215.zip
fix not detecting gdk-pixbuf-0.20.0
Diffstat (limited to 'dev-perl/gtk-perl')
-rw-r--r--dev-perl/gtk-perl/ChangeLog8
-rw-r--r--dev-perl/gtk-perl/files/digest-gtk-perl-0.7008-r71
-rw-r--r--dev-perl/gtk-perl/files/gtk-perl-0.7008-gdkpixbuf-detect-fix.patch11
-rw-r--r--dev-perl/gtk-perl/gtk-perl-0.7008-r7.ebuild42
4 files changed, 61 insertions, 1 deletions
diff --git a/dev-perl/gtk-perl/ChangeLog b/dev-perl/gtk-perl/ChangeLog
index 4e8e8e5415ec..4eec5991b96e 100644
--- a/dev-perl/gtk-perl/ChangeLog
+++ b/dev-perl/gtk-perl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-perlgtk-perlChangeLog/
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/gtk-perl/ChangeLog,v 1.11 2002/11/05 16:14:59 mcummings Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/gtk-perl/ChangeLog,v 1.12 2002/11/07 13:14:29 azarah Exp $
+
+*gtk-perl-0.7008-r7 (7 Nov 2002)
+
+ 07 Nov 2002; Martin Schlemmer <azarah@gentoo.org> :
+
+ Fix gdk-pixbuf-0.20.0 not detected, bug #10232.
*gtk-perl-0.7008-r6 (26 May 2002)
diff --git a/dev-perl/gtk-perl/files/digest-gtk-perl-0.7008-r7 b/dev-perl/gtk-perl/files/digest-gtk-perl-0.7008-r7
new file mode 100644
index 000000000000..14b778b7f495
--- /dev/null
+++ b/dev-perl/gtk-perl/files/digest-gtk-perl-0.7008-r7
@@ -0,0 +1 @@
+MD5 b499abb5db7794f200abbf07879dd65d Gtk-Perl-0.7008.tar.gz 455977
diff --git a/dev-perl/gtk-perl/files/gtk-perl-0.7008-gdkpixbuf-detect-fix.patch b/dev-perl/gtk-perl/files/gtk-perl-0.7008-gdkpixbuf-detect-fix.patch
new file mode 100644
index 000000000000..05b53c1de329
--- /dev/null
+++ b/dev-perl/gtk-perl/files/gtk-perl-0.7008-gdkpixbuf-detect-fix.patch
@@ -0,0 +1,11 @@
+--- Gtk-Perl-0.7008/Makefile.PL.orig 2002-11-06 00:19:54.000000000 +0200
++++ Gtk-Perl-0.7008/Makefile.PL 2002-11-06 00:21:12.000000000 +0200
+@@ -22,7 +22,7 @@
+ check => sub {ccompile('#include <gtkgl/gtkglarea.h>', "", `gtk-config --cflags`,
+ "-lgtkgl -lGL -lGLU " . `gtk-config --libs`)}},
+ gdkpixbuf => {order => 2, dir => 'GdkPixbuf', depends => [qw(gtk)],
+- check => sub {cconfig('gdk-pixbuf-config --version', '0\.(8|9|1\d)\.?')}},
++ check => sub {cconfig('gdk-pixbuf-config --version', '0\.(8|9|1|2\d)\.?')}},
+ gtkhtml => {order => 2, dir => 'GtkHTML', depends => [qw(gtk)],
+ check => sub {cconfig('gnome-config --modversion gtkhtml', 'gtkhtml-0\.[89]')}},
+ gtkxmhtml => {order => 2, dir => 'GtkXmHTML', depends => [qw(gtk)],
diff --git a/dev-perl/gtk-perl/gtk-perl-0.7008-r7.ebuild b/dev-perl/gtk-perl/gtk-perl-0.7008-r7.ebuild
new file mode 100644
index 000000000000..0c43d68dc1ac
--- /dev/null
+++ b/dev-perl/gtk-perl/gtk-perl-0.7008-r7.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/gtk-perl/gtk-perl-0.7008-r7.ebuild,v 1.1 2002/11/07 13:14:29 azarah Exp $
+
+inherit perl-module
+
+MY_P=Gtk-Perl-${PV}
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="Perl bindings for GTK"
+SRC_URI="http://www.gtkperl.org/${MY_P}.tar.gz"
+HOMEPAGE="http://www.perl.org/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86 ppc sparc sparc64 alpha"
+
+DEPEND="${DEPEND}
+ media-libs/gdk-pixbuf
+ =x11-libs/gtk+-1.2*
+ dev-perl/XML-Writer
+ dev-perl/XML-Parser
+ gnome? ( gnome-base/gnome-libs )"
+
+mydoc="VERSIONS WARNING NOTES"
+
+src_unpack() {
+
+ unpack ${A}
+
+ # Fix gdk-pixbuf-0.20.0 not detected, bug #10232.
+ cd ${S}; patch -p1 < ${FILESDIR}/${P}-gdkpixbuf-detect-fix.patch || die
+}
+
+use gnome || (myconf="${myconf} --without-module gnome --without-module gnomeprint")
+src_compile() {
+
+ cd ${S}
+ cp Makefile.PL Makefile.PL.bak
+ perl -pi -e '/CCMD/ && s|/m;|/mg;|' */Makefile.PL
+ perl-module_src_compile
+
+}