summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2012-02-29 09:16:11 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2012-02-29 09:16:11 +0000
commitd9c9a9db101ac3cabe5907bbe506fa6e73ea734b (patch)
tree04bd5adc5b09ac6ba9d73398bc21792fc3ca0954 /dev-perl/WWW-Mechanize
parentVersion bump via perl-bump experimental tool. (diff)
downloadgentoo-2-d9c9a9db101ac3cabe5907bbe506fa6e73ea734b.tar.gz
gentoo-2-d9c9a9db101ac3cabe5907bbe506fa6e73ea734b.tar.bz2
gentoo-2-d9c9a9db101ac3cabe5907bbe506fa6e73ea734b.zip
Version bump via perl-bump experimental tool.
(Portage version: 2.2.0_alpha89/cvs/Linux x86_64)
Diffstat (limited to 'dev-perl/WWW-Mechanize')
-rw-r--r--dev-perl/WWW-Mechanize/ChangeLog10
-rw-r--r--dev-perl/WWW-Mechanize/WWW-Mechanize-1.720.0.ebuild44
2 files changed, 52 insertions, 2 deletions
diff --git a/dev-perl/WWW-Mechanize/ChangeLog b/dev-perl/WWW-Mechanize/ChangeLog
index 980a9b773044..c8a81ffbe862 100644
--- a/dev-perl/WWW-Mechanize/ChangeLog
+++ b/dev-perl/WWW-Mechanize/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-perl/WWW-Mechanize
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/WWW-Mechanize/ChangeLog,v 1.81 2011/11/30 18:58:42 tove Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/WWW-Mechanize/ChangeLog,v 1.82 2012/02/29 09:16:11 robbat2 Exp $
+
+*WWW-Mechanize-1.720.0 (29 Feb 2012)
+
+ 29 Feb 2012; Robin H. Johnson <robbat2@gentoo.org>
+ +WWW-Mechanize-1.720.0.ebuild:
+ Version bump via perl-bump experimental tool.
*WWW-Mechanize-1.710.0 (30 Nov 2011)
diff --git a/dev-perl/WWW-Mechanize/WWW-Mechanize-1.720.0.ebuild b/dev-perl/WWW-Mechanize/WWW-Mechanize-1.720.0.ebuild
new file mode 100644
index 000000000000..34cd42b4191c
--- /dev/null
+++ b/dev-perl/WWW-Mechanize/WWW-Mechanize-1.720.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/WWW-Mechanize/WWW-Mechanize-1.720.0.ebuild,v 1.1 2012/02/29 09:16:11 robbat2 Exp $
+
+EAPI=4
+
+MODULE_AUTHOR=JESSE
+MODULE_VERSION=1.72
+inherit perl-module
+
+DESCRIPTION="Handy web browsing in a Perl object"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="test"
+
+RDEPEND="
+ dev-perl/IO-Socket-SSL
+ || (
+ ( >dev-perl/libwww-perl-6 dev-perl/HTML-Form )
+ <dev-perl/libwww-perl-6
+ )
+ >=dev-perl/URI-1.36
+ >=dev-perl/HTML-Parser-3.34
+ dev-perl/HTML-Tree
+"
+DEPEND="${RDEPEND}
+ test? (
+ dev-perl/PadWalker
+ dev-perl/Test-Pod
+ dev-perl/Test-Pod-Coverage
+ dev-perl/Test-Exception
+ dev-perl/Test-NoWarnings
+ dev-perl/Test-Taint
+ >=dev-perl/Test-Warn-0.11
+ dev-perl/Test-Memory-Cycle
+ dev-perl/HTTP-Server-Simple
+ )
+"
+
+# configure to run the local tests, but not the ones which access the Internet
+myconf="--local --nolive"
+
+SRC_TEST=do