summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2011-11-30 18:58:42 +0000
committerTorsten Veller <tove@gentoo.org>2011-11-30 18:58:42 +0000
commit7a92e859f0972e9751ebb27f2424fe0f943d25b6 (patch)
treebcfa9dc0c3181637833e3cbcaeca8336bacbf89b /dev-perl/WWW-Mechanize
parent[bump] virtual/perl-version-0.950.0 (diff)
downloadgentoo-2-7a92e859f0972e9751ebb27f2424fe0f943d25b6.tar.gz
gentoo-2-7a92e859f0972e9751ebb27f2424fe0f943d25b6.tar.bz2
gentoo-2-7a92e859f0972e9751ebb27f2424fe0f943d25b6.zip
[bump] dev-perl/WWW-Mechanize-1.710.0
(Portage version: 2.2.0_alpha79/cvs/Linux x86_64)
Diffstat (limited to 'dev-perl/WWW-Mechanize')
-rw-r--r--dev-perl/WWW-Mechanize/ChangeLog7
-rw-r--r--dev-perl/WWW-Mechanize/WWW-Mechanize-1.710.0.ebuild44
2 files changed, 50 insertions, 1 deletions
diff --git a/dev-perl/WWW-Mechanize/ChangeLog b/dev-perl/WWW-Mechanize/ChangeLog
index a71ce77670ba..980a9b773044 100644
--- a/dev-perl/WWW-Mechanize/ChangeLog
+++ b/dev-perl/WWW-Mechanize/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-perl/WWW-Mechanize
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/WWW-Mechanize/ChangeLog,v 1.80 2011/09/04 11:24:00 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/WWW-Mechanize/ChangeLog,v 1.81 2011/11/30 18:58:42 tove Exp $
+
+*WWW-Mechanize-1.710.0 (30 Nov 2011)
+
+ 30 Nov 2011; Torsten Veller <tove@gentoo.org> +WWW-Mechanize-1.710.0.ebuild:
+ Version bump. Drop Test-LongString, add HTML-Tree and enable the tests again.
04 Sep 2011; Torsten Veller <tove@gentoo.org> -WWW-Mechanize-1.680.0.ebuild:
Cleanup
diff --git a/dev-perl/WWW-Mechanize/WWW-Mechanize-1.710.0.ebuild b/dev-perl/WWW-Mechanize/WWW-Mechanize-1.710.0.ebuild
new file mode 100644
index 000000000000..fcc998f4a5c5
--- /dev/null
+++ b/dev-perl/WWW-Mechanize/WWW-Mechanize-1.710.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/WWW-Mechanize/WWW-Mechanize-1.710.0.ebuild,v 1.1 2011/11/30 18:58:42 tove Exp $
+
+EAPI=4
+
+MODULE_AUTHOR=JESSE
+MODULE_VERSION=1.71
+inherit perl-module
+
+DESCRIPTION="Handy web browsing in a Perl object"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="test"
+
+RDEPEND="
+ dev-perl/IO-Socket-SSL
+ || (
+ ( >dev-perl/libwww-perl-6 dev-perl/HTML-Form )
+ <dev-perl/libwww-perl-6
+ )
+ >=dev-perl/URI-1.36
+ >=dev-perl/HTML-Parser-3.34
+ dev-perl/HTML-Tree
+"
+DEPEND="${RDEPEND}
+ test? (
+ dev-perl/PadWalker
+ dev-perl/Test-Pod
+ dev-perl/Test-Pod-Coverage
+ dev-perl/Test-Exception
+ dev-perl/Test-NoWarnings
+ dev-perl/Test-Taint
+ >=dev-perl/Test-Warn-0.11
+ dev-perl/Test-Memory-Cycle
+ dev-perl/HTTP-Server-Simple
+ )
+"
+
+# configure to run the local tests, but not the ones which access the Internet
+myconf="--local --nolive"
+
+SRC_TEST=do