summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2007-05-13 08:18:36 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2007-05-13 08:18:36 +0000
commit3f263324cb14463069250cb0a43db992de911056 (patch)
tree64f731b7436e0dd2a8ff83324404c3f2c5b70d6a /dev-perl/Perlbal
parentPatch gearmand to have a suitable cmdline in the process listing, and thus si... (diff)
downloadgentoo-2-3f263324cb14463069250cb0a43db992de911056.tar.gz
gentoo-2-3f263324cb14463069250cb0a43db992de911056.tar.bz2
gentoo-2-3f263324cb14463069250cb0a43db992de911056.zip
Patch perlbal to have a suitable cmdline in the process listing, and add an init script now that it is possible.
(Portage version: 2.1.2.7)
Diffstat (limited to 'dev-perl/Perlbal')
-rw-r--r--dev-perl/Perlbal/ChangeLog11
-rw-r--r--dev-perl/Perlbal/Perlbal-1.58.ebuild44
-rw-r--r--dev-perl/Perlbal/files/Perlbal-1.58-Use-saner-name-in-process-listing.patch34
-rw-r--r--dev-perl/Perlbal/files/digest-Perlbal-1.583
-rw-r--r--dev-perl/Perlbal/files/perlbal_conf.d_1.585
-rwxr-xr-xdev-perl/Perlbal/files/perlbal_init.d_1.5825
6 files changed, 121 insertions, 1 deletions
diff --git a/dev-perl/Perlbal/ChangeLog b/dev-perl/Perlbal/ChangeLog
index 73410b7d74b9..ed15e2cf0565 100644
--- a/dev-perl/Perlbal/ChangeLog
+++ b/dev-perl/Perlbal/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for dev-perl/Perlbal
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/Perlbal/ChangeLog,v 1.1 2007/04/30 06:01:23 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Perlbal/ChangeLog,v 1.2 2007/05/13 08:18:36 robbat2 Exp $
+
+*Perlbal-1.58 (13 May 2007)
+
+ 13 May 2007; Robin H. Johnson <robbat2@gentoo.org>
+ +files/Perlbal-1.58-Use-saner-name-in-process-listing.patch,
+ +files/perlbal_conf.d_1.58, +files/perlbal_init.d_1.58,
+ +Perlbal-1.58.ebuild:
+ Patch perlbal to have a suitable cmdline in the process listing, and add an
+ init script now that it is possible.
*Perlbal-1.57 (30 Apr 2007)
diff --git a/dev-perl/Perlbal/Perlbal-1.58.ebuild b/dev-perl/Perlbal/Perlbal-1.58.ebuild
new file mode 100644
index 000000000000..fd9a5b2e90ba
--- /dev/null
+++ b/dev-perl/Perlbal/Perlbal-1.58.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Perlbal/Perlbal-1.58.ebuild,v 1.1 2007/05/13 08:18:36 robbat2 Exp $
+
+inherit perl-module
+
+DESCRIPTION="Reverse-proxy load balancer and webserver"
+HOMEPAGE="http://search.cpan.org/search?query=Perlbal&mode=dist"
+SRC_URI="mirror://cpan/authors/id/B/BR/BRADFITZ/${P}.tar.gz"
+
+IUSE=""
+
+SLOT="0"
+LICENSE="|| ( Artistic GPL-2 )"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+DEPEND="dev-perl/libwww-perl
+ >=dev-perl/Danga-Socket-1.57
+ dev-perl/Sys-Syscall
+ dev-perl/BSD-Resource
+ dev-lang/perl"
+#SRC_TEST="do" # testing not available on Perlbal yet ;-)
+mydoc="CHANGES"
+
+PATCHES="${FILESDIR}/${PN}-1.58-Use-saner-name-in-process-listing.patch"
+
+src_install() {
+ perl-module_src_install || die "perl-module_src_install failed"
+ cd ${S}
+ dodoc doc/*.txt
+ docinto hacking
+ dodoc doc/hacking/*.txt
+ docinto conf
+ dodoc conf/*.{dat,conf}
+ keepdir /etc/perlbal
+ newinitd ${FILESDIR}/perlbal_init.d_1.58 perlbal
+ newconfd ${FILESDIR}/perlbal_conf.d_1.58 perlbal
+}
+
+pkg_postinst() {
+ perl-module_pkg_postinst
+ einfo "Please see the example configuration files located"
+ einfo "within /usr/share/doc/${PF}/conf/"
+}
diff --git a/dev-perl/Perlbal/files/Perlbal-1.58-Use-saner-name-in-process-listing.patch b/dev-perl/Perlbal/files/Perlbal-1.58-Use-saner-name-in-process-listing.patch
new file mode 100644
index 000000000000..1ccafb9cb9b7
--- /dev/null
+++ b/dev-perl/Perlbal/files/Perlbal-1.58-Use-saner-name-in-process-listing.patch
@@ -0,0 +1,34 @@
+From 75b0930eb392c6389f6e96b0c1df067ae917b962 Mon Sep 17 00:00:00 2001
+From: Robin H. Johnson <robbat2@gentoo.org>
+Date: Sat, 12 May 2007 21:32:53 -0700
+Subject: [PATCH perlbal] Use saner name in process listing.
+
+Normally the binary will turn up in the process list as:
+/usr/bin/perl $SCRIPTNAME
+
+By adding a single line, we can make it be simply '$SCRIPTNAME'.
+This makes writing init.d scripts signficently easier.
+
+Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
+---
+ perlbal | 4 ++++
+ 1 files changed, 4 insertions(+), 0 deletions(-)
+
+diff --git a/perlbal b/perlbal
+index f0149b3..7a9d28c 100755
+--- a/perlbal
++++ b/perlbal
+@@ -37,6 +37,10 @@ my $opt_daemonize;
+ my $opt_config;
+ my $opt_help;
+ my $opt_version;
++
++# Rename binary in process list to make init scripts saner
++$0 = $_ = $0;
++
+ usage(1) unless
+ Getopt::Long::GetOptions(
+ 'daemon' => \$opt_daemonize,
+--
+1.5.1.4
+
diff --git a/dev-perl/Perlbal/files/digest-Perlbal-1.58 b/dev-perl/Perlbal/files/digest-Perlbal-1.58
new file mode 100644
index 000000000000..c79471b0d6b9
--- /dev/null
+++ b/dev-perl/Perlbal/files/digest-Perlbal-1.58
@@ -0,0 +1,3 @@
+MD5 74fcead0bceef6d8ef454ae6656ced88 Perlbal-1.58.tar.gz 128557
+RMD160 fd42bb7df27631b83ec15e9cb6acf97cddeeb8b9 Perlbal-1.58.tar.gz 128557
+SHA256 01324bdaac313bed0ce579141ee119664ab9adb819953aade61e5b1521078bf6 Perlbal-1.58.tar.gz 128557
diff --git a/dev-perl/Perlbal/files/perlbal_conf.d_1.58 b/dev-perl/Perlbal/files/perlbal_conf.d_1.58
new file mode 100644
index 000000000000..f500cb435317
--- /dev/null
+++ b/dev-perl/Perlbal/files/perlbal_conf.d_1.58
@@ -0,0 +1,5 @@
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Perlbal/files/perlbal_conf.d_1.58,v 1.1 2007/05/13 08:18:36 robbat2 Exp $
+# PIDFILE is not yet used, pending upstream still
+#PIDFILE="/var/run/perlbal.pid"
+PERLBAL_OPTS="--daemon --config=/etc/perlbal/perlbal.conf"
+# vim: ft=gentoo-conf-d:
diff --git a/dev-perl/Perlbal/files/perlbal_init.d_1.58 b/dev-perl/Perlbal/files/perlbal_init.d_1.58
new file mode 100755
index 000000000000..38f64f4960d7
--- /dev/null
+++ b/dev-perl/Perlbal/files/perlbal_init.d_1.58
@@ -0,0 +1,25 @@
+#!/sbin/runscript
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Perlbal/files/perlbal_init.d_1.58,v 1.1 2007/05/13 08:18:36 robbat2 Exp $
+
+NAME="perlbal"
+BINARY="/usr/bin/perlbal"
+
+depend() {
+ use net
+}
+
+start() {
+ ebegin "Starting $NAME"
+ # Add --pidfile when upstream supports PIDFILES
+ start-stop-daemon --start \
+ --exec ${BINARY} -- ${PERLBAL_OPTS}
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping $NAME"
+ start-stop-daemon --stop --exec "${BINARY}"
+ eend $?
+}
+
+# vim: ft=gentoo-init-d: