summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2010-01-07 14:12:42 +0000
committerTorsten Veller <tove@gentoo.org>2010-01-07 14:12:42 +0000
commit127eeaa725ce54c1c539dea92e2e2ffc95c14613 (patch)
tree165cd6340ee039bb2067662346844b24b1518a24 /dev-perl/HTML-TableContentParser
parentBump (diff)
downloadgentoo-2-127eeaa725ce54c1c539dea92e2e2ffc95c14613.tar.gz
gentoo-2-127eeaa725ce54c1c539dea92e2e2ffc95c14613.tar.bz2
gentoo-2-127eeaa725ce54c1c539dea92e2e2ffc95c14613.zip
Fix test failure on perl-5.10.1 (#300013). Thanks to David Abbott
(Portage version: 2.2_rc61/cvs/Linux x86_64)
Diffstat (limited to 'dev-perl/HTML-TableContentParser')
-rw-r--r--dev-perl/HTML-TableContentParser/ChangeLog8
-rw-r--r--dev-perl/HTML-TableContentParser/HTML-TableContentParser-0.13.ebuild5
-rw-r--r--dev-perl/HTML-TableContentParser/files/0.13-test.patch74
3 files changed, 83 insertions, 4 deletions
diff --git a/dev-perl/HTML-TableContentParser/ChangeLog b/dev-perl/HTML-TableContentParser/ChangeLog
index 1e65b99598fc..c3bd59e3debd 100644
--- a/dev-perl/HTML-TableContentParser/ChangeLog
+++ b/dev-perl/HTML-TableContentParser/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-perl/HTML-TableContentParser
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/HTML-TableContentParser/ChangeLog,v 1.5 2009/12/07 12:38:43 tove Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/HTML-TableContentParser/ChangeLog,v 1.6 2010/01/07 14:12:41 tove Exp $
+
+ 07 Jan 2010; Torsten Veller <tove@gentoo.org> +files/0.13-test.patch,
+ HTML-TableContentParser-0.13.ebuild:
+ Fix test failure on perl-5.10.1 (#300013). Thanks to David Abbott
07 Dec 2009; Torsten Veller <tove@gentoo.org> metadata.xml:
Add perl herd
diff --git a/dev-perl/HTML-TableContentParser/HTML-TableContentParser-0.13.ebuild b/dev-perl/HTML-TableContentParser/HTML-TableContentParser-0.13.ebuild
index caf880df6f7d..229e6b1d2576 100644
--- a/dev-perl/HTML-TableContentParser/HTML-TableContentParser-0.13.ebuild
+++ b/dev-perl/HTML-TableContentParser/HTML-TableContentParser-0.13.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/HTML-TableContentParser/HTML-TableContentParser-0.13.ebuild,v 1.5 2009/06/23 10:53:41 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/HTML-TableContentParser/HTML-TableContentParser-0.13.ebuild,v 1.6 2010/01/07 14:12:41 tove Exp $
EAPI=2
@@ -17,3 +17,4 @@ RDEPEND="dev-perl/HTML-Parser"
DEPEND="${RDEPEND}"
SRC_TEST=do
+PATCHES=( "${FILESDIR}"/0.13-test.patch )
diff --git a/dev-perl/HTML-TableContentParser/files/0.13-test.patch b/dev-perl/HTML-TableContentParser/files/0.13-test.patch
new file mode 100644
index 000000000000..79916acc1e1c
--- /dev/null
+++ b/dev-perl/HTML-TableContentParser/files/0.13-test.patch
@@ -0,0 +1,74 @@
+--- t/1.t
++++ t/1.t
+@@ -2,6 +2,8 @@
+
+
+ use Test;
++use strict;
++use warnings;
+
+ BEGIN { plan tests => 34 }
+
+@@ -20,7 +22,7 @@
+
+ ## Test object creation
+
+-$obj = HTML::TableContentParser->new();
++my $obj = HTML::TableContentParser->new();
+ ok(defined $obj, 1, $@);
+
+
+@@ -29,14 +31,14 @@
+ ## the correct values to the callback.
+
+
+-$table_caption = 'This is a caption';
+-$table_content1 = 'This is table cell content 1';
+-$table_content2 = 'This is table cell content 2';
+-$table_content3 = '<a href="SomeLink">This is table cell content 3, a link</a>';
+-$table_content4 = 'Some more text wrapping <a href="SomeLink">This is table cell content 4</a> a link.';
+-$header_text = 'Header text';
++my $table_caption = 'This is a caption';
++my $table_content1 = 'This is table cell content 1';
++my $table_content2 = 'This is table cell content 2';
++my $table_content3 = '<a href="SomeLink">This is table cell content 3, a link</a>';
++my $table_content4 = 'Some more text wrapping <a href="SomeLink">This is table cell content 4</a> a link.';
++my $header_text = 'Header text';
+
+-$html = qq{
++my $html = qq{
+ <html>
+ <head>
+ </head>
+@@ -59,7 +61,7 @@
+
+
+ $HTML::TableContentParser::DEBUG = 0;
+-$tables = $obj->parse($html);
++my $tables = $obj->parse($html);
+ ok($tables->[0]->{caption}->{data}, $table_caption, $@);
+ ok($tables->[0]->{rows}->[0]->{cells}->[0]->{data}, $table_content1, $@);
+ ok($tables->[0]->{rows}->[1]->{cells}->[0]->{data}, $table_content2, $@);
+@@ -124,16 +126,17 @@
+ ok(@$tables, 2, @_);
+
+ ## and three headers for each table
+-for $t (0..$#{@$tables}) {
+- for (0..$#hdrs) {
+- ok($tables->[$t]->{headers}->[$_]->{data}, $hdrs[$_], $@);
++for my $t (0..(@$tables-1)) {
++ for (0..2) {
++ # ok($t, $t);
++ ok($tables->[$t]->{headers}->[$_]->{data}, $hdrs[$_], $@);
+ }
+ }
+
+
+ ## and three rows of three cells each, for each table.. (18 total).
+-for $t (0..$#{@$tables}) {
+- for $r (0..$#rows) {
++for my $t (0..1) {
++ for my $r (0..$#rows) {
+ for (0..2) {
+ ok($tables->[$t]->{rows}->[$r]->{cells}->[$_]->{data}, $rows[$r]->[$_], $@);
+ }