summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2013-08-17 13:24:19 +0000
committerPatrick Lauer <patrick@gentoo.org>2013-08-17 13:24:19 +0000
commit95814fce103a116b7cd0477e1e77d43da720fa36 (patch)
tree7b3c8d449b6cda3fcf01e875c4a519f9ef6f4aa5 /dev-perl/DBD-SQLite
parentBump (diff)
downloadgentoo-2-95814fce103a116b7cd0477e1e77d43da720fa36.tar.gz
gentoo-2-95814fce103a116b7cd0477e1e77d43da720fa36.tar.bz2
gentoo-2-95814fce103a116b7cd0477e1e77d43da720fa36.zip
Bump
(Portage version: 2.2.0/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-perl/DBD-SQLite')
-rw-r--r--dev-perl/DBD-SQLite/ChangeLog9
-rw-r--r--dev-perl/DBD-SQLite/DBD-SQLite-1.400.0.ebuild40
2 files changed, 47 insertions, 2 deletions
diff --git a/dev-perl/DBD-SQLite/ChangeLog b/dev-perl/DBD-SQLite/ChangeLog
index bb2e1dc79ab2..0d05faf9e420 100644
--- a/dev-perl/DBD-SQLite/ChangeLog
+++ b/dev-perl/DBD-SQLite/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-perl/DBD-SQLite
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/DBD-SQLite/ChangeLog,v 1.109 2012/09/02 17:30:27 tove Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/DBD-SQLite/ChangeLog,v 1.110 2013/08/17 13:24:19 patrick Exp $
+
+*DBD-SQLite-1.400.0 (17 Aug 2013)
+
+ 17 Aug 2013; Patrick Lauer <patrick@gentoo.org> +DBD-SQLite-1.400.0.ebuild:
+ Bump
02 Sep 2012; Torsten Veller <tove@gentoo.org> -DBD-SQLite-0.31-r1.ebuild,
-DBD-SQLite-1.31.ebuild, -DBD-SQLite-1.330.0.ebuild:
diff --git a/dev-perl/DBD-SQLite/DBD-SQLite-1.400.0.ebuild b/dev-perl/DBD-SQLite/DBD-SQLite-1.400.0.ebuild
new file mode 100644
index 000000000000..b3ae72443880
--- /dev/null
+++ b/dev-perl/DBD-SQLite/DBD-SQLite-1.400.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/DBD-SQLite/DBD-SQLite-1.400.0.ebuild,v 1.1 2013/08/17 13:24:19 patrick Exp $
+
+EAPI=4
+
+MODULE_AUTHOR=ISHIGAKI
+MODULE_VERSION=1.40
+inherit perl-module
+
+DESCRIPTION="Self Contained RDBMS in a DBI Driver"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE="test"
+
+RDEPEND="
+ >=dev-db/sqlite-3.6.22[extensions]
+ >=dev-perl/DBI-1.57
+ !<dev-perl/DBD-SQLite-1
+"
+DEPEND="${RDEPEND}
+ test? (
+ >=virtual/perl-Test-Simple-0.86
+ )
+"
+
+SRC_TEST="do"
+
+src_prepare() {
+ perl-module_src_prepare
+ sed -i 's/^if ( 0 )/if ( 1 )/' "${S}"/Makefile.PL || die
+ # remove bundled sqlite (rt.cpan#61361)
+ for i in sqlite3{.c,.h,ext.h} ; do
+ rm ${i} || die
+ sed -i -e "/^${i}\$/d" MANIFEST || die
+ done
+
+ myconf="SQLITE_LOCATION=${EPREFIX}/usr"
+}